summaryrefslogtreecommitdiff
path: root/net-analyzer/ttcp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-07 03:12:12 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-07 03:12:12 +0000
commit4e0f61672a4cd8a3d8afc21e9afc2a7acd849976 (patch)
tree20cba6f816bb34fdd956935e64d4432ed2427c65 /net-analyzer/ttcp
parentd479c9c5c724c7b1300a98e44975f31f4f2e51dd (diff)
gentoo auto-resync : 07:12:2022 - 03:12:11
Diffstat (limited to 'net-analyzer/ttcp')
-rw-r--r--net-analyzer/ttcp/Manifest2
-rw-r--r--net-analyzer/ttcp/ttcp-1.12-r3.ebuild (renamed from net-analyzer/ttcp/ttcp-1.12-r2.ebuild)32
2 files changed, 22 insertions, 12 deletions
diff --git a/net-analyzer/ttcp/Manifest b/net-analyzer/ttcp/Manifest
index 45ed518954be..2c6c5e1501ea 100644
--- a/net-analyzer/ttcp/Manifest
+++ b/net-analyzer/ttcp/Manifest
@@ -1,4 +1,4 @@
DIST ttcp-1.12.c 23690 BLAKE2B 972869da1e2e945702e6852648166eefae224b39715ef8495526ec7cd33cdb1e69fa10bb356a96e701f8b597c547b3090956320f947a02f1fad0b12d027b7e32 SHA512 8fc800b05fcf3590d15a87983ac7abc3646c6d4a89f7cc6b91e495066a90a6ce21f7bd7b6ab21e09f07bfa20c39bdc7bcec479449d7cd2b88639dc6cca4a432e
DIST ttcp-1.12.tar.bz2 8086 BLAKE2B 42ec3d82d56ef28527c096be7b6ea568997f0028ebf51811974fec8c444a39785996b0a51eedff6cec6c53f215e4300a3dee91e45f54dbe979d1d1c42e792ab1 SHA512 2218f801a04964dcc684bac2957f892569e4458eb7770e26d4ac5a9a5beebb16b9191cacd8e60cceee306b8fe53000248b52457cb679a3d12ad4308bb0066dbb
-EBUILD ttcp-1.12-r2.ebuild 633 BLAKE2B dd298aa4886a2d70ec6d7969fc0dc4aa08b43d8b680c29364e0746b659477e6f13965a7420e4a0895d84b77dba706be6ffddbb730094a32bb8f654b5a245b49b SHA512 40e90723480e231afb4c3ee51fd791ee672d4c8248d24cdc228986c66a208dba2f09b2ad5dfd04d608fcf8dcd72b7b4cca490a417ef3cffab259cc353e42d476
+EBUILD ttcp-1.12-r3.ebuild 675 BLAKE2B dd4693a4b19738e6e35d11920a9940e6534f162f8bf96412a843ff61fc8fe64856075233c107a7efbd764ed653bc21226301fc32863ce5333fd0b249e3d22ea3 SHA512 5ccae2fb95590310d07d7a17c3617e7f82cdded376cfd7e30881fc08a28fcae653151d957632ae226774b896b711f9ef605e5cc43e14f69a6266feccc45b134e
MISC metadata.xml 277 BLAKE2B 57fc90092c4674e5c4dfe38b0d79c983990fce4e8208b70c2ebb218aebb6d2135537f927115f3a7b7eb8c1ddb596461c17e60acb3e6a11b289796f20f3c80a33 SHA512 5ac67e6beabab60f83ac521249c6d1f021988d522fc86ab12ec98fbaa9d47a50157c10c7b9a39554e66a02b141cdc6dc6669e5e7c9c02c8b36ad404aa790d619
diff --git a/net-analyzer/ttcp/ttcp-1.12-r2.ebuild b/net-analyzer/ttcp/ttcp-1.12-r3.ebuild
index 6ef77f5b49cc..bd4b1e8b315a 100644
--- a/net-analyzer/ttcp/ttcp-1.12-r2.ebuild
+++ b/net-analyzer/ttcp/ttcp-1.12-r3.ebuild
@@ -1,26 +1,36 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
+
inherit toolchain-funcs
DESCRIPTION="Tool to test TCP and UDP throughput"
HOMEPAGE="
http://ftp.arl.mil/~mike/ttcp.html
- http://www.netcore.fi/pekkas/linux/ipv6/
-"
+ http://www.netcore.fi/pekkas/linux/ipv6/"
+SRC_URI="
+ mirror://gentoo/${P}.tar.bz2
+ https://dev.gentoo.org/~jsmolic/distfiles/${P}.c"
+
LICENSE="public-domain"
SLOT="0"
KEYWORDS="~amd64 ~hppa ~mips ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
-SRC_URI="
- mirror://gentoo/${P}.tar.bz2
- https://dev.gentoo.org/~jsmolic/distfiles/${P}.c
-"
+
+src_prepare() {
+ mv "${DISTDIR}"/${P}.c ${PN}.c || die
+ default
+}
+
+src_configure() {
+ tc-export CC
+}
+
src_compile() {
- $(tc-getCC) ${CFLAGS} ${LDFLAGS} -o ${PN} "${DISTDIR}"/${P}.c || die
+ emake ttcp
}
src_install() {
- dobin ${PN}
- newman sgi-${PN}.1 ${PN}.1
+ dobin ttcp
+ newman sgi-ttcp.1 ttcp.1
}