summaryrefslogtreecommitdiff
path: root/net-analyzer/ttcp/ttcp-1.12-r3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/ttcp/ttcp-1.12-r3.ebuild')
-rw-r--r--net-analyzer/ttcp/ttcp-1.12-r3.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/net-analyzer/ttcp/ttcp-1.12-r3.ebuild b/net-analyzer/ttcp/ttcp-1.12-r3.ebuild
new file mode 100644
index 000000000000..bd4b1e8b315a
--- /dev/null
+++ b/net-analyzer/ttcp/ttcp-1.12-r3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Tool to test TCP and UDP throughput"
+HOMEPAGE="
+ http://ftp.arl.mil/~mike/ttcp.html
+ http://www.netcore.fi/pekkas/linux/ipv6/"
+SRC_URI="
+ mirror://gentoo/${P}.tar.bz2
+ https://dev.gentoo.org/~jsmolic/distfiles/${P}.c"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~mips ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+
+src_prepare() {
+ mv "${DISTDIR}"/${P}.c ${PN}.c || die
+ default
+}
+
+src_configure() {
+ tc-export CC
+}
+
+src_compile() {
+ emake ttcp
+}
+
+src_install() {
+ dobin ttcp
+ newman sgi-ttcp.1 ttcp.1
+}