summaryrefslogtreecommitdiff
path: root/media-video/vcdimager
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-12-10 09:09:16 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-12-10 09:09:16 +0000
commitf45955e60d4da9b7f4a1088c98042f9c06669039 (patch)
tree25ff171e8813c8b99f79a424124ed214a9520850 /media-video/vcdimager
parentb9ef7cab6264f1838672efbbcb4ba3b3abd5323f (diff)
gentoo resync : 10.12.2017
Diffstat (limited to 'media-video/vcdimager')
-rw-r--r--media-video/vcdimager/Manifest5
-rw-r--r--media-video/vcdimager/files/vcdimager-0.7.24-libcdio-1.0.0.patch230
-rw-r--r--media-video/vcdimager/vcdimager-0.7.24.ebuild13
3 files changed, 242 insertions, 6 deletions
diff --git a/media-video/vcdimager/Manifest b/media-video/vcdimager/Manifest
index a4d4c585765b..754d2157bba2 100644
--- a/media-video/vcdimager/Manifest
+++ b/media-video/vcdimager/Manifest
@@ -1,3 +1,4 @@
-DIST vcdimager-0.7.24.tar.gz 1066815 SHA256 075d7a67353ff3004745da781435698b6bc4a053838d0d4a3ce0516d7d974694 SHA512 162f361d3c871c85887f0b25e70c207c511dcf597f337633be3ce925e8c589a8ba26275b8378d1002b8c5eb56995eda017f5f1cf52e52a38e9ff900acba7a214 WHIRLPOOL b94f3937415ec1b178484adfc653b1846e9f52ed95fd0677fa5f7b077b345f4cbd3b11526bb9b9011b76f74a916644e9d60dec3ce37571ed97523db04cb5ec42
-EBUILD vcdimager-0.7.24.ebuild 1423 BLAKE2B b6293723049acbcf806cbd8f9dde69c9eb3f6b6747a9dae5cc5d2ec285f8dc0a0085dda12b4b704570fb9fc0b816c67abf9be92f2e0e6e964c1bbe750a916298 SHA512 1377de57d124ebea3bfece0603ad1c213d708f7309e28177c01e8f2add398e9c1128d3a4e20942682ba8af7f32dca134025671276f1de56c520cc8757b0550a1
+AUX vcdimager-0.7.24-libcdio-1.0.0.patch 7545 BLAKE2B 58426bd919e0c0cbe9703a33fc99f9aaaac6b4fa5130d8b39fab505d309741e7c301b2ace213e927a4399cb5b215b1a38b761c3d6ac9a25ddb32cfc7626844b4 SHA512 b49e8742627b6e0d56efd455230f78cb49a3337a376da39d9b77869835c1d34b8f4a826ae0f888fe0f81ce011a3f0e6dcf52479c34813594129fb2916c782c57
+DIST vcdimager-0.7.24.tar.gz 1066815 BLAKE2B b58648a4ab54b3151448c2aa17306105ada45d9708375c7461c7f9087b851339f8288855c0d38d1521317b303c79b432b5e99b39ca7b8f59da8ae7aff7238582 SHA512 162f361d3c871c85887f0b25e70c207c511dcf597f337633be3ce925e8c589a8ba26275b8378d1002b8c5eb56995eda017f5f1cf52e52a38e9ff900acba7a214
+EBUILD vcdimager-0.7.24.ebuild 1494 BLAKE2B d6d71aa03fef4ee2af9c7f160a8218448b4b2eb2f84b64726e5d38ac1a4a0a5f36ca5c69d896354ced7f2cf11b73324c9157ce917413d519b9dd96599c2bb781 SHA512 5800c746da2facc0537f54b40d3a66ed1b9065ae4e2e05cd6713712f366d435c3fe7c5b180642948d97eabd3950b4045ce1652891f69e26fe5a5f8223e72b072
MISC metadata.xml 223 BLAKE2B 1a772bb5add75cb4343b09bb2456adcd5e46896daaab4091ab64b667c5fa1a4adab0940015a3e755df3d6540b456694dc67ef9581d02d40c63b89290f8f83e43 SHA512 27b688917e0b1c4a75ea34c97d2d67d309573941492ab04124de11034f3b2796480f02408d86e2eba77ca2000722ea6606fe12a49622c04f9e2c1fa27b6fc8db
diff --git a/media-video/vcdimager/files/vcdimager-0.7.24-libcdio-1.0.0.patch b/media-video/vcdimager/files/vcdimager-0.7.24-libcdio-1.0.0.patch
new file mode 100644
index 000000000000..477e400f6304
--- /dev/null
+++ b/media-video/vcdimager/files/vcdimager-0.7.24-libcdio-1.0.0.patch
@@ -0,0 +1,230 @@
+diff --git a/frontends/xml/vcd_xml_rip.c b/frontends/xml/vcd_xml_rip.c
+index 3d28065..f1be95d 100644
+--- a/frontends/xml/vcd_xml_rip.c
++++ b/frontends/xml/vcd_xml_rip.c
+@@ -769,7 +769,7 @@ _visit_lot (pbc_ctx_t *p_pbc_ctx)
+ _visit_pbc (p_pbc_ctx, n + 1, tmp, true);
+
+ _vcd_list_sort (p_pbc_ctx->offset_list,
+- (_cdio_list_cmp_func) vcdinf_lid_t_cmp);
++ (_cdio_list_cmp_func_t) vcdinf_lid_t_cmp);
+ }
+
+ static int
+diff --git a/include/libvcd/info.h b/include/libvcd/info.h
+index 2d70940..b62d541 100644
+--- a/include/libvcd/info.h
++++ b/include/libvcd/info.h
+@@ -455,12 +455,12 @@ extern "C" {
+ /*!
+ Get the VCD info list.
+ */
+- CdioList *vcdinfo_get_offset_list(const vcdinfo_obj_t *p_vcdinfo);
++ CdioList_t *vcdinfo_get_offset_list(const vcdinfo_obj_t *p_vcdinfo);
+
+ /*!
+ Get the VCD info extended offset list.
+ */
+- CdioList *vcdinfo_get_offset_x_list(const vcdinfo_obj_t *p_vcdinfo);
++ CdioList_t *vcdinfo_get_offset_x_list(const vcdinfo_obj_t *p_vcdinfo);
+
+ /*!
+ Get the VCD info offset multiplier.
+diff --git a/lib/data_structures.c b/lib/data_structures.c
+index 4415ae1..cef7381 100644
+--- a/lib/data_structures.c
++++ b/lib/data_structures.c
+@@ -58,7 +58,7 @@ struct _CdioListNode
+ /* impl */
+
+ static bool
+-_bubble_sort_iteration (CdioList_t *p_list, _cdio_list_cmp_func cmp_func)
++_bubble_sort_iteration (CdioList_t *p_list, _cdio_list_cmp_func_t cmp_func)
+ {
+ CdioListNode_t **pp_node;
+ bool changed = false;
+@@ -86,7 +86,7 @@ _bubble_sort_iteration (CdioList_t *p_list, _cdio_list_cmp_func cmp_func)
+ return changed;
+ }
+
+-void _vcd_list_sort (CdioList_t *list, _cdio_list_cmp_func cmp_func)
++void _vcd_list_sort (CdioList_t *list, _cdio_list_cmp_func_t cmp_func)
+ {
+ /* fixme -- this is bubble sort -- worst sorting algo... */
+
+@@ -263,7 +263,7 @@ _vcd_tree_node_sort_children (VcdTreeNode_t *p_node,
+ vcd_assert (p_node != NULL);
+
+ if (p_node->children)
+- _vcd_list_sort (p_node->children, (_cdio_list_cmp_func) cmp_func);
++ _vcd_list_sort (p_node->children, (_cdio_list_cmp_func_t) cmp_func);
+ }
+
+ void
+diff --git a/lib/data_structures.h b/lib/data_structures.h
+index d0932a9..eb5ba48 100644
+--- a/lib/data_structures.h
++++ b/lib/data_structures.h
+@@ -28,7 +28,7 @@
+
+ CdioListNode_t *_vcd_list_at (CdioList_t *list, int idx);
+
+-void _vcd_list_sort (CdioList_t *p_list, _cdio_list_cmp_func cmp_func);
++void _vcd_list_sort (CdioList_t *p_list, _cdio_list_cmp_func_t cmp_func);
+
+ /* n-way tree */
+
+diff --git a/lib/dict.h b/lib/dict.h
+index c3e2ce3..fa003f6 100644
+--- a/lib/dict.h
++++ b/lib/dict.h
+@@ -88,7 +88,7 @@ _dict_get_bykey (VcdObj_t *obj, const char key[])
+ vcd_assert (key != NULL);
+
+ node = _cdio_list_find (obj->buffer_dict_list,
+- (_cdio_list_iterfunc) _dict_key_cmp,
++ (_cdio_list_iterfunc_t) _dict_key_cmp,
+ (char *) key);
+
+ if (node)
+@@ -106,7 +106,7 @@ _dict_get_bysector (VcdObj_t *obj, uint32_t sector)
+ vcd_assert (sector != SECTOR_NIL);
+
+ node = _cdio_list_find (obj->buffer_dict_list,
+- (_cdio_list_iterfunc) _dict_sector_cmp,
++ (_cdio_list_iterfunc_t) _dict_sector_cmp,
+ &sector);
+
+ if (node)
+diff --git a/lib/files.c b/lib/files.c
+index 79fa8fe..61e8077 100644
+--- a/lib/files.c
++++ b/lib/files.c
+@@ -634,7 +634,7 @@ get_search_dat_size (const VcdObj_t *p_vcdobj)
+ + (_get_scanpoint_count (p_vcdobj) * sizeof (msf_t));
+ }
+
+-static CdioList *
++static CdioList_t *
+ _make_track_scantable (const VcdObj_t *p_vcdobj)
+ {
+ CdioList_t *p_all_aps = _cdio_list_new ();
+diff --git a/lib/image_bincue.c b/lib/image_bincue.c
+index 69091b3..4e4d460 100644
+--- a/lib/image_bincue.c
++++ b/lib/image_bincue.c
+@@ -88,7 +88,7 @@ _sink_free (void *user_data)
+ }
+
+ static int
+-_set_cuesheet (void *user_data, const CdioList *vcd_cue_list)
++_set_cuesheet (void *user_data, const CdioList_t *vcd_cue_list)
+ {
+ _img_bincue_snk_t *_obj = user_data;
+ CdioListNode_t *node;
+@@ -102,7 +102,7 @@ _set_cuesheet (void *user_data, const CdioList *vcd_cue_list)
+
+ track_no = 0;
+ index_no = 0;
+- _CDIO_LIST_FOREACH (node, (CdioList *) vcd_cue_list)
++ _CDIO_LIST_FOREACH (node, (CdioList_t *) vcd_cue_list)
+ {
+ const vcd_cue_t *_cue = _cdio_list_node_data (node);
+ char *psz_msf;
+diff --git a/lib/info_private.c b/lib/info_private.c
+index 648ef27..53edff7 100644
+--- a/lib/info_private.c
++++ b/lib/info_private.c
+@@ -136,7 +136,7 @@ vcdinf_visit_lot (struct _vcdinf_pbc_ctx *obj)
+ ret &= vcdinf_visit_pbc (obj, n + 1, tmp, true);
+
+ _vcd_list_sort (obj->extended ? obj->offset_x_list : obj->offset_list,
+- (_cdio_list_cmp_func) vcdinf_lid_t_cmp);
++ (_cdio_list_cmp_func_t) vcdinf_lid_t_cmp);
+
+ /* Now really complete the offset table with LIDs. This routine
+ might obviate the need for vcdinf_visit_pbc() or some of it which is
+diff --git a/lib/mpeg.h b/lib/mpeg.h
+index 0425db6..7df668a 100644
+--- a/lib/mpeg.h
++++ b/lib/mpeg.h
+@@ -103,7 +103,7 @@ typedef struct {
+ unsigned vbvsize;
+ bool constrained_flag;
+
+- CdioList *aps_list; /* filled up by vcd_mpeg_source */
++ CdioList_t *aps_list; /* filled up by vcd_mpeg_source */
+ double last_aps_pts; /* temp, see ->packet */
+
+ } shdr[3];
+diff --git a/lib/mpeg_stream.c b/lib/mpeg_stream.c
+index 8384780..2ee3f41 100644
+--- a/lib/mpeg_stream.c
++++ b/lib/mpeg_stream.c
+@@ -270,7 +270,7 @@ vcd_mpeg_source_scan (VcdMpegSource_t *obj, bool strict_aps, bool fix_scan_info,
+ }
+
+ static double
+-_approx_pts (CdioList *aps_list, uint32_t packet_no)
++_approx_pts (CdioList_t *aps_list, uint32_t packet_no)
+ {
+ double retval = 0;
+ CdioListNode_t *node;
+@@ -324,7 +324,7 @@ _set_scan_msf (msf_t *_msf, long lsn)
+
+ static void
+ _fix_scan_info (struct vcd_mpeg_scan_data_t *scan_data_ptr,
+- unsigned packet_no, double pts, CdioList *aps_list)
++ unsigned packet_no, double pts, CdioList_t *aps_list)
+ {
+ CdioListNode_t *node;
+ long _next = -1, _prev = -1, _forw = -1, _back = -1;
+diff --git a/lib/vcd.c b/lib/vcd.c
+index 4936c09..b1545a0 100644
+--- a/lib/vcd.c
++++ b/lib/vcd.c
+@@ -583,7 +583,7 @@ vcd_obj_add_sequence_pause (VcdObj_t *obj, const char sequence_id[],
+ }
+
+ _vcd_list_sort (p_sequence->pause_list,
+- (_cdio_list_cmp_func) _pause_cmp);
++ (_cdio_list_cmp_func_t) _pause_cmp);
+
+ vcd_debug ("added autopause point at %f", pause_time);
+
+@@ -623,7 +623,7 @@ vcd_obj_add_segment_pause (VcdObj_t *p_obj, const char segment_id[],
+ }
+
+ _vcd_list_sort (_segment->pause_list,
+- (_cdio_list_cmp_func) _pause_cmp);
++ (_cdio_list_cmp_func_t) _pause_cmp);
+
+ vcd_debug ("added autopause point at %f", pause_time);
+
+@@ -685,7 +685,7 @@ vcd_obj_add_sequence_entry (VcdObj_t *p_obj, const char sequence_id[],
+ }
+
+ _vcd_list_sort (p_sequence->entry_list,
+- (_cdio_list_cmp_func) _entry_cmp);
++ (_cdio_list_cmp_func_t) _entry_cmp);
+
+ return 0;
+ }
+@@ -1001,7 +1001,7 @@ vcd_obj_add_dir (VcdObj_t *p_obj, const char iso_pathname[])
+ _cdio_list_append (p_obj->custom_dir_list, _iso_pathname);
+
+ _vcd_list_sort (p_obj->custom_dir_list,
+- (_cdio_list_cmp_func) strcmp);
++ (_cdio_list_cmp_func_t) strcmp);
+
+ return 0;
+ }
+@@ -2290,7 +2290,7 @@ vcd_obj_write_image (VcdObj_t *p_obj, VcdImageSink_t *p_image_sink,
+ /* start with meta info */
+
+ {
+- CdioList *p_cue_list;
++ CdioList_t *p_cue_list;
+ vcd_cue_t *p_cue;
+
+ p_cue_list = _cdio_list_new ();
diff --git a/media-video/vcdimager/vcdimager-0.7.24.ebuild b/media-video/vcdimager/vcdimager-0.7.24.ebuild
index 9de4050771a7..7b2ce51b663b 100644
--- a/media-video/vcdimager/vcdimager-0.7.24.ebuild
+++ b/media-video/vcdimager/vcdimager-0.7.24.ebuild
@@ -1,8 +1,9 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-inherit eutils multilib-minimal
+EAPI=6
+
+inherit multilib-minimal
DESCRIPTION="GNU VCDimager"
HOMEPAGE="http://www.vcdimager.org/"
@@ -22,9 +23,13 @@ DEPEND="${RDEPEND}
virtual/pkgconfig
"
-DOCS="AUTHORS BUGS ChangeLog FAQ HACKING NEWS README THANKS TODO"
+DOCS=( AUTHORS BUGS ChangeLog FAQ HACKING NEWS README THANKS TODO )
+
+PATCHES=( "${FILESDIR}/${P}-libcdio-1.0.0.patch" )
src_prepare() {
+ default
+
# Avoid building useless programs. Bug #226249
sed -i \
-e 's/check_PROGRAMS =/check_PROGRAMS +=/' \
@@ -50,6 +55,6 @@ multilib_src_configure() {
}
multilib_src_install_all() {
- prune_libtool_files
+ find "${D}" -name '*.la' -delete
einstalldocs
}