summaryrefslogtreecommitdiff
path: root/media-video/vcdimager/vcdimager-0.7.24.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-video/vcdimager/vcdimager-0.7.24.ebuild')
-rw-r--r--media-video/vcdimager/vcdimager-0.7.24.ebuild13
1 files changed, 9 insertions, 4 deletions
diff --git a/media-video/vcdimager/vcdimager-0.7.24.ebuild b/media-video/vcdimager/vcdimager-0.7.24.ebuild
index 9de4050771a7..7b2ce51b663b 100644
--- a/media-video/vcdimager/vcdimager-0.7.24.ebuild
+++ b/media-video/vcdimager/vcdimager-0.7.24.ebuild
@@ -1,8 +1,9 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-inherit eutils multilib-minimal
+EAPI=6
+
+inherit multilib-minimal
DESCRIPTION="GNU VCDimager"
HOMEPAGE="http://www.vcdimager.org/"
@@ -22,9 +23,13 @@ DEPEND="${RDEPEND}
virtual/pkgconfig
"
-DOCS="AUTHORS BUGS ChangeLog FAQ HACKING NEWS README THANKS TODO"
+DOCS=( AUTHORS BUGS ChangeLog FAQ HACKING NEWS README THANKS TODO )
+
+PATCHES=( "${FILESDIR}/${P}-libcdio-1.0.0.patch" )
src_prepare() {
+ default
+
# Avoid building useless programs. Bug #226249
sed -i \
-e 's/check_PROGRAMS =/check_PROGRAMS +=/' \
@@ -50,6 +55,6 @@ multilib_src_configure() {
}
multilib_src_install_all() {
- prune_libtool_files
+ find "${D}" -name '*.la' -delete
einstalldocs
}