summaryrefslogtreecommitdiff
path: root/media-sound/mp3check
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-06-22 11:40:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-06-22 11:40:06 +0100
commit7a86906b67693cc65671d3e1476835d3a7e13092 (patch)
tree9de1b9e2cf77833183d4e5ffab2e94d0403ef725 /media-sound/mp3check
parentd56d144655e3785864da43c9acb6c228ef9360ae (diff)
gentoo resync : 22.06.2019
Diffstat (limited to 'media-sound/mp3check')
-rw-r--r--media-sound/mp3check/files/mp3check-0.8.7-fix-buildsystem.patch17
-rw-r--r--media-sound/mp3check/files/mp3check-0.8.7-fix-c++14-operator-delete.patch19
2 files changed, 36 insertions, 0 deletions
diff --git a/media-sound/mp3check/files/mp3check-0.8.7-fix-buildsystem.patch b/media-sound/mp3check/files/mp3check-0.8.7-fix-buildsystem.patch
new file mode 100644
index 000000000000..86c69c162c42
--- /dev/null
+++ b/media-sound/mp3check/files/mp3check-0.8.7-fix-buildsystem.patch
@@ -0,0 +1,17 @@
+--- a/Makefile
++++ b/Makefile
+@@ -2,12 +2,10 @@
+ # Please see COPYING for license.
+
+ # --- config ----------------------------------------------------------------
+-WARN = -Wall -W -g
++WARN = -Wall -W
+ #OPT = -O2
+ OPT =
+-CPPFLAGS = $(ADDITIONAL_CPPFLAGS)
+-CXXFLAGS = $(WARN) $(OPT)
+-CXX = g++
++CXXFLAGS += $(WARN)
+ CC = $(CXX)
+
+ # --- default target
diff --git a/media-sound/mp3check/files/mp3check-0.8.7-fix-c++14-operator-delete.patch b/media-sound/mp3check/files/mp3check-0.8.7-fix-c++14-operator-delete.patch
new file mode 100644
index 000000000000..de19421ac57b
--- /dev/null
+++ b/media-sound/mp3check/files/mp3check-0.8.7-fix-c++14-operator-delete.patch
@@ -0,0 +1,19 @@
+https://bugs.gentoo.org/685880
+tstring.cc: In static member function ‘static tstring::Rep* tstring::Rep::create(size_t)’:
+tstring.cc:114:39: error: exception cleanup for this placement new selects non-placement operator delete [-fpermissive]
+ 114 | Rep *p = new (m - 1 - sizeof(Rep)) Rep;
+ | ^~~
+In file included from tstring.cc:26:
+
+--- a/tstring.h
++++ b/tstring.h
+@@ -75,6 +75,9 @@
+ return ::operator new (size + tmem + 1);}
+ static void operator delete (void *p, size_t) {
+ ::operator delete (p); }
++ // Gentoo Bug #685880
++ static void operator delete (void *p) {
++ ::operator delete (p); }
+
+ // create a new representation
+ static Rep *create(size_t tmem);