summaryrefslogtreecommitdiff
path: root/media-sound/grip
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-29 13:20:26 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-29 13:20:26 +0000
commit82020bf7ff936f52f6f1efc646ae374e46b5ed36 (patch)
tree1b1d0c4ea3c8e8d77a6066d8ac29c51cececd1a9 /media-sound/grip
parent0bdb5244708888dfc364e30b08facc0a45281f78 (diff)
gentoo auto-resync : 29:11:2022 - 13:20:25
Diffstat (limited to 'media-sound/grip')
-rw-r--r--media-sound/grip/Manifest2
-rw-r--r--media-sound/grip/grip-4.2.4.ebuild47
2 files changed, 49 insertions, 0 deletions
diff --git a/media-sound/grip/Manifest b/media-sound/grip/Manifest
index 56b394f4d66f..e107d9a4fc07 100644
--- a/media-sound/grip/Manifest
+++ b/media-sound/grip/Manifest
@@ -1,3 +1,5 @@
DIST grip-4.2.3.tar.gz 1210695 BLAKE2B d4b5cde336fd9db3a68d6ded2375d12c0ac42af86b34067d5eb4b3356bead13e3c5fe967a7932ae9f4be418dbf5136a889fecc0362bf453f4b1d92193013f739 SHA512 05b66c363af31835e534547ae5dcb21340a7b3a824e46b337b511a8ddd0bbd161ab16470b658eb1df3887838b391d71702069da9207160a692e1a8ebae0d52e0
+DIST grip-4.2.4.tar.gz 1212479 BLAKE2B 58203a4faca90e8662347a5f67b7e026c2235ed53c5dbfe351faf4027608eb9e9c7b106907f2abb0dfffd4d01da33eeb334d2500c7f359314c003dc881e1a863 SHA512 fdc2808b91df617f4d2447114037c31bd5fa0657aa4ea2453e644b155468971c65a364bb0a3c6ed8ff2ba0e44e7117a51bec3081c7defd590f9fbc802a216bf5
EBUILD grip-4.2.3.ebuild 1077 BLAKE2B 0bd30aad441c24bed4d4c8c8470db29ddda3fb205de881d72284bd3673a7e7d0ae533b72045e8e0e947d0c6d7f1bdb9f63b721207d600420aa8ca2c95c175772 SHA512 30f0cce595c4e88344eb6a2697d8bf455172c41895676d462db5040f19f1f7bad83bbd80fea810196dd8cd4bdc634199f896a857f0de473b0ea45e195209c279
+EBUILD grip-4.2.4.ebuild 1082 BLAKE2B 12619ef9856be9a0662d58bb60eed383b7778b954151128bc21f3eb3a5319bbf4474bb77e107998c773841cc8e4b0fecb80d1a3a9e3207ff2a17fd3962e38be6 SHA512 f41957a65bfcd8a6b1488ab0deae14e7463b05c2cfc244800db83a8b50573463e4b07fc2d0c549a2d9fc170285d37e258127ddadbaf469f626229fdbccfb3a14
MISC metadata.xml 328 BLAKE2B 069257071d00003496464c8990afebb2d35428231b1b787ff65237c6ddf69c40c6f402939696915d781d21c13fd823183e0c2266b26176f9e58ce47324f07bfc SHA512 e6d401ccb1682cf890600714a33d51650901e9c4724b0b08bad99c2c85a17571fb877489e8f4ae33b1db760c5de5f9150ebf4fb6ab50303186402fad624b6d86
diff --git a/media-sound/grip/grip-4.2.4.ebuild b/media-sound/grip/grip-4.2.4.ebuild
new file mode 100644
index 000000000000..09c22db206c4
--- /dev/null
+++ b/media-sound/grip/grip-4.2.4.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit flag-o-matic toolchain-funcs xdg strip-linguas
+
+DESCRIPTION="GTK+ based Audio CD Player/Ripper"
+HOMEPAGE="https://sourceforge.net/projects/grip/"
+SRC_URI="mirror://sourceforge/grip/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="vorbis"
+
+# lame and vorbis-tools are no real RDEPENDs. But without them
+# grip cannot convert ripped files to any format. So use them as
+# a sane default.
+RDEPEND="
+ !app-text/grip
+ dev-libs/glib:2
+ media-libs/id3lib
+ media-sound/cdparanoia
+ media-sound/lame
+ net-misc/curl
+ x11-libs/gtk+:2
+ x11-libs/libX11
+ x11-libs/pango
+ vorbis? ( media-sound/vorbis-tools )
+"
+# gnome-extra/yelp, see bug 416843
+DEPEND="
+ ${RDEPEND}
+ sys-devel/gettext
+"
+BDEPEND="
+ virtual/pkgconfig
+"
+
+src_configure() {
+ # Bug #69536
+ [[ $(tc-arch) == "x86" ]] && append-flags "-mno-sse"
+
+ strip-linguas be bg ca de en en_CA en_GB en_US es fi fr hu it ja nb nl pl_PL pt_BR ru sr vi zh_CN zh_HK zh_TW
+
+ econf
+}