summaryrefslogtreecommitdiff
path: root/media-sound
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-29 13:20:26 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-29 13:20:26 +0000
commit82020bf7ff936f52f6f1efc646ae374e46b5ed36 (patch)
tree1b1d0c4ea3c8e8d77a6066d8ac29c51cececd1a9 /media-sound
parent0bdb5244708888dfc364e30b08facc0a45281f78 (diff)
gentoo auto-resync : 29:11:2022 - 13:20:25
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/Manifest.gzbin56874 -> 56884 bytes
-rw-r--r--media-sound/grip/Manifest2
-rw-r--r--media-sound/grip/grip-4.2.4.ebuild47
-rw-r--r--media-sound/pulseaudio-daemon/Manifest3
-rw-r--r--media-sound/pulseaudio-daemon/files/pulseaudio-16.1-module-combine-sink-load-crash.patch26
-rw-r--r--media-sound/pulseaudio-daemon/files/pulseaudio-16.1-module-combine-sink-unload-crash.patch22
-rw-r--r--media-sound/pulseaudio-daemon/pulseaudio-daemon-16.1-r1.ebuild395
-rw-r--r--media-sound/qtractor/Manifest2
-rw-r--r--media-sound/qtractor/qtractor-0.9.28.ebuild108
9 files changed, 495 insertions, 110 deletions
diff --git a/media-sound/Manifest.gz b/media-sound/Manifest.gz
index b87df85f5ced..ed21a87194b6 100644
--- a/media-sound/Manifest.gz
+++ b/media-sound/Manifest.gz
Binary files differ
diff --git a/media-sound/grip/Manifest b/media-sound/grip/Manifest
index 56b394f4d66f..e107d9a4fc07 100644
--- a/media-sound/grip/Manifest
+++ b/media-sound/grip/Manifest
@@ -1,3 +1,5 @@
DIST grip-4.2.3.tar.gz 1210695 BLAKE2B d4b5cde336fd9db3a68d6ded2375d12c0ac42af86b34067d5eb4b3356bead13e3c5fe967a7932ae9f4be418dbf5136a889fecc0362bf453f4b1d92193013f739 SHA512 05b66c363af31835e534547ae5dcb21340a7b3a824e46b337b511a8ddd0bbd161ab16470b658eb1df3887838b391d71702069da9207160a692e1a8ebae0d52e0
+DIST grip-4.2.4.tar.gz 1212479 BLAKE2B 58203a4faca90e8662347a5f67b7e026c2235ed53c5dbfe351faf4027608eb9e9c7b106907f2abb0dfffd4d01da33eeb334d2500c7f359314c003dc881e1a863 SHA512 fdc2808b91df617f4d2447114037c31bd5fa0657aa4ea2453e644b155468971c65a364bb0a3c6ed8ff2ba0e44e7117a51bec3081c7defd590f9fbc802a216bf5
EBUILD grip-4.2.3.ebuild 1077 BLAKE2B 0bd30aad441c24bed4d4c8c8470db29ddda3fb205de881d72284bd3673a7e7d0ae533b72045e8e0e947d0c6d7f1bdb9f63b721207d600420aa8ca2c95c175772 SHA512 30f0cce595c4e88344eb6a2697d8bf455172c41895676d462db5040f19f1f7bad83bbd80fea810196dd8cd4bdc634199f896a857f0de473b0ea45e195209c279
+EBUILD grip-4.2.4.ebuild 1082 BLAKE2B 12619ef9856be9a0662d58bb60eed383b7778b954151128bc21f3eb3a5319bbf4474bb77e107998c773841cc8e4b0fecb80d1a3a9e3207ff2a17fd3962e38be6 SHA512 f41957a65bfcd8a6b1488ab0deae14e7463b05c2cfc244800db83a8b50573463e4b07fc2d0c549a2d9fc170285d37e258127ddadbaf469f626229fdbccfb3a14
MISC metadata.xml 328 BLAKE2B 069257071d00003496464c8990afebb2d35428231b1b787ff65237c6ddf69c40c6f402939696915d781d21c13fd823183e0c2266b26176f9e58ce47324f07bfc SHA512 e6d401ccb1682cf890600714a33d51650901e9c4724b0b08bad99c2c85a17571fb877489e8f4ae33b1db760c5de5f9150ebf4fb6ab50303186402fad624b6d86
diff --git a/media-sound/grip/grip-4.2.4.ebuild b/media-sound/grip/grip-4.2.4.ebuild
new file mode 100644
index 000000000000..09c22db206c4
--- /dev/null
+++ b/media-sound/grip/grip-4.2.4.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit flag-o-matic toolchain-funcs xdg strip-linguas
+
+DESCRIPTION="GTK+ based Audio CD Player/Ripper"
+HOMEPAGE="https://sourceforge.net/projects/grip/"
+SRC_URI="mirror://sourceforge/grip/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="vorbis"
+
+# lame and vorbis-tools are no real RDEPENDs. But without them
+# grip cannot convert ripped files to any format. So use them as
+# a sane default.
+RDEPEND="
+ !app-text/grip
+ dev-libs/glib:2
+ media-libs/id3lib
+ media-sound/cdparanoia
+ media-sound/lame
+ net-misc/curl
+ x11-libs/gtk+:2
+ x11-libs/libX11
+ x11-libs/pango
+ vorbis? ( media-sound/vorbis-tools )
+"
+# gnome-extra/yelp, see bug 416843
+DEPEND="
+ ${RDEPEND}
+ sys-devel/gettext
+"
+BDEPEND="
+ virtual/pkgconfig
+"
+
+src_configure() {
+ # Bug #69536
+ [[ $(tc-arch) == "x86" ]] && append-flags "-mno-sse"
+
+ strip-linguas be bg ca de en en_CA en_GB en_US es fi fr hu it ja nb nl pl_PL pt_BR ru sr vi zh_CN zh_HK zh_TW
+
+ econf
+}
diff --git a/media-sound/pulseaudio-daemon/Manifest b/media-sound/pulseaudio-daemon/Manifest
index 3dbcbe6d0ab1..67d4d677fdb7 100644
--- a/media-sound/pulseaudio-daemon/Manifest
+++ b/media-sound/pulseaudio-daemon/Manifest
@@ -1,9 +1,12 @@
AUX enable-autospawn.conf 65 BLAKE2B 47e57076b19000ca3c57f0368e453198131c41a5a9c2d0cc8632f0a7ed4e5c992cf93e3c7651c4f3b59ceaf177d4d811bd6774676a2b005ec12259e56d99b4d2 SHA512 61f90b0d19e807a672bd39d190c1102db0b8c46284cf09d4a19b4b96d566633e56a60d21a3a1374e447e8e06496a3aef56bf5ae574337c081e7cf18842458e59
AUX pulseaudio-16.0-optional-module-console-kit.patch 3077 BLAKE2B 3b8abc67478f6c8848a24788bdceeb5bce868bf5214a092c3abbd39a3102679e4b390e56231de0559c8389730a2a75ba21bf4d9f9d942792589c6db66d6eb04d SHA512 bec1a747593d9130bb8cfb05b0894e467c953264879f2a856a420b07ee688640ec2279c136daa825b21e0e7e3bfc3aa1e333487a776d1c7ffb9a6d0293a0502b
+AUX pulseaudio-16.1-module-combine-sink-load-crash.patch 1052 BLAKE2B 09fa471cb40a83bd1969795ed8f7f3b1418efb99e1d79e6135785d4e54f0ebcb44813cf584067f4462b800e18661a508a120521e606687e2a49836020eb0ccf3 SHA512 3817f5267fd8287a7be4004189432601128c10c592fe54e4bdbdbb1a6ddd2fadede82dab047ea6693ef81cb04280e1fa4968d883ce7e03c2646145488f36d52a
+AUX pulseaudio-16.1-module-combine-sink-unload-crash.patch 802 BLAKE2B 4c82bf606bb6b7123d53dac093044e9d74328f7eef616ad2da4a2c37e7dca3223e2ecc1bafd7dfc4b363c5bff20dd915a5f328236389b6dae37a74688fe886e0 SHA512 4cb64be8a41e16cf854d992416bdc25b327ab8adc706e091e20fc6bf35c7161ed798b611db2060a14af5974a987f10931f9086b45bb0b95cd82010ce952e0c80
AUX pulseaudio.conf.d 151 BLAKE2B 99b185b9353259f37f3396c6f2bb56b80cac0159c9c5d06af4b298ad71d9c577dd6b3f0d9097fc95184b14193d0d55252987465ebd93bd0005849a68ce9b428d SHA512 f97ed431e371e43d297b099952bf1e897b243a822183524b8e3ea17e888c08590bb3793e195bc22e3254eae7f2e1fa00204a752638746c4dde825a423f08c24b
AUX pulseaudio.init.d-5 2224 BLAKE2B d7710b77b209391016e9f84b574cdf70636904d7f54caf9297357ebee97e8ae10c54119521ecad99fbef5f1ad341128b06816f8c733faa29d9c44fa8c435008b SHA512 a11d02fd1c6672a7f022e6ef3e3ad8e3a7f2bf50257c38573db0823415c990021a7bf29b1e194d3d9c8a59464673958604086ef519313a4e3a6bd79071397f29
AUX pulseaudio.service 227 BLAKE2B f58fa701152e84f4d52426f6f76b5a01a1a315d09e5fb8e9e57860b44dc63b78b3f1c1629380b4345c53b003c677f729b3959419e8488e37607c56d6a700626a SHA512 567663b231fe7c2682b08b1059cdad1fcb3c4cb01c1b24aed9afb6fb767b30f250b78bbbed48aadfb06c6d1a4963a6db24877d79a1d36c4be2a128b479c086d6
AUX pulseaudio.tmpfiles 36 BLAKE2B 4fe7c88fb35f561b0eb756146db17e37201126b5d7f906c88cdc778c6191f17c799f1db072f09d5a384485830e4d33266c224955bad22081255544642399b2f6 SHA512 f040850d81030ef04e1aa368d333a1ae1b7238adef5772280fc344c3068262d5ab8c9f3edb92db9c443f9d7d21abb27583ea1efc51ed733bbfa43e2edc68dde1
DIST pulseaudio-16.1.tar.xz 1545596 BLAKE2B 535706abcea2cae39834b23c8bdc37f71b0e633de2d8e43ea4425da97a850b57c2f980c318681cbc86cf1e746200609dad41f8b96ecf4568f86d94aa6831c9a1 SHA512 33b0b4292f05e0882f3ec822cf5720414bb34c523d80fe287b9740d6be219787c562e8024c9b0d9e2ee010771ca72c7ae4f27df1bbef9c9cb6bb6a23cbcc412f
+EBUILD pulseaudio-daemon-16.1-r1.ebuild 12321 BLAKE2B 6fdad20a3e41c8e84171f1e284ea831484a8f4464181985d06df0cc19eacfeac7fefa024e026ab9a9517b8719062738edf56d80d653537022d8db0d5d24f061f SHA512 5bbe66e7eb2ddcf2b1a24e95c664cc93ad7bc78bebcc8f24fc603fcb8888cb9850e1bdcde63748efc8825d0e0a5fdd90ba115cd6c48018193300ea2a03a880fc
EBUILD pulseaudio-daemon-16.1.ebuild 12176 BLAKE2B 9191d042a854771890e77a7824365f10c84d4a3fb96d755ec19d4ee63b4074b725712ca4ee48a45453fd59ed931438bf2e88a9b835acbf15bbf5947beade2a51 SHA512 301dad95a0ce492684dddca6d1b4700e1e2dd4a9c607e26fd802cb63f2685748c68848d43aaeaed050897208ad3e83858ffab47a61f90856397fb6d60eabac0e
MISC metadata.xml 3570 BLAKE2B 24d7b24a68f5e832708d9879769f55ec4cf146c47a41b5fa0ff33f63a5a9945736e227c6a6afa106f964fd91eb3b0ee441203c92f312ed835ef2197979b6fda9 SHA512 34aa5503ad5483eeff2f7c4713d96322dedbdd56b7d52a17ba0658aba24aef58239d5ee1943a276555c2508fd3d5e18639ec6417044adad512693fa6c673c5df
diff --git a/media-sound/pulseaudio-daemon/files/pulseaudio-16.1-module-combine-sink-load-crash.patch b/media-sound/pulseaudio-daemon/files/pulseaudio-16.1-module-combine-sink-load-crash.patch
new file mode 100644
index 000000000000..d02c1029f8b0
--- /dev/null
+++ b/media-sound/pulseaudio-daemon/files/pulseaudio-16.1-module-combine-sink-load-crash.patch
@@ -0,0 +1,26 @@
+commit 37c72c20720d6f7fefeeb151f5e10c2cd0dda30e
+Author: Igor V. Kovalenko <igor.v.kovalenko@gmail.com>
+Date: Sun Nov 27 22:30:45 2022 +0300
+
+ module-combine-sink: Do not set up rate adjustment timer at load time
+
+ Rate adjustment timer is set up when combine sink is resumed and relased when
+ combine sink is suspended. Do not create this timer again while module is loaded
+ to prevent duplicate effort causing assertion in time_callback.
+
+ Part-of: <https://gitlab.freedesktop.org/pulseaudio/pulseaudio/-/merge_requests/756>
+
+diff --git a/src/modules/module-combine-sink.c b/src/modules/module-combine-sink.c
+index f98f4820b..4b7690183 100644
+--- a/src/modules/module-combine-sink.c
++++ b/src/modules/module-combine-sink.c
+@@ -1711,9 +1711,6 @@ int pa__init(pa_module*m) {
+ PA_IDXSET_FOREACH(o, u->outputs, idx)
+ output_verify(o);
+
+- if (u->adjust_time > 0)
+- u->time_event = pa_core_rttime_new(m->core, pa_rtclock_now() + u->adjust_time, time_callback, u);
+-
+ pa_modargs_free(ma);
+
+ return 0;
diff --git a/media-sound/pulseaudio-daemon/files/pulseaudio-16.1-module-combine-sink-unload-crash.patch b/media-sound/pulseaudio-daemon/files/pulseaudio-16.1-module-combine-sink-unload-crash.patch
new file mode 100644
index 000000000000..f0cd82dde16e
--- /dev/null
+++ b/media-sound/pulseaudio-daemon/files/pulseaudio-16.1-module-combine-sink-unload-crash.patch
@@ -0,0 +1,22 @@
+commit 0cbbc408aee2b5f2c42280d24dc615405387b5b1
+Author: Igor V. Kovalenko <igor.v.kovalenko@gmail.com>
+Date: Sun Nov 27 19:39:23 2022 +0300
+
+ module-combine-sink: Suspend while unloading to fix crash moving sinks
+
+ Part-of: <https://gitlab.freedesktop.org/pulseaudio/pulseaudio/-/merge_requests/756>
+
+diff --git a/src/modules/module-combine-sink.c b/src/modules/module-combine-sink.c
+index 4b7690183..2ccd9eb13 100644
+--- a/src/modules/module-combine-sink.c
++++ b/src/modules/module-combine-sink.c
+@@ -1733,6 +1733,9 @@ void pa__done(pa_module*m) {
+ if (!(u = m->userdata))
+ return;
+
++ if (u->sink && PA_SINK_IS_LINKED(u->sink->state))
++ pa_sink_suspend(u->sink, true, PA_SUSPEND_UNAVAILABLE);
++
+ pa_strlist_free(u->unlinked_slaves);
+
+ if (u->sink_put_slot)
diff --git a/media-sound/pulseaudio-daemon/pulseaudio-daemon-16.1-r1.ebuild b/media-sound/pulseaudio-daemon/pulseaudio-daemon-16.1-r1.ebuild
new file mode 100644
index 000000000000..8ccca2d552d5
--- /dev/null
+++ b/media-sound/pulseaudio-daemon/pulseaudio-daemon-16.1-r1.ebuild
@@ -0,0 +1,395 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+MY_PV="${PV/_pre*}"
+MY_P="pulseaudio-${MY_PV}"
+inherit bash-completion-r1 gnome2-utils meson optfeature systemd tmpfiles udev
+
+DESCRIPTION="Daemon component of PulseAudio (networked sound server)"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/PulseAudio/"
+
+if [[ ${PV} = 9999 ]]; then
+ inherit git-r3
+ EGIT_BRANCH="master"
+ EGIT_REPO_URI="https://gitlab.freedesktop.org/pulseaudio/pulseaudio"
+else
+ SRC_URI="https://freedesktop.org/software/pulseaudio/releases/${MY_P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+S="${WORKDIR}/${MY_P}"
+
+# libpulse-simple and libpulse link to libpulse-core; this is daemon's
+# library and can link to gdbm and other GPL-only libraries. In this
+# cases, we have a fully GPL-2 package. Leaving the rest of the
+# GPL-forcing USE flags for those who use them.
+LICENSE="!gdbm? ( LGPL-2.1 ) gdbm? ( GPL-2 )"
+
+SLOT="0"
+
+# +alsa-plugin as discussed in bug #519530
+# TODO: Find out why webrtc-aec is + prefixed - there's already the always available speexdsp-aec
+# NOTE: The current ebuild sets +X almost certainly just for the pulseaudio.desktop file
+IUSE="+alsa +alsa-plugin aptx +asyncns bluetooth dbus elogind equalizer fftw +gdbm +glib gstreamer jack ldac lirc
+ofono-headset +orc oss selinux sox ssl systemd system-wide tcpd test +udev valgrind +webrtc-aec +X zeroconf"
+
+RESTRICT="!test? ( test )"
+
+# See "*** BLUEZ support not found (requires D-Bus)" in configure.ac
+# Basically all IUSE are either ${MULTILIB_USEDEP} for client libs or they belong under !daemon ()
+# We duplicate alsa-plugin, {native,ofono}-headset under daemon to let users deal with them at once
+REQUIRED_USE="
+ ?? ( elogind systemd )
+ alsa-plugin? ( alsa )
+ aptx? ( bluetooth )
+ bluetooth? ( dbus )
+ equalizer? ( dbus )
+ ldac? ( bluetooth )
+ ofono-headset? ( bluetooth )
+ udev? ( || ( alsa oss ) )
+ zeroconf? ( dbus )
+"
+
+# NOTE:
+# - libpcre needed in some cases, bug #472228
+# - media-libs/speexdsp is providing echo canceller implementation and used in resampler
+# TODO: libatomic_ops is only needed on some architectures and conditions, and then at runtime too
+gstreamer_deps="
+ media-libs/gst-plugins-base
+ >=media-libs/gstreamer-1.14
+"
+COMMON_DEPEND="
+ ~media-libs/libpulse-${PV}[dbus?,glib?,systemd?,valgrind?,X?]
+ dev-libs/libatomic_ops
+ >=media-libs/libsndfile-1.0.20
+ >=media-libs/speexdsp-1.2
+ || (
+ elibc_glibc? ( virtual/libc )
+ dev-libs/libpcre:3
+ )
+ alsa? ( >=media-libs/alsa-lib-1.0.24 )
+ aptx? ( ${gstreamer_deps} )
+ asyncns? ( >=net-libs/libasyncns-0.1 )
+ bluetooth? (
+ >=net-wireless/bluez-5
+ media-libs/sbc
+ )
+ dev-libs/libltdl
+ sys-kernel/linux-headers
+ >=sys-libs/libcap-2.22-r2
+ dbus? ( >=sys-apps/dbus-1.4.12 )
+ elogind? ( sys-auth/elogind )
+ equalizer? (
+ sci-libs/fftw:3.0=
+ )
+ fftw? (
+ sci-libs/fftw:3.0=
+ )
+ gdbm? ( sys-libs/gdbm:= )
+ glib? ( >=dev-libs/glib-2.28.0:2 )
+ gstreamer? (
+ ${gstreamer_deps}
+ >=dev-libs/glib-2.26.0:2
+ )
+ jack? ( virtual/jack )
+ ldac? ( ${gstreamer_deps} )
+ lirc? ( app-misc/lirc )
+ ofono-headset? ( >=net-misc/ofono-1.13 )
+ orc? ( >=dev-lang/orc-0.4.15 )
+ selinux? ( sec-policy/selinux-pulseaudio )
+ sox? ( >=media-libs/soxr-0.1.1 )
+ ssl? ( dev-libs/openssl:= )
+ systemd? ( sys-apps/systemd:= )
+ tcpd? ( sys-apps/tcp-wrappers )
+ udev? ( >=virtual/udev-143[hwdb(+)] )
+ valgrind? ( dev-util/valgrind )
+ webrtc-aec? ( >=media-libs/webrtc-audio-processing-0.2:0 )
+ X? (
+ >=x11-libs/libxcb-1.6
+ x11-libs/libICE
+ x11-libs/libSM
+ >=x11-libs/libX11-1.4.0
+ >=x11-libs/libXtst-1.0.99.2
+ )
+ zeroconf? ( >=net-dns/avahi-0.6.12[dbus] )
+ !<media-sound/pulseaudio-15.0-r100
+"
+
+# pulseaudio ships a bundle xmltoman, which uses XML::Parser
+DEPEND="
+ ${COMMON_DEPEND}
+ test? ( >=dev-libs/check-0.9.10 )
+ X? ( x11-base/xorg-proto )
+"
+
+# alsa-utils dep is for the alsasound init.d script (see bug 155707); TODO: read it
+# NOTE: Only system-wide needs acct-group/audio unless elogind/systemd is not used
+RDEPEND="
+ ${COMMON_DEPEND}
+ system-wide? (
+ alsa? ( media-sound/alsa-utils )
+ acct-user/pulse
+ acct-group/audio
+ acct-group/pulse-access
+ )
+ bluetooth? (
+ ldac? ( media-plugins/gst-plugins-ldac )
+ aptx? ( media-plugins/gst-plugins-openaptx )
+ )
+ !media-video/pipewire[sound-server(+)]
+"
+unset gstreamer_deps
+
+# This is a PDEPEND to avoid a circular dep
+PDEPEND="
+ alsa? ( alsa-plugin? ( >=media-plugins/alsa-plugins-1.0.27-r1[pulseaudio] ) )
+"
+
+BDEPEND="
+ dev-lang/perl
+ dev-perl/XML-Parser
+ sys-devel/gettext
+ virtual/libiconv
+ virtual/libintl
+ virtual/pkgconfig
+ orc? ( >=dev-lang/orc-0.4.15 )
+ system-wide? ( dev-util/unifdef )
+"
+
+DOCS=( NEWS README )
+
+S="${WORKDIR}/${MY_P}"
+
+# patches merged upstream, to be removed with 16.2 or later bump
+PATCHES=(
+ "${FILESDIR}"/pulseaudio-16.0-optional-module-console-kit.patch
+ "${FILESDIR}"/pulseaudio-16.1-module-combine-sink-load-crash.patch
+ "${FILESDIR}"/pulseaudio-16.1-module-combine-sink-unload-crash.patch
+)
+
+src_prepare() {
+ default
+
+ gnome2_environment_reset
+}
+
+src_configure() {
+ local enable_bluez5_gstreamer="disabled"
+ if use aptx || use ldac ; then
+ enable_bluez5_gstreamer="enabled"
+ fi
+
+ local enable_fftw="disabled"
+ if use equalizer || use fftw ; then
+ enable_fftw="enabled"
+ fi
+
+ local emesonargs=(
+ --localstatedir="${EPREFIX}"/var
+
+ -Ddaemon=true
+ -Dclient=false
+ -Ddoxygen=false
+ -Dgcov=false
+ -Dman=true
+ # tests involve random modules, so just do them for the native # TODO: tests should run always
+ $(meson_use test tests)
+ -Ddatabase=$(usex gdbm gdbm simple) # tdb is also an option but no one cares about it
+ -Dstream-restore-clear-old-devices=true
+ -Drunning-from-build-tree=false
+
+ # Paths
+ -Dmodlibexecdir="${EPREFIX}/usr/$(get_libdir)/pulseaudio/modules" # Was $(get_libdir)/${P}
+ -Dsystemduserunitdir=$(systemd_get_userunitdir)
+ -Dudevrulesdir="${EPREFIX}$(get_udevdir)/rules.d"
+ -Dbashcompletiondir="$(get_bashcompdir)" # Alternatively DEPEND on app-shells/bash-completion for pkg-config to provide the value
+
+ # Optional features
+ $(meson_feature alsa)
+ $(meson_feature asyncns)
+ $(meson_feature zeroconf avahi)
+ $(meson_feature bluetooth bluez5)
+ -Dbluez5-gstreamer=${enable_bluez5_gstreamer}
+ $(meson_use bluetooth bluez5-native-headset)
+ $(meson_use ofono-headset bluez5-ofono-headset)
+ -Dconsolekit=disabled
+ $(meson_feature dbus)
+ $(meson_feature elogind)
+ -Dfftw=${enable_fftw}
+ $(meson_feature glib) # WARNING: toggling this likely changes ABI
+ $(meson_feature glib gsettings) # Supposedly correct?
+ $(meson_feature gstreamer)
+ -Dgtk=disabled
+ -Dhal-compat=false
+ -Dipv6=true
+ $(meson_feature jack)
+ $(meson_feature lirc)
+ $(meson_feature ssl openssl)
+ $(meson_feature orc)
+ $(meson_feature oss oss-output)
+ -Dsamplerate=disabled # Matches upstream
+ $(meson_feature sox soxr)
+ -Dspeex=enabled
+ $(meson_feature systemd)
+ $(meson_feature tcpd tcpwrap)
+ $(meson_feature udev)
+ $(meson_feature valgrind)
+ $(meson_feature X x11)
+
+ # Echo cancellation
+ -Dadrian-aec=false # Not packaged?
+ $(meson_feature webrtc-aec)
+ )
+
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+
+ # Upstream installs 'pactl' if client is built, with all symlinks except for
+ # 'pulseaudio', 'pacmd' and 'pasuspender' which are installed if server is built.
+ # This trips QA warning, workaround:
+ # - install missing aliases in media-libs/libpulse (client build)
+ # - remove corresponding symlinks in media-sound/pulseaudio-daemonclient (server build)
+ rm "${D}/$(get_bashcompdir)"/pulseaudio || die
+ rm "${D}/$(get_bashcompdir)"/pacmd || die
+ rm "${D}/$(get_bashcompdir)"/pasuspender || die
+
+ # Daemon configuration scripts will try to load snippets from corresponding '.d' dirs.
+ # Install these dirs to silence a warning if they are missing.
+ keepdir /etc/pulse/default.pa.d
+ keepdir /etc/pulse/system.pa.d
+
+ if use system-wide; then
+ newconfd "${FILESDIR}"/pulseaudio.conf.d pulseaudio
+
+ use_define() {
+ local define=${2:-$(echo ${1} | tr '[:lower:]' '[:upper:]')}
+
+ use "${1}" && echo "-D${define}" || echo "-U${define}"
+ }
+
+ unifdef -x 1 \
+ $(use_define zeroconf AVAHI) \
+ $(use_define alsa) \
+ $(use_define bluetooth) \
+ $(use_define udev) \
+ "${FILESDIR}"/pulseaudio.init.d-5 \
+ > "${T}"/pulseaudio \
+ || die
+
+ doinitd "${T}"/pulseaudio
+
+ systemd_dounit "${FILESDIR}"/pulseaudio.service
+
+ # We need /var/run/pulse, bug 442852
+ newtmpfiles "${FILESDIR}"/pulseaudio.tmpfiles pulseaudio.conf
+ else
+ # Prevent warnings when system-wide is not used, bug 447694
+ if use dbus; then
+ rm "${ED}"/etc/dbus-1/system.d/pulseaudio-system.conf || die
+ fi
+ fi
+
+ if use zeroconf; then
+ sed -i \
+ -e '/module-zeroconf-publish/s:^#::' \
+ "${ED}/etc/pulse/default.pa" \
+ || die
+ fi
+
+ # Only enable autospawning pulseaudio daemon on systems without systemd
+ if ! use systemd; then
+ insinto /etc/pulse/client.conf.d
+ newins "${FILESDIR}/enable-autospawn.conf" "enable-autospawn.conf"
+ fi
+
+ find "${ED}" \( -name '*.a' -o -name '*.la' \) -delete || die
+}
+
+pkg_postinst() {
+ gnome2_schemas_update
+
+ use udev && udev_reload
+
+ if use system-wide; then
+ tmpfiles_process "pulseaudio.conf"
+
+ elog "You have enabled the 'system-wide' USE flag for pulseaudio."
+ elog "This mode should only be used on headless servers, embedded systems,"
+ elog "or thin clients. It will usually require manual configuration, and is"
+ elog "incompatible with many expected pulseaudio features."
+ elog "On normal desktop systems, system-wide mode is STRONGLY DISCOURAGED."
+ elog ""
+ elog "For more information, see"
+ elog " https://www.freedesktop.org/wiki/Software/PulseAudio/Documentation/User/WhatIsWrongWithSystemWide/"
+ elog " https://www.freedesktop.org/wiki/Software/PulseAudio/Documentation/User/SystemWide/"
+ elog " https://wiki.gentoo.org/wiki/PulseAudio#Headless_server"
+ elog ""
+ fi
+
+ if use equalizer; then
+ elog "You will need to load some extra modules to make qpaeq work."
+ elog "You can do that by adding the following two lines in"
+ elog "/etc/pulse/default.pa and restarting pulseaudio:"
+ elog "load-module module-equalizer-sink"
+ elog "load-module module-dbus-protocol"
+ elog ""
+ fi
+
+ if use bluetooth; then
+ elog "You have enabled bluetooth USE flag for pulseaudio. Daemon will now handle"
+ elog "bluetooth Headset (HSP HS and HSP AG) and Handsfree (HFP HF) profiles using"
+ elog "native headset backend by default. This can be selectively disabled"
+ elog "via runtime configuration arguments to module-bluetooth-discover"
+ elog "in /etc/pulse/default.pa"
+ elog "To disable HFP HF append enable_native_hfp_hf=false"
+ elog "To disable HSP HS append enable_native_hsp_hs=false"
+ elog "To disable HSP AG append headset=auto or headset=ofono"
+ elog "(note this does NOT require enabling USE ofono)"
+ elog ""
+ fi
+
+ if use ofono-headset; then
+ elog "You have enabled both native and ofono headset profiles. The runtime decision"
+ elog "which to use is done via the 'headset' argument of module-bluetooth-discover."
+ elog ""
+ fi
+
+ if use gstreamer; then
+ elog "GStreamer-based RTP implementation modile enabled."
+ elog "To use OPUS payload install media-plugins/gst-plugins-opus"
+ elog "and add enable_opus=1 argument to module-rtp-send"
+ elog ""
+ fi
+
+ if use systemd; then
+ elog "Pulseaudio autospawn by client library is no longer enabled when systemd is available."
+ elog "It's recommended to start pulseaudio via its systemd user units:"
+ elog ""
+ elog " systemctl --user enable pulseaudio.service pulseaudio.socket"
+ elog ""
+ elog "Root user can change system default configuration for all users:"
+ elog ""
+ elog " systemctl --global enable pulseaudio.service pulseaudio.socket"
+ elog ""
+ elog "If you would like to enable autospawn by client library, edit autospawn flag in /etc/pulse/client.conf like this:"
+ elog ""
+ elog " autospawn = yes"
+ elog ""
+ elog "The change from autospawn to user units will take effect after restarting."
+ elog ""
+ fi
+
+ optfeature_header "PulseAudio can be enhanced by installing the following:"
+ use equalizer && optfeature "using the qpaeq script" dev-python/PyQt5[dbus,widgets]
+ use dbus && optfeature "restricted realtime capabilities via D-Bus" sys-auth/rtkit
+}
+
+pkg_postrm() {
+ gnome2_schemas_update
+ use udev && udev_reload
+}
diff --git a/media-sound/qtractor/Manifest b/media-sound/qtractor/Manifest
index cfe9c394a65f..565278159a9a 100644
--- a/media-sound/qtractor/Manifest
+++ b/media-sound/qtractor/Manifest
@@ -1,5 +1,3 @@
-DIST qtractor-0.9.28.tar.gz 2000685 BLAKE2B aa0d71732b9d214da22a97ca15d0c54eb61b7c35656f827bd0e39f5b55981b0c0d29645d5d3c4280ccba6aab971171615ef099f1cea1f3a8c381ac0dfffd2ca8 SHA512 db63766bcfd5a744a532d68cbe6f3153f9dd02208bca5098b27cda1cbec694b2981b3eb6a7912324c07327c000087cb5f5ba46dccc96398d051e011ce563fc67
DIST qtractor-0.9.29.tar.gz 1988719 BLAKE2B d7f17211e885c8458c7d74d1cd0cde69d316b1765ab79bdfb3ff1abcfb35ad008f017dd12372a2fafb309a7bead0c3d31f8f1cc322da123d39760377c1883e82 SHA512 bd432e3eb2d804aacc45943c36160c938778827a1c832f30045b2456d363843ac2f77e4b2cb897b905aa026b7d9238eb2963ca1ebbd64d127d890857c5426c41
-EBUILD qtractor-0.9.28.ebuild 2503 BLAKE2B 82e268d7cc532cfa54937bf76cce36751f546ceb924d5cf07908f0423529ed93a4c3ed526a17ae472781b26a04977da2f0892656516ba3da906bbb981f87c5c1 SHA512 a029c76b6386ff1e10eddefa0738591a51b60b0564266f5defe2a26c6aeb25d2b6719c62a97396cfb5e1df7a49ee25dc6212bd5835b7afaae55605ccb891d912
EBUILD qtractor-0.9.29.ebuild 2503 BLAKE2B 82e268d7cc532cfa54937bf76cce36751f546ceb924d5cf07908f0423529ed93a4c3ed526a17ae472781b26a04977da2f0892656516ba3da906bbb981f87c5c1 SHA512 a029c76b6386ff1e10eddefa0738591a51b60b0564266f5defe2a26c6aeb25d2b6719c62a97396cfb5e1df7a49ee25dc6212bd5835b7afaae55605ccb891d912
MISC metadata.xml 891 BLAKE2B c85e76d86b5e559e2de880a440e8bdddfb8d67de2b7216a42ebb1ec7cce7b9a4dc8ccf20732e4b4ea489a14fcf5584aecef193e9fe3ac2bb0159011002607a60 SHA512 fcc0f8b61f0b9d9fd3d49c5f00f46b739012a6e8e4f7664bf08ae277b279d282d11056f9ca986788a7e444da53a17aeab46c2ee30fa945eb54dd271b11cf4a55
diff --git a/media-sound/qtractor/qtractor-0.9.28.ebuild b/media-sound/qtractor/qtractor-0.9.28.ebuild
deleted file mode 100644
index 57db29bd6746..000000000000
--- a/media-sound/qtractor/qtractor-0.9.28.ebuild
+++ /dev/null
@@ -1,108 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake xdg
-
-DESCRIPTION="Audio/MIDI multi-track sequencer written in C++ with the Qt framework"
-HOMEPAGE="https://qtractor.sourceforge.io"
-SRC_URI="mirror://sourceforge/qtractor/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86"
-
-IUSE="aubio cpu_flags_x86_sse debug dssi ladspa libsamplerate mad osc rubberband vorbis zlib"
-REQUIRED_USE="dssi? ( ladspa )"
-
-BDEPEND="
- dev-qt/linguist-tools:5
- virtual/pkgconfig
-"
-DEPEND="
- dev-qt/qtcore:5
- dev-qt/qtgui:5
- dev-qt/qtsvg:5
- dev-qt/qtwidgets:5
- dev-qt/qtxml:5
- dev-qt/qtx11extras:5
- media-libs/alsa-lib
- media-libs/libsndfile
- media-libs/lilv
- media-libs/lv2
- media-libs/suil
- virtual/jack
- x11-libs/libxcb:=
- aubio? ( media-libs/aubio:= )
- dssi? ( media-libs/dssi )
- ladspa? ( media-libs/ladspa-sdk )
- libsamplerate? ( media-libs/libsamplerate )
- mad? ( media-libs/libmad )
- osc? ( media-libs/liblo )
- rubberband? ( media-libs/rubberband )
- vorbis? (
- media-libs/libogg
- media-libs/libvorbis
- )
- zlib? ( sys-libs/zlib )
-"
-RDEPEND="${DEPEND}"
-
-src_prepare() {
- cmake_src_prepare
-}
-
-src_configure() {
- local mycmakeargs=(
- -DCONFIG_DSSI=$(usex dssi 1 0)
- -DCONFIG_GRADIENT=1
- -DCONFIG_JACK_LATENCY=1
- -DCONFIG_JACK_METADATA=1
- -DCONFIG_JACK_SESSION=1
- -DCONFIG_LADSPA=$(usex ladspa 1 0)
- -DCONFIG_LIBAUBIO=$(usex aubio 1 0)
- -DCONFIG_LIBLILV=1
- -DCONFIG_LIBLO=$(usex osc 1 0)
- -DCONFIG_LIBMAD=$(usex mad 1 0)
- -DCONFIG_LIBRUBBERBAND=$(usex rubberband 1 0)
- -DCONFIG_LIBSAMPLERATE=$(usex libsamplerate 1 0)
- -DCONFIG_LIBVORBIS=$(usex vorbis 1 0)
- -DCONFIG_LIBZ=$(usex zlib 1 0)
- -DCONFIG_LV2=1
- -DCONFIG_LV2_UI_GTK2=0
- -DCONFIG_NSM=0
- -DCONFIG_SSE=$(usex cpu_flags_x86_sse 1 0)
- -DCONFIG_STACKTRACE=$(usex debug 1 0)
- -DCONFIG_VESTIGE=1
- -DCONFIG_VST=1
- -DCONFIG_VST3=0
- -DCONFIG_XUNIQUE=0
- )
- # Following options are left to the default
- # CONFIG_LV2_ATOM
- # CONFIG_LV2_BUF_SIZE
- # CONFIG_LV2_CVPORT
- # CONFIG_LV2_EVENT
- # CONFIG_LV2_EXTERNAL_UI
- # CONFIG_LV2_MIDNAM
- # CONFIG_LV2_OPTIONS
- # CONFIG_LV2_PARAMETERS
- # CONFIG_LV2_PATCH
- # CONFIG_LV2_PORT_EVENT
- # CONFIG_LV2_PRESETS
- # CONFIG_LV2_PROGRAMS
- # CONFIG_LV2_STATE
- # CONFIG_LV2_STATE_FILES
- # CONFIG_LV2_STATE_MAKE_PATH
- # CONFIG_LV2_TIME
- # CONFIG_LV2_TIME_POSITION
- # CONFIG_LV2_UI
- # CONFIG_LV2_UI_IDLE
- # CONFIG_LV2_UI_REQ_VALUE
- # CONFIG_LV2_UI_SHOW
- # CONFIG_LV2_UI_TOUCH
- # CONFIG_LV2_WORKER
- # CONFIG_LV2_UI_X11
- cmake_src_configure
-}