summaryrefslogtreecommitdiff
path: root/media-sound/fluidsynth
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-26 18:57:55 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-26 18:57:55 +0000
commitdd8cf418a044466cd5a1239059d5d21744f73f14 (patch)
tree0d4b5a88a46cdc31e1f7f8f302ac8114e3f94a9d /media-sound/fluidsynth
parent6887f21af5af228689c7587c4adf37baa07d563f (diff)
gentoo auto-resync : 26:01:2024 - 18:57:55
Diffstat (limited to 'media-sound/fluidsynth')
-rw-r--r--media-sound/fluidsynth/Manifest2
-rw-r--r--media-sound/fluidsynth/fluidsynth-2.3.4-r1.ebuild (renamed from media-sound/fluidsynth/fluidsynth-2.3.4.ebuild)42
2 files changed, 36 insertions, 8 deletions
diff --git a/media-sound/fluidsynth/Manifest b/media-sound/fluidsynth/Manifest
index 9b66e677d13d..29b2b835a1c3 100644
--- a/media-sound/fluidsynth/Manifest
+++ b/media-sound/fluidsynth/Manifest
@@ -1,3 +1,3 @@
DIST fluidsynth-2.3.4.tar.gz 1775291 BLAKE2B 5146c1f0243ac1fcc3d4f29ea65bb03b326c59bf9de1f53def447f4a924c7fdde31f8b33300051d2e7765087fb8bbdba3643b03c537e3366b02ca42b3b9d4311 SHA512 79891116d78b9be1c38bce9e5759b9bb732c3d8ee31c6e57d1a3e2b5548879b91d19582e73ee7fb0fd243beba3bf1bbc341a26aab0b6440eef36fc55dce3e8b0
-EBUILD fluidsynth-2.3.4.ebuild 3450 BLAKE2B 392ce61e1a306ba8f185deaadc2ad9f6a8ef18d670b7003d29ecccfd9da880e5606c507250cd040060692a626fec5cfa4637630be4d6f35c0686198046b74287 SHA512 e1d051a699fb8f38e9210916ac596ffce0cc421ac810a9b4be1763451712101fb38a7b29d5d73e5f4ebb269dcf73032dcd9283ba9c171ad662abb94e129a4e1e
+EBUILD fluidsynth-2.3.4-r1.ebuild 4017 BLAKE2B 12a779cdbca3bcb05c428d57a9f063634cc72870f0baf954096af7b3235ea284d0971054e0721194570a28777172ac4bd49b657882182569fe12a01a5c85d3fb SHA512 f83ce5a5250de7153e4407878ba1af8baf46ded702a009b75ecebb0c352ac6530891e73f38bfe89975d0abef5d973c73f0d58d20d49b21a3359afff4d036c78f
MISC metadata.xml 509 BLAKE2B f94b91d9486a14757aa47e69269d6321fb330556f24ac0d2d47d7734bc28164d9cff5d7ff7728aa6d59606006bc4bfa090662b9dd087a6bf36ae23660604938a SHA512 7bf5aeb69570ef736dc6a1a3d652449b0142978ee5e6ed9902d4f851deea87c8fb94bee821ee9ae93bc529411f336288021718490e86c2815de5d30111bd3b28
diff --git a/media-sound/fluidsynth/fluidsynth-2.3.4.ebuild b/media-sound/fluidsynth/fluidsynth-2.3.4-r1.ebuild
index 96ebeb8f21dd..936c864a0e52 100644
--- a/media-sound/fluidsynth/fluidsynth-2.3.4.ebuild
+++ b/media-sound/fluidsynth/fluidsynth-2.3.4-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit cmake-multilib systemd toolchain-funcs
+inherit cmake-multilib multibuild systemd toolchain-funcs
DESCRIPTION="Software real-time synthesizer based on the Soundfont 2 specifications"
HOMEPAGE="https://www.fluidsynth.org"
@@ -12,10 +12,14 @@ SRC_URI="https://github.com/FluidSynth/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.g
LICENSE="LGPL-2.1+"
SLOT="0/3"
KEYWORDS="~alpha amd64 arm arm64 ~hppa ~loong ppc ppc64 ~riscv sparc x86"
-IUSE="alsa dbus debug examples ipv6 jack ladspa lash network oss pipewire portaudio pulseaudio +readline sdl +sndfile systemd threads"
+IUSE="alsa dbus debug doc ipv6 jack ladspa lash network oss pipewire portaudio pulseaudio +readline sdl +sndfile systemd threads"
BDEPEND="
virtual/pkgconfig
+ doc? (
+ app-text/doxygen
+ dev-libs/libxslt
+ )
"
DEPEND="
dev-libs/glib:2[${MULTILIB_USEDEP}]
@@ -42,9 +46,15 @@ RDEPEND="${DEPEND}"
DOCS=( AUTHORS ChangeLog README.md THANKS TODO doc/fluidsynth-v20-devdoc.txt )
+src_prepare() {
+ # https://bugs.gentoo.org/833979#c17
+ sed -i "/CONFIGURE_COMMAND/{n;s/$/ -DCMAKE_C_COMPILER=$(tc-getBUILD_CC)/}" \
+ src/CMakeLists.txt || die
+ cmake_src_prepare
+}
+
src_configure() {
local mycmakeargs=(
- -DCMAKE_C_COMPILER="$(tc-getCC)"
-Denable-alsa=$(usex alsa)
-Denable-aufile=ON
-Denable-dbus=$(usex dbus)
@@ -73,6 +83,7 @@ src_configure() {
-Denable-ubsan=OFF # compile and link against UBSan (for debugging fluidsynth internals)
-Denable-waveout=OFF # Windows
-Denable-winmidi=OFF # Windows
+ $(cmake_use_find_package doc Doxygen)
)
if use alsa; then
@@ -88,6 +99,22 @@ src_configure() {
cmake-multilib_src_configure
}
+compile_doxygen_doc() {
+ multilib_is_native_abi && cmake_build doxygen
+}
+
+src_compile() {
+ cmake-multilib_src_compile
+ use doc && multilib_foreach_abi compile_doxygen_doc
+}
+
+install_doxygen_doc() {
+ if multilib_is_native_abi; then
+ docinto .
+ dodoc -r "${BUILD_DIR}/doc/api/html"
+ fi
+}
+
install_systemd_files() {
if multilib_is_native_abi; then
systemd_dounit "${BUILD_DIR}/fluidsynth.service"
@@ -106,11 +133,12 @@ src_install() {
docinto pdf
dodoc doc/*.pdf
- if use examples; then
- docinto examples
- dodoc doc/examples/*.c
- fi
+ docinto examples
+ dodoc doc/examples/*.c
+ if use doc; then
+ multilib_foreach_abi install_doxygen_doc
+ fi
if use systemd; then
multilib_foreach_abi install_systemd_files