summaryrefslogtreecommitdiff
path: root/media-sound
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-26 18:57:55 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-26 18:57:55 +0000
commitdd8cf418a044466cd5a1239059d5d21744f73f14 (patch)
tree0d4b5a88a46cdc31e1f7f8f302ac8114e3f94a9d /media-sound
parent6887f21af5af228689c7587c4adf37baa07d563f (diff)
gentoo auto-resync : 26:01:2024 - 18:57:55
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/Manifest.gzbin57734 -> 57721 bytes
-rw-r--r--media-sound/fluidsynth/Manifest2
-rw-r--r--media-sound/fluidsynth/fluidsynth-2.3.4-r1.ebuild (renamed from media-sound/fluidsynth/fluidsynth-2.3.4.ebuild)42
-rw-r--r--media-sound/picard/Manifest2
-rw-r--r--media-sound/picard/picard-2.11.ebuild65
5 files changed, 103 insertions, 8 deletions
diff --git a/media-sound/Manifest.gz b/media-sound/Manifest.gz
index 9071f5f2e799..3894aa324207 100644
--- a/media-sound/Manifest.gz
+++ b/media-sound/Manifest.gz
Binary files differ
diff --git a/media-sound/fluidsynth/Manifest b/media-sound/fluidsynth/Manifest
index 9b66e677d13d..29b2b835a1c3 100644
--- a/media-sound/fluidsynth/Manifest
+++ b/media-sound/fluidsynth/Manifest
@@ -1,3 +1,3 @@
DIST fluidsynth-2.3.4.tar.gz 1775291 BLAKE2B 5146c1f0243ac1fcc3d4f29ea65bb03b326c59bf9de1f53def447f4a924c7fdde31f8b33300051d2e7765087fb8bbdba3643b03c537e3366b02ca42b3b9d4311 SHA512 79891116d78b9be1c38bce9e5759b9bb732c3d8ee31c6e57d1a3e2b5548879b91d19582e73ee7fb0fd243beba3bf1bbc341a26aab0b6440eef36fc55dce3e8b0
-EBUILD fluidsynth-2.3.4.ebuild 3450 BLAKE2B 392ce61e1a306ba8f185deaadc2ad9f6a8ef18d670b7003d29ecccfd9da880e5606c507250cd040060692a626fec5cfa4637630be4d6f35c0686198046b74287 SHA512 e1d051a699fb8f38e9210916ac596ffce0cc421ac810a9b4be1763451712101fb38a7b29d5d73e5f4ebb269dcf73032dcd9283ba9c171ad662abb94e129a4e1e
+EBUILD fluidsynth-2.3.4-r1.ebuild 4017 BLAKE2B 12a779cdbca3bcb05c428d57a9f063634cc72870f0baf954096af7b3235ea284d0971054e0721194570a28777172ac4bd49b657882182569fe12a01a5c85d3fb SHA512 f83ce5a5250de7153e4407878ba1af8baf46ded702a009b75ecebb0c352ac6530891e73f38bfe89975d0abef5d973c73f0d58d20d49b21a3359afff4d036c78f
MISC metadata.xml 509 BLAKE2B f94b91d9486a14757aa47e69269d6321fb330556f24ac0d2d47d7734bc28164d9cff5d7ff7728aa6d59606006bc4bfa090662b9dd087a6bf36ae23660604938a SHA512 7bf5aeb69570ef736dc6a1a3d652449b0142978ee5e6ed9902d4f851deea87c8fb94bee821ee9ae93bc529411f336288021718490e86c2815de5d30111bd3b28
diff --git a/media-sound/fluidsynth/fluidsynth-2.3.4.ebuild b/media-sound/fluidsynth/fluidsynth-2.3.4-r1.ebuild
index 96ebeb8f21dd..936c864a0e52 100644
--- a/media-sound/fluidsynth/fluidsynth-2.3.4.ebuild
+++ b/media-sound/fluidsynth/fluidsynth-2.3.4-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit cmake-multilib systemd toolchain-funcs
+inherit cmake-multilib multibuild systemd toolchain-funcs
DESCRIPTION="Software real-time synthesizer based on the Soundfont 2 specifications"
HOMEPAGE="https://www.fluidsynth.org"
@@ -12,10 +12,14 @@ SRC_URI="https://github.com/FluidSynth/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.g
LICENSE="LGPL-2.1+"
SLOT="0/3"
KEYWORDS="~alpha amd64 arm arm64 ~hppa ~loong ppc ppc64 ~riscv sparc x86"
-IUSE="alsa dbus debug examples ipv6 jack ladspa lash network oss pipewire portaudio pulseaudio +readline sdl +sndfile systemd threads"
+IUSE="alsa dbus debug doc ipv6 jack ladspa lash network oss pipewire portaudio pulseaudio +readline sdl +sndfile systemd threads"
BDEPEND="
virtual/pkgconfig
+ doc? (
+ app-text/doxygen
+ dev-libs/libxslt
+ )
"
DEPEND="
dev-libs/glib:2[${MULTILIB_USEDEP}]
@@ -42,9 +46,15 @@ RDEPEND="${DEPEND}"
DOCS=( AUTHORS ChangeLog README.md THANKS TODO doc/fluidsynth-v20-devdoc.txt )
+src_prepare() {
+ # https://bugs.gentoo.org/833979#c17
+ sed -i "/CONFIGURE_COMMAND/{n;s/$/ -DCMAKE_C_COMPILER=$(tc-getBUILD_CC)/}" \
+ src/CMakeLists.txt || die
+ cmake_src_prepare
+}
+
src_configure() {
local mycmakeargs=(
- -DCMAKE_C_COMPILER="$(tc-getCC)"
-Denable-alsa=$(usex alsa)
-Denable-aufile=ON
-Denable-dbus=$(usex dbus)
@@ -73,6 +83,7 @@ src_configure() {
-Denable-ubsan=OFF # compile and link against UBSan (for debugging fluidsynth internals)
-Denable-waveout=OFF # Windows
-Denable-winmidi=OFF # Windows
+ $(cmake_use_find_package doc Doxygen)
)
if use alsa; then
@@ -88,6 +99,22 @@ src_configure() {
cmake-multilib_src_configure
}
+compile_doxygen_doc() {
+ multilib_is_native_abi && cmake_build doxygen
+}
+
+src_compile() {
+ cmake-multilib_src_compile
+ use doc && multilib_foreach_abi compile_doxygen_doc
+}
+
+install_doxygen_doc() {
+ if multilib_is_native_abi; then
+ docinto .
+ dodoc -r "${BUILD_DIR}/doc/api/html"
+ fi
+}
+
install_systemd_files() {
if multilib_is_native_abi; then
systemd_dounit "${BUILD_DIR}/fluidsynth.service"
@@ -106,11 +133,12 @@ src_install() {
docinto pdf
dodoc doc/*.pdf
- if use examples; then
- docinto examples
- dodoc doc/examples/*.c
- fi
+ docinto examples
+ dodoc doc/examples/*.c
+ if use doc; then
+ multilib_foreach_abi install_doxygen_doc
+ fi
if use systemd; then
multilib_foreach_abi install_systemd_files
diff --git a/media-sound/picard/Manifest b/media-sound/picard/Manifest
index 67adaba122b4..f5b2a9d410ba 100644
--- a/media-sound/picard/Manifest
+++ b/media-sound/picard/Manifest
@@ -1,4 +1,6 @@
DIST picard-2.10.tar.gz 5800268 BLAKE2B 5590b9dd9a88244486688d73ea0e565b789da457e5cab5c57d7abad54cae0a52fb574090d45efeb317ee405dbf61185ff6d24d5a7ec7d5afc1db0713a5b09e92 SHA512 d771a2629163d140edb7d39dfb48a7d2c4d2e3025f3111d3f090036c2ba734f8a4ba08fa1035f2ba4e04c8e80c07a517fe98df430407ee71fac14b289b7316cb
+DIST picard-2.11.tar.gz 5829423 BLAKE2B 1f5b675a3668b7545bbb5966e3d81bec09912acbe5ae7270b92eb25accf4bbd1cc67a2a183c6d1fa0300bb0adea5dbdcdc0998d2c44f60d2dbac941ca5af9fc8 SHA512 713a2782b26c4cd0dafa95b9c0b41bf3566d933ce9af712822cce0492ca8efa45ee57f1fb51aeacef824f699156a4156ee84ba91d5cfea28751e7d0f1e9a964a
EBUILD picard-2.10.ebuild 1458 BLAKE2B e34ec114b1f745ae9854d305ed4e1d767b88b170776fe9916973ea1d199180a1fe089f5cc9a7d7932d6a9dbcb67f39b9ff1fb41ad93ad29e3fb8883086da3d7d SHA512 f6d2838fa37e15c8fe6b09414529c724d846530a4acd42bafcf01b09aaed400a24585b599b7b5773831f7d623fe3239576aadf4919fb95ef5a712ed4ac655fa7
+EBUILD picard-2.11.ebuild 1460 BLAKE2B 9c16c620974efe86e040c2f6897fbda66dc64730d92cee4c8a71709049aea9f8c267591a118e53dcad14099edd2743078bc7727062a9b2158858325fa60cdb34 SHA512 3f982fce7007f4a590939ca0a6a5da00804689e69e7bb97409595d99872958684cef7266d6fd9c36aaf9bace9a1e547365795aca2265792b24d1b5f93ab1af89
EBUILD picard-9999.ebuild 1460 BLAKE2B b6b2c08ebed6a02513a6a96bad57e6b1e3f91f693da3c9e5707c670b1aa4914aa53fdc5bb0246af14a0594ae67e3a4d9d5fb7d8fc4714469fdf0f759be3546a8 SHA512 511e956e66b15526d60f7b3c1ef215b7b048eb1dcd473a5bfb145f4eb4e2bfe29648f09380845b0ad335b8b8d58c74b081c2fb87c6520304c5d212f0e0798084
MISC metadata.xml 740 BLAKE2B cc09a7bf012e0b85ff55531ace5d8b187cd68fdae7d274cb640a7ae446296c2ac70bb599955d6ab2570b3eb879c28cad0cf2e70fe7339c2c0c58fd8b0dcdcac7 SHA512 321188fd4887593a3683b2c507673baa9e2faf2b46b0158338a67e72dbf5267b93c1e358ceadeacd707d6a6bb234a4fae8ef681779463c4ab5bd3b79dbd47c43
diff --git a/media-sound/picard/picard-2.11.ebuild b/media-sound/picard/picard-2.11.ebuild
new file mode 100644
index 000000000000..b4b408e1ab81
--- /dev/null
+++ b/media-sound/picard/picard-2.11.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..12} )
+DISTUTILS_USE_PEP517=setuptools
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_EXT=1
+
+inherit distutils-r1 xdg
+
+if [[ ${PV} = *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/metabrainz/picard"
+ inherit git-r3
+else
+ SRC_URI="https://data.musicbrainz.org/pub/musicbrainz/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+DESCRIPTION="Cross-platform music tagger"
+HOMEPAGE="https://picard.musicbrainz.org"
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="discid fingerprints nls"
+
+BDEPEND="
+ nls? ( dev-qt/linguist-tools:5 )
+"
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/fasteners[${PYTHON_USEDEP}]
+ dev-python/pyjwt[${PYTHON_USEDEP}]
+ dev-python/PyQt5[declarative,gui,network,widgets,${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ media-libs/mutagen[${PYTHON_USEDEP}]
+ discid? ( dev-python/discid[${PYTHON_USEDEP}] )
+ ')
+ fingerprints? ( media-libs/chromaprint[tools] )
+"
+
+distutils_enable_tests pytest
+
+python_compile() {
+ local build_args=(
+ --disable-autoupdate
+ )
+ if ! use nls; then
+ build_args+=( --disable-locales )
+ fi
+ distutils-r1_python_compile ${build_args[@]}
+}
+
+python_install() {
+ local install_args=(
+ --disable-autoupdate
+ --skip-build
+ )
+ if ! use nls; then
+ install_args+=( --disable-locales )
+ fi
+ distutils-r1_python_install ${install_args[@]}
+}