summaryrefslogtreecommitdiff
path: root/media-libs/zxing-cpp/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-14 19:40:40 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-14 19:40:40 +0100
commit7cffc3e7845d1a3ae331145c5e1226e314badf4a (patch)
treeae17da77e9a871037a9669ec708469eefddbd40c /media-libs/zxing-cpp/files
parent3e627c1432765cb6a32877e73f985e8bfb5102ce (diff)
gentoo auto-resync : 14:07:2022 - 19:40:39
Diffstat (limited to 'media-libs/zxing-cpp/files')
-rw-r--r--media-libs/zxing-cpp/files/zxing-cpp-1.4.0-install-required-private-headers.patch43
1 files changed, 43 insertions, 0 deletions
diff --git a/media-libs/zxing-cpp/files/zxing-cpp-1.4.0-install-required-private-headers.patch b/media-libs/zxing-cpp/files/zxing-cpp-1.4.0-install-required-private-headers.patch
new file mode 100644
index 000000000000..2a85252f5439
--- /dev/null
+++ b/media-libs/zxing-cpp/files/zxing-cpp-1.4.0-install-required-private-headers.patch
@@ -0,0 +1,43 @@
+From 4159a44bdc785b27013bc6be1d32b2e442c73b74 Mon Sep 17 00:00:00 2001
+From: Andreas Sturmlechner <asturm@gentoo.org>
+Date: Thu, 14 Jul 2022 12:04:27 +0200
+Subject: [PATCH] Add INSTALL_PRIVATE_HEADERS switch to unbreak LibreOffice
+
+Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
+---
+ CMakeLists.txt | 1 +
+ core/CMakeLists.txt | 6 ++++++
+ 2 files changed, 7 insertions(+)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index e947ce8d..2e41e773 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -9,6 +9,7 @@ option (BUILD_BLACKBOX_TESTS "Build the black box reader/writer tests" OFF)
+ option (BUILD_UNIT_TESTS "Build the unit tests (don't enable for production builds)" OFF)
+ option (BUILD_PYTHON_MODULE "Build the python module" OFF)
+ set(BUILD_DEPENDENCIES "AUTO" CACHE STRING "Fetch from github or use locally installed (AUTO/GITHUB/LOCAL)")
++option (INSTALL_PRIVATE_HEADERS "Install (some) private headers to unbreak (some) revdeps broken by 1.4.0 cleanup" OFF)
+
+ if (WIN32)
+ option (BUILD_SHARED_LIBS "Build and link as shared library" OFF)
+diff --git a/core/CMakeLists.txt b/core/CMakeLists.txt
+index 7382bcae..575e696b 100644
+--- a/core/CMakeLists.txt
++++ b/core/CMakeLists.txt
+@@ -174,6 +174,12 @@ if (BUILD_WRITERS)
+ )
+ endif()
+ # end of public header set
++if (INSTALL_PRIVATE_HEADERS)
++ set (PUBLIC_HEADERS ${PUBLIC_HEADERS}
++ src/BitArray.h
++ )
++endif()
++# end of 'private' public header set
+
+ set (AZTEC_FILES
+ )
+--
+2.35.1
+