summaryrefslogtreecommitdiff
path: root/media-libs/zxing-cpp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-14 19:40:40 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-14 19:40:40 +0100
commit7cffc3e7845d1a3ae331145c5e1226e314badf4a (patch)
treeae17da77e9a871037a9669ec708469eefddbd40c /media-libs/zxing-cpp
parent3e627c1432765cb6a32877e73f985e8bfb5102ce (diff)
gentoo auto-resync : 14:07:2022 - 19:40:39
Diffstat (limited to 'media-libs/zxing-cpp')
-rw-r--r--media-libs/zxing-cpp/Manifest3
-rw-r--r--media-libs/zxing-cpp/files/zxing-cpp-1.4.0-install-required-private-headers.patch43
-rw-r--r--media-libs/zxing-cpp/zxing-cpp-1.4.0.ebuild28
3 files changed, 74 insertions, 0 deletions
diff --git a/media-libs/zxing-cpp/Manifest b/media-libs/zxing-cpp/Manifest
index 03480b393ccb..bb7393176c2a 100644
--- a/media-libs/zxing-cpp/Manifest
+++ b/media-libs/zxing-cpp/Manifest
@@ -1,3 +1,6 @@
+AUX zxing-cpp-1.4.0-install-required-private-headers.patch 1473 BLAKE2B 8e2445934b118bdaf85b7567ee93fcf370d9e93ae23c2cb35a91e0c32ece380dcde92a0b34b9069805edf96a5f74ad5b20ffc4d8395f6084ed5bae14b961822d SHA512 98a8beaa4fafbc454663b9e8e3553e3859d6639f10a314eb7d668351a247222fb09636a36c68c32de8ffdc283dd3f92ec17cc706a9848099d20e74349d08cb0f
DIST zxing-cpp-1.3.0.tar.gz 97938087 BLAKE2B f0c9c906ab2b534c67cf66605eca0ecc22a90fc9d69e23397bcb0bc8eaf3d68a7ad41631ea6d9c7f292ee03165d2e038d84f497307384205e2d6f37fef5dddba SHA512 27821667dea3d09b91bf9825ff25483ed658d850fd238009f1c7e43b1b09e62d24b3a2cd78d4e39d29725931b32bfce3e21e7ec871830b3ad69a5a69c72d8de8
+DIST zxing-cpp-1.4.0.tar.gz 1018225 BLAKE2B 98b6badfe0ddfa39650eb4fbfc02bc01f5237cdd5edfafd7b88067997a22caa2e64d067328b534c439d7d89fef5b6d48acf4bc29389142b332123b477f3e3dde SHA512 05c5b9282f13b76fa0897b21e5b73cb7df0c52e62f1a2d9760fe774aa0378fde97f5f9896690b65b28b4b96ba6ad2703bed53ffaf9d3784636d29cbe860d4bad
EBUILD zxing-cpp-1.3.0.ebuild 674 BLAKE2B beb366970d86e34a60eb7c156f62a43c251b167db59c85964258b57f68e49f08efa1cd97692607b2c63b295f7a666f3a60c60fafff0e84db77c0c5dc953599bf SHA512 0b064d67c9b1e3bf25059e906fae8e573300da28b2ee5d3b45ee9be33d13d1b8d690d596cd61b185083932aa122f8683120fdb8c2796b2ae3004d6721ba691e8
+EBUILD zxing-cpp-1.4.0.ebuild 883 BLAKE2B bca217aa2db0fcdc8673c64f5d89ed1a43366023c2c35eee331f903381538456961e3023c4ca1c268d8ec5db48bab2c7922646446ab38d051687b7a7e3048281 SHA512 ff22b030384277a0e806b4d569ae2ded4a55e3996ec03e2033baa469bed3c7853d9ba84f230d6ae09f14eb73afab42b485d05c01ab2d901266ee4bbc2f318540
MISC metadata.xml 250 BLAKE2B f3e9395137ebb9adf46cd35c1b6156f82c04cfa94f964f6da24fe71eb560cf51b4f70ebfa10daaa4884400ec22782d819ab794dfd29e7a47559f07208397195d SHA512 78c4ff15eed76ba883b457be95dabd41e928a0e64a42b758b5eab4d8a95afca27d5ea6a7cfe0948de578b169153a05f08aadfce1ddd41a88732212a1e76e565f
diff --git a/media-libs/zxing-cpp/files/zxing-cpp-1.4.0-install-required-private-headers.patch b/media-libs/zxing-cpp/files/zxing-cpp-1.4.0-install-required-private-headers.patch
new file mode 100644
index 000000000000..2a85252f5439
--- /dev/null
+++ b/media-libs/zxing-cpp/files/zxing-cpp-1.4.0-install-required-private-headers.patch
@@ -0,0 +1,43 @@
+From 4159a44bdc785b27013bc6be1d32b2e442c73b74 Mon Sep 17 00:00:00 2001
+From: Andreas Sturmlechner <asturm@gentoo.org>
+Date: Thu, 14 Jul 2022 12:04:27 +0200
+Subject: [PATCH] Add INSTALL_PRIVATE_HEADERS switch to unbreak LibreOffice
+
+Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
+---
+ CMakeLists.txt | 1 +
+ core/CMakeLists.txt | 6 ++++++
+ 2 files changed, 7 insertions(+)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index e947ce8d..2e41e773 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -9,6 +9,7 @@ option (BUILD_BLACKBOX_TESTS "Build the black box reader/writer tests" OFF)
+ option (BUILD_UNIT_TESTS "Build the unit tests (don't enable for production builds)" OFF)
+ option (BUILD_PYTHON_MODULE "Build the python module" OFF)
+ set(BUILD_DEPENDENCIES "AUTO" CACHE STRING "Fetch from github or use locally installed (AUTO/GITHUB/LOCAL)")
++option (INSTALL_PRIVATE_HEADERS "Install (some) private headers to unbreak (some) revdeps broken by 1.4.0 cleanup" OFF)
+
+ if (WIN32)
+ option (BUILD_SHARED_LIBS "Build and link as shared library" OFF)
+diff --git a/core/CMakeLists.txt b/core/CMakeLists.txt
+index 7382bcae..575e696b 100644
+--- a/core/CMakeLists.txt
++++ b/core/CMakeLists.txt
+@@ -174,6 +174,12 @@ if (BUILD_WRITERS)
+ )
+ endif()
+ # end of public header set
++if (INSTALL_PRIVATE_HEADERS)
++ set (PUBLIC_HEADERS ${PUBLIC_HEADERS}
++ src/BitArray.h
++ )
++endif()
++# end of 'private' public header set
+
+ set (AZTEC_FILES
+ )
+--
+2.35.1
+
diff --git a/media-libs/zxing-cpp/zxing-cpp-1.4.0.ebuild b/media-libs/zxing-cpp/zxing-cpp-1.4.0.ebuild
new file mode 100644
index 000000000000..7fe3f592a74c
--- /dev/null
+++ b/media-libs/zxing-cpp/zxing-cpp-1.4.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="C++ Multi-format 1D/2D barcode image processing library"
+HOMEPAGE="https://github.com/nu-book/zxing-cpp"
+SRC_URI="https://github.com/nu-book/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/1.4"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE=""
+
+# Downstream patch until revdeps like LibreOffice are fixed
+PATCHES=( "${FILESDIR}/${P}-install-required-private-headers.patch" )
+
+src_configure() {
+ local mycmakeargs=(
+ -DINSTALL_PRIVATE_HEADERS=ON # required by LibreOffice as of 7.3.5.1
+ -DBUILD_EXAMPLES=OFF # nothing is installed
+ -DBUILD_BLACKBOX_TESTS=OFF # FIXME: FetchContent.cmake module usage
+ -DBUILD_UNIT_TESTS=OFF # for both tests options. no thanks. bug #793173
+ )
+ cmake_src_configure
+}