summaryrefslogtreecommitdiff
path: root/media-libs/theoraplay/theoraplay-0_pre20180524.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-06-16 21:23:20 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-06-16 21:23:20 +0100
commitfab849d1daed0ba7f2ac497d07985c3dbb692543 (patch)
tree10baa743a5340b42ad538dd19d48669ccac209b1 /media-libs/theoraplay/theoraplay-0_pre20180524.ebuild
parent73c318acdaf6f8309d68bd266051e6dd1f1bd787 (diff)
gentoo resync : 16.06.2019
Diffstat (limited to 'media-libs/theoraplay/theoraplay-0_pre20180524.ebuild')
-rw-r--r--media-libs/theoraplay/theoraplay-0_pre20180524.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/media-libs/theoraplay/theoraplay-0_pre20180524.ebuild b/media-libs/theoraplay/theoraplay-0_pre20180524.ebuild
new file mode 100644
index 000000000000..487a8f89eb15
--- /dev/null
+++ b/media-libs/theoraplay/theoraplay-0_pre20180524.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multilib multilib-minimal toolchain-funcs
+
+COMMIT="7d8701876294"
+DESCRIPTION="Simple library to make decoding of Ogg Theora videos easier"
+HOMEPAGE="https://icculus.org/projects/theoraplay/"
+SRC_URI="https://hg.icculus.org/icculus/${PN}/archive/${COMMIT}.tar.bz2 -> ${P}.tar.bz2"
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ media-libs/libogg
+ media-libs/libtheora
+ media-libs/libvorbis
+"
+
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+multilib_src_compile() {
+ libtool --tag=CC --mode=compile $(tc-getCC) -shared ${CFLAGS} -pthread -c "${S}"/${PN}.c || die
+ libtool --tag=CC --mode=link $(tc-getCC) -shared ${LDFLAGS} -pthread -Wl,-z,defs ${PN}.lo \
+ -logg -ltheoradec -lvorbis -o lib${PN}.la -rpath "${EPREFIX}/usr/$(get_libdir)" || die
+}
+
+multilib_src_install() {
+ dolib.so .libs/lib${PN}$(get_libname)*
+}
+
+multilib_src_install_all() {
+ doheader ${PN}.h
+}