summaryrefslogtreecommitdiff
path: root/media-libs/theoraplay
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-06-16 21:23:20 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-06-16 21:23:20 +0100
commitfab849d1daed0ba7f2ac497d07985c3dbb692543 (patch)
tree10baa743a5340b42ad538dd19d48669ccac209b1 /media-libs/theoraplay
parent73c318acdaf6f8309d68bd266051e6dd1f1bd787 (diff)
gentoo resync : 16.06.2019
Diffstat (limited to 'media-libs/theoraplay')
-rw-r--r--media-libs/theoraplay/Manifest3
-rw-r--r--media-libs/theoraplay/metadata.xml8
-rw-r--r--media-libs/theoraplay/theoraplay-0_pre20180524.ebuild36
3 files changed, 47 insertions, 0 deletions
diff --git a/media-libs/theoraplay/Manifest b/media-libs/theoraplay/Manifest
new file mode 100644
index 000000000000..ba86630feb28
--- /dev/null
+++ b/media-libs/theoraplay/Manifest
@@ -0,0 +1,3 @@
+DIST theoraplay-0_pre20180524.tar.bz2 14504 BLAKE2B 99580d65574887c283c8d7d1a588783bdb91ea5570adb4e194919ed930be558d62ddbd10e451746aa47bd6996cc3102f0b1eee50308cc278c2c6368a2a76d244 SHA512 509815535f73efe3b1c602b425d4a0aa78ce744809e8242fdfdecbb74a3a765d80b8e565dbdd00cd2daaf122365ba5a8651d302c907c714eae97f64607b7d0b8
+EBUILD theoraplay-0_pre20180524.ebuild 982 BLAKE2B 243f8081623bb289008de66e5051ec01c47895c96e572ba70b0f3fc9533f37c6cd08d3da55591245bcdd4792a66ba3322bc8b1a4db9c78065cdf061287e57377 SHA512 74a900d1431d426b8b4f32da1e783a69ee748f355193455fa915f6cbe5550d8edb7cffb57adf2ce6f7f23fd9d80c2a6148079ed779031952602e69c061d89ffa
+MISC metadata.xml 253 BLAKE2B 443ca9c8d4f6801169382e87a0ecd1385c56e65229209e7200f9d313ef380e92ae8d7dc3c38e5989a4166289f22607a20b1e13bb960fff6b3d9f78629d8ab020 SHA512 61c4689cbc649d84a00be211b7b5b98dd03e1d3f813eff370df549f2998cd4343f391c18b57cf20e4a8f4dd2311e3bfa04eb60f356f2bbac78f0b68f5091f254
diff --git a/media-libs/theoraplay/metadata.xml b/media-libs/theoraplay/metadata.xml
new file mode 100644
index 000000000000..26079e608bed
--- /dev/null
+++ b/media-libs/theoraplay/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/media-libs/theoraplay/theoraplay-0_pre20180524.ebuild b/media-libs/theoraplay/theoraplay-0_pre20180524.ebuild
new file mode 100644
index 000000000000..487a8f89eb15
--- /dev/null
+++ b/media-libs/theoraplay/theoraplay-0_pre20180524.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multilib multilib-minimal toolchain-funcs
+
+COMMIT="7d8701876294"
+DESCRIPTION="Simple library to make decoding of Ogg Theora videos easier"
+HOMEPAGE="https://icculus.org/projects/theoraplay/"
+SRC_URI="https://hg.icculus.org/icculus/${PN}/archive/${COMMIT}.tar.bz2 -> ${P}.tar.bz2"
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ media-libs/libogg
+ media-libs/libtheora
+ media-libs/libvorbis
+"
+
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+multilib_src_compile() {
+ libtool --tag=CC --mode=compile $(tc-getCC) -shared ${CFLAGS} -pthread -c "${S}"/${PN}.c || die
+ libtool --tag=CC --mode=link $(tc-getCC) -shared ${LDFLAGS} -pthread -Wl,-z,defs ${PN}.lo \
+ -logg -ltheoradec -lvorbis -o lib${PN}.la -rpath "${EPREFIX}/usr/$(get_libdir)" || die
+}
+
+multilib_src_install() {
+ dolib.so .libs/lib${PN}$(get_libname)*
+}
+
+multilib_src_install_all() {
+ doheader ${PN}.h
+}