summaryrefslogtreecommitdiff
path: root/media-libs/openpgl/openpgl-0.5.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-16 05:49:50 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-16 05:49:50 +0100
commit1ac83daac7198a5717483e1cfab669ba4f12debe (patch)
treefb9c448591e3f43e411800a609df633313aab78f /media-libs/openpgl/openpgl-0.5.0.ebuild
parentfddb33ccaadabe03f5571606f796b45965b38e9c (diff)
gentoo auto-resync : 16:04:2023 - 05:49:50
Diffstat (limited to 'media-libs/openpgl/openpgl-0.5.0.ebuild')
-rw-r--r--media-libs/openpgl/openpgl-0.5.0.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/media-libs/openpgl/openpgl-0.5.0.ebuild b/media-libs/openpgl/openpgl-0.5.0.ebuild
new file mode 100644
index 000000000000..81276940fbc2
--- /dev/null
+++ b/media-libs/openpgl/openpgl-0.5.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Intel Open Path Guiding Library"
+HOMEPAGE="https://github.com/OpenPathGuidingLibrary/openpgl"
+SRC_URI="https://github.com/OpenPathGuidingLibrary/openpgl/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+X86_CPU_FLAGS=( sse4_2 avx2 avx512dq )
+CPU_FLAGS=( ${X86_CPU_FLAGS[@]/#/cpu_flags_x86_} )
+IUSE="${CPU_FLAGS[@]%:*} debug"
+
+RDEPEND="
+ media-libs/embree
+ dev-cpp/tbb:=
+"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DOPENPGL_ISA_AVX2=$(usex cpu_flags_x86_avx2)
+ -DOPENPGL_ISA_AVX512=$(usex cpu_flags_x86_avx512dq)
+ -DOPENPGL_ISA_SSE4=$(usex cpu_flags_x86_sse4_2)
+ )
+
+ # Disable asserts
+ append-cppflags $(usex debug '' '-DNDEBUG')
+
+ cmake_src_configure
+}