summaryrefslogtreecommitdiff
path: root/media-libs/openpgl
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-16 05:49:50 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-16 05:49:50 +0100
commit1ac83daac7198a5717483e1cfab669ba4f12debe (patch)
treefb9c448591e3f43e411800a609df633313aab78f /media-libs/openpgl
parentfddb33ccaadabe03f5571606f796b45965b38e9c (diff)
gentoo auto-resync : 16:04:2023 - 05:49:50
Diffstat (limited to 'media-libs/openpgl')
-rw-r--r--media-libs/openpgl/Manifest3
-rw-r--r--media-libs/openpgl/metadata.xml24
-rw-r--r--media-libs/openpgl/openpgl-0.5.0.ebuild37
3 files changed, 64 insertions, 0 deletions
diff --git a/media-libs/openpgl/Manifest b/media-libs/openpgl/Manifest
new file mode 100644
index 000000000000..5d52e2efb6ab
--- /dev/null
+++ b/media-libs/openpgl/Manifest
@@ -0,0 +1,3 @@
+DIST openpgl-0.5.0.tar.gz 10767365 BLAKE2B 051b26c17300506dd20989ba9dc1aa83b0baf77c5f24650c74518ae56081b5a0ecca88c13d5d79a71cb0b6fa4a5b4841ee03e5223ec91ab16bb5655f2e52a9d7 SHA512 9b992ffa17ad6f9fcde48add5d9cc1e58be2daacd40478fb1babe0741a6c7a64f12f36c9c1f7d5ec6f79cdd847c082d39e03e58cfd9af1a903adca56f1ac19e1
+EBUILD openpgl-0.5.0.ebuild 872 BLAKE2B c9283be19c0c9bfcde71de6305f4d32df2d28aacc12c5843155f53b81f494d08181fcf137d87d2b7dcd3a9138f6e4f61b0423e6c2c2351f95345ef731ccf0efe SHA512 21e303ea511abadaee500985f2575b2e803147fb19f1028f4afe597494896407ff06e7a71aa56c727fd3786322cf99a582e3db2f365414845f557c07fc5ae966
+MISC metadata.xml 1011 BLAKE2B c88245ac6d49bf09e2a96754713dcf088ec1ba4700713d2551a8af4f9c509553edbde8e9775fb1bc410b2eec742df26527b07d5cd36194ae5a2b4c5c018b51b1 SHA512 ff6c48d3db9dfd2737410f5d689d08fcb49a062bc291eb0e5442851037723a701629c13d44929b6812df5098adda7695b1edbd1bae9ed3cca63cf04b710cfdf2
diff --git a/media-libs/openpgl/metadata.xml b/media-libs/openpgl/metadata.xml
new file mode 100644
index 000000000000..362878695f7a
--- /dev/null
+++ b/media-libs/openpgl/metadata.xml
@@ -0,0 +1,24 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>darkdefende@gmail.com</email>
+ <name>Sebastian Parborg</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription>
+ The IntelĀ® Open Path Guiding Library (IntelĀ® Open PGL) implements a set of
+ representations and training algorithms needed to integrate path guiding
+ into a renderer. Open PGL offers implementations of current state-of-the-art
+ path guiding methods, which increase the sampling quality and, therefore,
+ the efficiency of a renderer. The goal of Open PGL is to provide
+ implementations that are well tested and robust enough to be used in a
+ production environment.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">OpenPathGuidingLibrary/openpgl</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/media-libs/openpgl/openpgl-0.5.0.ebuild b/media-libs/openpgl/openpgl-0.5.0.ebuild
new file mode 100644
index 000000000000..81276940fbc2
--- /dev/null
+++ b/media-libs/openpgl/openpgl-0.5.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Intel Open Path Guiding Library"
+HOMEPAGE="https://github.com/OpenPathGuidingLibrary/openpgl"
+SRC_URI="https://github.com/OpenPathGuidingLibrary/openpgl/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+X86_CPU_FLAGS=( sse4_2 avx2 avx512dq )
+CPU_FLAGS=( ${X86_CPU_FLAGS[@]/#/cpu_flags_x86_} )
+IUSE="${CPU_FLAGS[@]%:*} debug"
+
+RDEPEND="
+ media-libs/embree
+ dev-cpp/tbb:=
+"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DOPENPGL_ISA_AVX2=$(usex cpu_flags_x86_avx2)
+ -DOPENPGL_ISA_AVX512=$(usex cpu_flags_x86_avx512dq)
+ -DOPENPGL_ISA_SSE4=$(usex cpu_flags_x86_sse4_2)
+ )
+
+ # Disable asserts
+ append-cppflags $(usex debug '' '-DNDEBUG')
+
+ cmake_src_configure
+}