summaryrefslogtreecommitdiff
path: root/media-libs/oidn/oidn-1.3.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
commitd18bf1e01b65ee4bf0c804e2843b282d3d4e5d7c (patch)
tree4a95cbc6ffdf13bad6ecbc7f8d5af99631984123 /media-libs/oidn/oidn-1.3.0.ebuild
parente748ba9741f6540f4675c23e3e37b73e822c13a4 (diff)
gentoo resync : 15.06.2021
Diffstat (limited to 'media-libs/oidn/oidn-1.3.0.ebuild')
-rw-r--r--media-libs/oidn/oidn-1.3.0.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/media-libs/oidn/oidn-1.3.0.ebuild b/media-libs/oidn/oidn-1.3.0.ebuild
new file mode 100644
index 000000000000..7e79c737d50f
--- /dev/null
+++ b/media-libs/oidn/oidn-1.3.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{6,7,8,9} )
+
+inherit cmake python-single-r1 eutils
+
+DESCRIPTION="Intel(R) Open Image Denoise library"
+HOMEPAGE="http://www.openimagedenoise.org/"
+
+if [[ ${PV} = *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/OpenImageDenoise/oidn.git"
+ EGIT_BRANCH="master"
+else
+ SRC_URI="https://github.com/OpenImageDenoise/${PN}/releases/download/v${PV}/${P}.src.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ dev-cpp/tbb
+ dev-lang/ispc"
+DEPEND="
+ ${RDEPEND}
+ dev-util/cmake"
+
+CMAKE_BUILD_TYPE=Release
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}