summaryrefslogtreecommitdiff
path: root/media-libs/oidn
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
commitd18bf1e01b65ee4bf0c804e2843b282d3d4e5d7c (patch)
tree4a95cbc6ffdf13bad6ecbc7f8d5af99631984123 /media-libs/oidn
parente748ba9741f6540f4675c23e3e37b73e822c13a4 (diff)
gentoo resync : 15.06.2021
Diffstat (limited to 'media-libs/oidn')
-rw-r--r--media-libs/oidn/Manifest3
-rw-r--r--media-libs/oidn/metadata.xml20
-rw-r--r--media-libs/oidn/oidn-1.3.0.ebuild39
3 files changed, 62 insertions, 0 deletions
diff --git a/media-libs/oidn/Manifest b/media-libs/oidn/Manifest
new file mode 100644
index 000000000000..eeb37748ee7d
--- /dev/null
+++ b/media-libs/oidn/Manifest
@@ -0,0 +1,3 @@
+DIST oidn-1.3.0.tar.gz 36763571 BLAKE2B 395d7aafd87babf7d2414ed940dd85adf4a488df2138e0e63cc82ac06088dd969879de73d79bead4b35bba0045081ee637b72f2a98770dbfc928ffe7c25da78a SHA512 19de3cf11b9d436ee6f33ff020187a4cdc05da5f43c47509f715ca99e4276bfb64425d0a48f3a6f0569c8c6701b46a7e35378f371fdbacc0b6d488e113ffe17c
+EBUILD oidn-1.3.0.ebuild 806 BLAKE2B ebc2a40fc86bd432593cf1ab6e28b6d4584b00b87a14dec3a2c2e132800d75acae8532869328f4193d9a4fcf294875d94fbb8099ea84dbf52390114db4a59548 SHA512 a5922175efeb4c0c187ffaee4c78ea924cc4ae57cb503bccc62433369510d5ae3099dcdd4ce10dbadbe3323927cccc43df9b062a19777119bb28dbd517f8ca75
+MISC metadata.xml 753 BLAKE2B f1cc053407f788b1e08043ad1e652658d946423a749811d007d1256bedb7a462ece80444967881d5951d7fd343f33de7ca5d23f7c1ee69f1c5ad9ec8e8cc174f SHA512 311f6dfa3d7815e03ff72dbe76d9be6de3247f7de5652fb9b03c1c10ac75a8c30c76f20c9e8e34d5b478fe1fcc287511773d1104b5c4c268b4778ad331cb8123
diff --git a/media-libs/oidn/metadata.xml b/media-libs/oidn/metadata.xml
new file mode 100644
index 000000000000..1787e6d6af0d
--- /dev/null
+++ b/media-libs/oidn/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>darkdefende@gmail.com</email>
+ <name>Sebastian Parborg</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription>
+ Intel Open Image Denoise is an open source library of high-performance,
+ high-quality denoising filters for images rendered with ray tracing. Intel
+ Open Image Denoise is part of the IntelĀ® oneAPI Rendering Toolkit and is
+ </longdescription>
+ <upstream>
+ <remote-id type="github">OpenImageDenoise/oidn</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/media-libs/oidn/oidn-1.3.0.ebuild b/media-libs/oidn/oidn-1.3.0.ebuild
new file mode 100644
index 000000000000..7e79c737d50f
--- /dev/null
+++ b/media-libs/oidn/oidn-1.3.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{6,7,8,9} )
+
+inherit cmake python-single-r1 eutils
+
+DESCRIPTION="Intel(R) Open Image Denoise library"
+HOMEPAGE="http://www.openimagedenoise.org/"
+
+if [[ ${PV} = *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/OpenImageDenoise/oidn.git"
+ EGIT_BRANCH="master"
+else
+ SRC_URI="https://github.com/OpenImageDenoise/${PN}/releases/download/v${PV}/${P}.src.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ dev-cpp/tbb
+ dev-lang/ispc"
+DEPEND="
+ ${RDEPEND}
+ dev-util/cmake"
+
+CMAKE_BUILD_TYPE=Release
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}