summaryrefslogtreecommitdiff
path: root/media-libs/libopenaptx/libopenaptx-0.2.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /media-libs/libopenaptx/libopenaptx-0.2.0-r1.ebuild
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'media-libs/libopenaptx/libopenaptx-0.2.0-r1.ebuild')
-rw-r--r--media-libs/libopenaptx/libopenaptx-0.2.0-r1.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/media-libs/libopenaptx/libopenaptx-0.2.0-r1.ebuild b/media-libs/libopenaptx/libopenaptx-0.2.0-r1.ebuild
new file mode 100644
index 000000000000..84aea87a2a3f
--- /dev/null
+++ b/media-libs/libopenaptx/libopenaptx-0.2.0-r1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic multilib-minimal toolchain-funcs
+
+DESCRIPTION="Reverse-engineered aptX and aptX HD library"
+HOMEPAGE="https://github.com/pali/libopenaptx"
+
+if [[ ${PV} == "9999" ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/pali/${PN}"
+else
+ SRC_URI="https://github.com/pali/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="amd64 arm arm64 ppc ppc64 ~riscv x86"
+fi
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+
+IUSE="cpu_flags_x86_avx2"
+
+src_prepare() {
+ default
+
+ # custom Makefiles
+ multilib_copy_sources
+}
+
+multilib_src_compile() {
+ tc-export CC AR
+
+ use cpu_flags_x86_avx2 && append-cflags "-mavx2"
+
+ emake \
+ PREFIX="${EPREFIX}"/usr \
+ LIBDIR=$(get_libdir) \
+ CFLAGS="${CFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
+ ARFLAGS="${ARFLAGS} -rcs" \
+ all
+}
+
+multilib_src_install() {
+ emake \
+ PREFIX="${EPREFIX}"/usr \
+ DESTDIR="${D}" \
+ LIBDIR="$(get_libdir)" \
+ CFLAGS="${CFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
+ ARFLAGS="${ARFLAGS} -rcs" \
+ install
+
+ rm -f "${ED}/usr/$(get_libdir)"/libopenaptx.a || die "Failed to remove static lib"
+}