summaryrefslogtreecommitdiff
path: root/media-libs/libcdr/libcdr-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-12-31 13:43:35 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-12-31 13:43:35 +0000
commit2891d29af8907ce881662f4a02844926d7a293c7 (patch)
tree56979d96839d0827aa52008b81b746b4934d88df /media-libs/libcdr/libcdr-9999.ebuild
parentde49812990871e1705b64051c35161d5e6400269 (diff)
gentoo resync : 31.12.2018
Diffstat (limited to 'media-libs/libcdr/libcdr-9999.ebuild')
-rw-r--r--media-libs/libcdr/libcdr-9999.ebuild27
1 files changed, 16 insertions, 11 deletions
diff --git a/media-libs/libcdr/libcdr-9999.ebuild b/media-libs/libcdr/libcdr-9999.ebuild
index 3c04d584f9e0..091f92e616d7 100644
--- a/media-libs/libcdr/libcdr-9999.ebuild
+++ b/media-libs/libcdr/libcdr-9999.ebuild
@@ -1,21 +1,23 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit flag-o-matic
-EGIT_REPO_URI="https://anongit.freedesktop.org/git/libreoffice/libcdr.git"
-[[ ${PV} == 9999 ]] && inherit autotools git-r3
+if [[ ${PV} = 9999 ]]; then
+ EGIT_REPO_URI="https://anongit.freedesktop.org/git/libreoffice/libcdr.git"
+ inherit autotools git-r3
+else
+ SRC_URI="https://dev-www.libreoffice.org/src/libcdr/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+fi
DESCRIPTION="Library parsing the Corel cdr documents"
HOMEPAGE="https://wiki.documentfoundation.org/DLP/Libraries/libcdr"
-[[ ${PV} == 9999 ]] || SRC_URI="https://dev-www.libreoffice.org/src/libcdr/${P}.tar.xz"
LICENSE="MPL-2.0"
SLOT="0"
-[[ ${PV} == 9999 ]] || \
-KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86"
IUSE="doc static-libs test"
RDEPEND="
@@ -26,6 +28,8 @@ RDEPEND="
"
DEPEND="${RDEPEND}
dev-libs/boost
+"
+BDEPEND="
sys-devel/libtool
virtual/pkgconfig
doc? ( app-doc/doxygen )
@@ -42,11 +46,12 @@ src_configure() {
# bug 619448
append-cxxflags -std=c++14
- econf \
- --disable-werror \
- $(use_with doc docs) \
- $(use_enable static-libs static) \
+ local myeconfargs=(
+ $(use_with doc docs)
+ $(use_enable static-libs static)
$(use_enable test tests)
+ )
+ econf "${myeconfargs[@]}"
}
src_install() {