summaryrefslogtreecommitdiff
path: root/media-libs/libcdr
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-12-31 13:43:35 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-12-31 13:43:35 +0000
commit2891d29af8907ce881662f4a02844926d7a293c7 (patch)
tree56979d96839d0827aa52008b81b746b4934d88df /media-libs/libcdr
parentde49812990871e1705b64051c35161d5e6400269 (diff)
gentoo resync : 31.12.2018
Diffstat (limited to 'media-libs/libcdr')
-rw-r--r--media-libs/libcdr/Manifest4
-rw-r--r--media-libs/libcdr/libcdr-0.1.5.ebuild60
-rw-r--r--media-libs/libcdr/libcdr-9999.ebuild27
3 files changed, 79 insertions, 12 deletions
diff --git a/media-libs/libcdr/Manifest b/media-libs/libcdr/Manifest
index 64d103c869ce..b28edac8bd2f 100644
--- a/media-libs/libcdr/Manifest
+++ b/media-libs/libcdr/Manifest
@@ -1,4 +1,6 @@
DIST libcdr-0.1.4.tar.xz 609592 BLAKE2B 201ed19cfe9aa93137279dfa6b9c3908691b2bddd1e8b7fb25505ab475cb8ae533d1b27857c99e36f618938aa7ee88075c3c7f5780872abe68994f380dc893c8 SHA512 769b0319b5a904ce9f727b7076f82cd915ecd8c9e5e2456416e3e6739c6403bbd4108787ab124d36efb1b47d5c9e37c48b0e12d096eb440ae8f9979ec06048a6
+DIST libcdr-0.1.5.tar.xz 612252 BLAKE2B d23c7ae0d0f5cbdb535bfba4dff4ad40e8b0633115cbc8c5b3a40343d941eaeafbffafe99ba2107640eafdd8181ab6eed7917095d05644a43f2b11cfcc66f8f1 SHA512 e985389b0cbad65dbfa9f59d7f9dba55f1684f63e852f9acca9abb863cdaab17072e761b48dca690673360d643686b5e9bc9878530f0a3a8b5b98d917f892cf0
EBUILD libcdr-0.1.4.ebuild 1165 BLAKE2B 52b9a6e747d26e2ab7d649faa3c9f7ba7e02973194fcb259963790ab387d1580ee6e35ef2f93d32017329d322a8476d0a312c13f624f7bb9816f9a438495f539 SHA512 50105446ee1d69d75fe6583c123f66832803da3987d9b67402d6e415ca2cc31a430a48b85e455bb43798a5660c0b6ece8e01d4b09596d066f1cc45a2fde8a842
-EBUILD libcdr-9999.ebuild 1162 BLAKE2B da233600b9eb7f57096d37a61c1f6925e38e4905e68a183aa93097f7e4ca7962f040c78d7164dc53e8f8568072186a79b2fd27564ed865db7ed152701688b519 SHA512 74e6b63100144ea92a50f1a664a10c67660b9631d5ba79f386b7a65d997b2c53857a5edcd361e1f92a8963d11c349ca7d7d76358e74c4ca79528938d58f5f4ce
+EBUILD libcdr-0.1.5.ebuild 1164 BLAKE2B 2ebed7c2dbd73964ea5a203693681b51c9e4dd4fcbfe24723dd3a92ee82ac286edbb9eef311fc891cff3cab2990084e176b6453b17dfbfb7df6120d29acd5389 SHA512 c4d2fdaeb651c2fa6065b7c7355375cfd813547d4007e0bdc37de70c785f99eee0f435b568e2dc7825390ee1832fc6b6e5d572ec6ea50a9a8b379cd254b55c94
+EBUILD libcdr-9999.ebuild 1164 BLAKE2B 2ebed7c2dbd73964ea5a203693681b51c9e4dd4fcbfe24723dd3a92ee82ac286edbb9eef311fc891cff3cab2990084e176b6453b17dfbfb7df6120d29acd5389 SHA512 c4d2fdaeb651c2fa6065b7c7355375cfd813547d4007e0bdc37de70c785f99eee0f435b568e2dc7825390ee1832fc6b6e5d572ec6ea50a9a8b379cd254b55c94
MISC metadata.xml 255 BLAKE2B 9b8486730bea2158e8be5cbbe0552c5460d1b18e2236a68e3f11d85ce4eeb96eb0e746f44a10cb7cdcf1bf498190a512ef42f47852c6843b9a3c937ceabc338d SHA512 ac646e8ac676faf0aac283e4be31c5f2b29e98ccf07327073ed05e688ce696caf639bdfea63e4aed141a90e84c0a86892bc717a52b95cdf1739aaa15240013c3
diff --git a/media-libs/libcdr/libcdr-0.1.5.ebuild b/media-libs/libcdr/libcdr-0.1.5.ebuild
new file mode 100644
index 000000000000..091f92e616d7
--- /dev/null
+++ b/media-libs/libcdr/libcdr-0.1.5.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic
+
+if [[ ${PV} = 9999 ]]; then
+ EGIT_REPO_URI="https://anongit.freedesktop.org/git/libreoffice/libcdr.git"
+ inherit autotools git-r3
+else
+ SRC_URI="https://dev-www.libreoffice.org/src/libcdr/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+fi
+
+DESCRIPTION="Library parsing the Corel cdr documents"
+HOMEPAGE="https://wiki.documentfoundation.org/DLP/Libraries/libcdr"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+IUSE="doc static-libs test"
+
+RDEPEND="
+ dev-libs/icu:=
+ dev-libs/librevenge
+ media-libs/lcms:2
+ sys-libs/zlib
+"
+DEPEND="${RDEPEND}
+ dev-libs/boost
+"
+BDEPEND="
+ sys-devel/libtool
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+ test? ( dev-util/cppunit )
+"
+
+src_prepare() {
+ default
+ [[ -d m4 ]] || mkdir "m4"
+ [[ ${PV} == 9999 ]] && eautoreconf
+}
+
+src_configure() {
+ # bug 619448
+ append-cxxflags -std=c++14
+
+ local myeconfargs=(
+ $(use_with doc docs)
+ $(use_enable static-libs static)
+ $(use_enable test tests)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
diff --git a/media-libs/libcdr/libcdr-9999.ebuild b/media-libs/libcdr/libcdr-9999.ebuild
index 3c04d584f9e0..091f92e616d7 100644
--- a/media-libs/libcdr/libcdr-9999.ebuild
+++ b/media-libs/libcdr/libcdr-9999.ebuild
@@ -1,21 +1,23 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit flag-o-matic
-EGIT_REPO_URI="https://anongit.freedesktop.org/git/libreoffice/libcdr.git"
-[[ ${PV} == 9999 ]] && inherit autotools git-r3
+if [[ ${PV} = 9999 ]]; then
+ EGIT_REPO_URI="https://anongit.freedesktop.org/git/libreoffice/libcdr.git"
+ inherit autotools git-r3
+else
+ SRC_URI="https://dev-www.libreoffice.org/src/libcdr/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+fi
DESCRIPTION="Library parsing the Corel cdr documents"
HOMEPAGE="https://wiki.documentfoundation.org/DLP/Libraries/libcdr"
-[[ ${PV} == 9999 ]] || SRC_URI="https://dev-www.libreoffice.org/src/libcdr/${P}.tar.xz"
LICENSE="MPL-2.0"
SLOT="0"
-[[ ${PV} == 9999 ]] || \
-KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86"
IUSE="doc static-libs test"
RDEPEND="
@@ -26,6 +28,8 @@ RDEPEND="
"
DEPEND="${RDEPEND}
dev-libs/boost
+"
+BDEPEND="
sys-devel/libtool
virtual/pkgconfig
doc? ( app-doc/doxygen )
@@ -42,11 +46,12 @@ src_configure() {
# bug 619448
append-cxxflags -std=c++14
- econf \
- --disable-werror \
- $(use_with doc docs) \
- $(use_enable static-libs static) \
+ local myeconfargs=(
+ $(use_with doc docs)
+ $(use_enable static-libs static)
$(use_enable test tests)
+ )
+ econf "${myeconfargs[@]}"
}
src_install() {