summaryrefslogtreecommitdiff
path: root/media-libs/lastfmlib
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-01 21:06:00 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-01 21:06:00 +0000
commit129160ec854dca4c3fedb5bcfbcb56930371da0f (patch)
tree53bf797418ac5e9b99c41ca0382c87b82421e5de /media-libs/lastfmlib
parent441d1370330332b7d78f238d2f5e13f7aed5e4e0 (diff)
gentoo new year resync : 01.01.2021
Diffstat (limited to 'media-libs/lastfmlib')
-rw-r--r--media-libs/lastfmlib/Manifest2
-rw-r--r--media-libs/lastfmlib/files/lastfmlib-0.4.0-string-conv.patch20
-rw-r--r--media-libs/lastfmlib/lastfmlib-0.4.0-r1.ebuild34
3 files changed, 56 insertions, 0 deletions
diff --git a/media-libs/lastfmlib/Manifest b/media-libs/lastfmlib/Manifest
index aa2e43c197bc..9847f276116d 100644
--- a/media-libs/lastfmlib/Manifest
+++ b/media-libs/lastfmlib/Manifest
@@ -1,3 +1,5 @@
+AUX lastfmlib-0.4.0-string-conv.patch 510 BLAKE2B 088c8deb83ad96450b21e1d7a8e99d34a5421ccaa72ad75e102f89f011d494ee4e54c9799a1a6296543f7d230dcb41dec48a083d4c0a09a8a52f87744c7256ab SHA512 cd212e173559822586c97fe175791b7ca2ca7239cc511d5b4d07ff7dfc9ec87b5f3a126acf58c4bd95a7cb19cfc04b067ecb99fab6cb1815e59f56fe9c70ee4f
DIST lastfmlib-0.4.0.tar.gz 333224 BLAKE2B 2e38adb90a468eccf959950d89e2e0b903e7e96c871b4d20216ee233933392fda7cd3bd86d90472e0f305922dc11e1dc998206c669a13be76eab7fdd07e6b45b SHA512 88e26bab04eda06f77f4684a5fe14aa9761acfcb5d7d8726c4d3ae5e1a4acd73e6b0c9bedff5d51bce07afd7b883085f1adba98714e8ebfc5bbd20b8aca66748
+EBUILD lastfmlib-0.4.0-r1.ebuild 714 BLAKE2B 345ecabe9615c4587e878086f07795032406a2f93bb83be60bfe26bd4c30585751c66e6d0cc58fed544c569614438a5da85a9564bd30a72ce4c56dbe37e0381c SHA512 b981d9273d217d4e59aeb9035c8f692d5fb9b009e9e3106321b7c43403dba84aa7413cf42f6d2b140a8d8d2ceac3cc25dd6d79e4d667734968b4e4f163ec0fcf
EBUILD lastfmlib-0.4.0.ebuild 664 BLAKE2B 3a0cf60999baa26e7d202fc3ef50bbe6e49d02c5ed328523abd05b78442ee8d7fbfb79376fe7504eac58a7a91fea97a1677c76e4dfa2d63511e5c328ad2e556c SHA512 2b263e34261d74d174fec0270d2b7510484514c497089a23d5a504d85a500052065030d5dcf5420f80ff4d5097b43092f3b71c11325f40c45de9a6f749c4f17d
MISC metadata.xml 335 BLAKE2B dabbb4b4997e73611fb77582fbb5b2f07bb0f41106dd68de366039342d2d1de1021e5d2133dc606baa6cc7f0510f7e532a955740c1735377d122f2387883fb9d SHA512 ecbb5547e38a68d686192d03224578355575915d90db53615a0b9aba928e4e2d1eec4b40a08da2eb8fb8e1a26a8b06e861cbad9b31a6af61087fe048e98b814f
diff --git a/media-libs/lastfmlib/files/lastfmlib-0.4.0-string-conv.patch b/media-libs/lastfmlib/files/lastfmlib-0.4.0-string-conv.patch
new file mode 100644
index 000000000000..381e731d9f62
--- /dev/null
+++ b/media-libs/lastfmlib/files/lastfmlib-0.4.0-string-conv.patch
@@ -0,0 +1,20 @@
+# Fix string conversions
+# Author: Steven Newbury <steve@snewbury.org.uk>
+# Gentoo Bug: 664760
+--- ./lastfmlib/utils/stringoperations.h~ 2020-02-27 11:50:53.000000000 +0000
++++ ./lastfmlib/utils/stringoperations.h 2020-02-27 11:55:49.228128570 +0000
+@@ -53,14 +53,6 @@
+ ss << numeric;
+ return ss.str();
+ }
+-
+- template<typename T>
+- inline std::string toWstring(T& numeric)
+- {
+- std::wstringstream ss;
+- ss << numeric;
+- return ss.str();
+- }
+ }
+
+ #endif
diff --git a/media-libs/lastfmlib/lastfmlib-0.4.0-r1.ebuild b/media-libs/lastfmlib/lastfmlib-0.4.0-r1.ebuild
new file mode 100644
index 000000000000..f10290636479
--- /dev/null
+++ b/media-libs/lastfmlib/lastfmlib-0.4.0-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="C++ library to scrobble tracks on Last.fm"
+HOMEPAGE="https://github.com/dirkvdb/lastfmlib/releases"
+SRC_URI="https://github.com/dirkvdb/lastfmlib/archive/lastfmlib-0.4.0.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug syslog"
+
+RDEPEND="net-misc/curl"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}/${P}-string-conv.patch"
+)
+
+src_configure() {
+ econf \
+ --disable-static \
+ $(use_enable debug) \
+ $(use_enable syslog logging) \
+ --disable-unittests
+}
+
+src_install() {
+ default
+ find "${D}"/usr -name '*.la' -delete || die "Pruning failed"
+}