summaryrefslogtreecommitdiff
path: root/media-libs/lastfmlib/lastfmlib-0.4.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/lastfmlib/lastfmlib-0.4.0-r1.ebuild')
-rw-r--r--media-libs/lastfmlib/lastfmlib-0.4.0-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/media-libs/lastfmlib/lastfmlib-0.4.0-r1.ebuild b/media-libs/lastfmlib/lastfmlib-0.4.0-r1.ebuild
new file mode 100644
index 000000000000..f10290636479
--- /dev/null
+++ b/media-libs/lastfmlib/lastfmlib-0.4.0-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="C++ library to scrobble tracks on Last.fm"
+HOMEPAGE="https://github.com/dirkvdb/lastfmlib/releases"
+SRC_URI="https://github.com/dirkvdb/lastfmlib/archive/lastfmlib-0.4.0.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug syslog"
+
+RDEPEND="net-misc/curl"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}/${P}-string-conv.patch"
+)
+
+src_configure() {
+ econf \
+ --disable-static \
+ $(use_enable debug) \
+ $(use_enable syslog logging) \
+ --disable-unittests
+}
+
+src_install() {
+ default
+ find "${D}"/usr -name '*.la' -delete || die "Pruning failed"
+}