summaryrefslogtreecommitdiff
path: root/media-gfx/inkscape/inkscape-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-18 11:05:42 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-18 11:05:42 +0100
commit1426dfeb15e4d49cb4238c6cf37455a6130cd83f (patch)
tree9f9734bcdc280108e52d753b3c57234371772c3c /media-gfx/inkscape/inkscape-9999.ebuild
parent836586553c510ee2dd91e2ecd7676fe432c1f1a4 (diff)
gentoo auto-resync : 18:09:2023 - 11:05:42
Diffstat (limited to 'media-gfx/inkscape/inkscape-9999.ebuild')
-rw-r--r--media-gfx/inkscape/inkscape-9999.ebuild27
1 files changed, 18 insertions, 9 deletions
diff --git a/media-gfx/inkscape/inkscape-9999.ebuild b/media-gfx/inkscape/inkscape-9999.ebuild
index 176dc00840be..0f162519d9ab 100644
--- a/media-gfx/inkscape/inkscape-9999.ebuild
+++ b/media-gfx/inkscape/inkscape-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..11} )
PYTHON_REQ_USE="xml(+)"
MY_P="${P/_/}"
inherit cmake flag-o-matic xdg toolchain-funcs python-single-r1
@@ -13,7 +13,7 @@ if [[ ${PV} = 9999* ]]; then
EGIT_REPO_URI="https://gitlab.com/inkscape/inkscape.git"
else
SRC_URI="https://media.inkscape.org/dl/resources/file/${P}.tar.xz"
- KEYWORDS="~alpha ~amd64"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
fi
DESCRIPTION="SVG based generic vector-drawing program"
@@ -21,10 +21,10 @@ HOMEPAGE="https://inkscape.org/ https://gitlab.com/inkscape/inkscape/"
LICENSE="GPL-2 LGPL-2.1"
SLOT="0"
-IUSE="cdr dia exif graphicsmagick imagemagick inkjar jpeg
-openmp postscript readline spell svg2 test visio wpg X"
-
+IUSE="cdr dia exif graphicsmagick imagemagick inkjar jpeg openmp postscript readline sourceview spell svg2 test visio wpg X"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+# Lots of test failures which need investigating, bug #871621
+RESTRICT="!test? ( test ) test"
BDEPEND="
dev-util/glib-utils
@@ -77,6 +77,7 @@ COMMON_DEPEND="${PYTHON_DEPS}
)
jpeg? ( media-libs/libjpeg-turbo:= )
readline? ( sys-libs/readline:= )
+ sourceview? ( x11-libs/gtksourceview:4 )
spell? ( app-text/gspell )
visio? (
app-text/libwpg:0.3
@@ -103,8 +104,6 @@ DEPEND="${COMMON_DEPEND}
test? ( dev-cpp/gtest )
"
-RESTRICT="!test? ( test )"
-
S="${WORKDIR}/${MY_P}"
pkg_pretend() {
@@ -151,6 +150,7 @@ src_configure() {
-DENABLE_LCMS=ON
-DWITH_OPENMP=$(usex openmp)
-DBUILD_SHARED_LIBS=ON
+ -DWITH_GSOURCEVIEW=$(usex sourceview)
-DWITH_SVG2=$(usex svg2)
-DWITH_LIBVISIO=$(usex visio)
-DWITH_LIBWPG=$(usex wpg)
@@ -161,14 +161,23 @@ src_configure() {
}
src_test() {
- local myctestargs=(
+ CMAKE_SKIP_TESTS=(
# render_text*: needs patched Cairo / maybe upstream changes
# not yet in a release.
# test_lpe/test_lpe64: precision differences b/c of new GCC?
# cli_export-png-color-mode-gray-8_png_check_output: ditto?
- -E "(render_test-use|render_test-glyph-y-pos|render_text-glyphs-combining|render_text-glyphs-vertical|render_test-rtl-vertical|test_lpe|test_lpe64|cli_export-png-color-mode-gray-8_png_check_output)"
+ render_test-use
+ render_test-glyph-y-pos
+ render_text-glyphs-combining
+ render_text-glyphs-vertical
+ render_test-rtl-vertical
+ test_lpe
+ test_lpe64
+ cli_export-png-color-mode-gray-8_png_check_output
)
+ # bug #871621
+ cmake_src_compile tests
cmake_src_test -j1
}