summaryrefslogtreecommitdiff
path: root/media-gfx/apngasm/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /media-gfx/apngasm/files
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'media-gfx/apngasm/files')
-rw-r--r--media-gfx/apngasm/files/apngasm-2.91-makefile.patch22
-rw-r--r--media-gfx/apngasm/files/apngasm-3.1.10-static.patch11
2 files changed, 11 insertions, 22 deletions
diff --git a/media-gfx/apngasm/files/apngasm-2.91-makefile.patch b/media-gfx/apngasm/files/apngasm-2.91-makefile.patch
deleted file mode 100644
index b9fb9c20ee89..000000000000
--- a/media-gfx/apngasm/files/apngasm-2.91-makefile.patch
+++ /dev/null
@@ -1,22 +0,0 @@
---- apngasm-2.91-src/Makefile
-+++ apngasm-2.91-src/Makefile
-@@ -1,8 +1,7 @@
- PACKAGE = apngasm
- CC = gcc
--SRC_DIRS = . 7z zopfli
--CFLAGS = -Wall -pedantic -DFEATURE_7ZIP -DFEATURE_ZOPFLI
--CFLAGS_OPT = -O2
-+SRC_DIRS = . 7z
-+CFLAGS += -Wall -pedantic
- CFLAGS_7Z = -Wno-sign-compare -Wno-reorder -Wno-maybe-uninitialized -Wno-parentheses
- LIBS = -lstdc++ -lm -lpng -lz
-
-@@ -16,7 +15,7 @@
- all : $(PACKAGE)
-
- $(PACKAGE) : objdirs $(OBJECTS)
-- $(CC) -o $@ $(OBJECTS) -s $(LIBS)
-+ $(CC) -o $@ $(OBJECTS) $(LDFLAGS) $(LIBS)
-
- objdirs :
- mkdir -p $(OBJ_DIRS)
diff --git a/media-gfx/apngasm/files/apngasm-3.1.10-static.patch b/media-gfx/apngasm/files/apngasm-3.1.10-static.patch
index a624d03278f3..fdc4f5ea41e8 100644
--- a/media-gfx/apngasm/files/apngasm-3.1.10-static.patch
+++ b/media-gfx/apngasm/files/apngasm-3.1.10-static.patch
@@ -1,3 +1,14 @@
+--- a/cli/CMakeLists.txt
++++ b/cli/CMakeLists.txt
+@@ -51,7 +51,7 @@ set_target_properties(apngasm-cli
+
+ # Link to built apngasm library
+ target_link_libraries(apngasm-cli
+- apngasm
++ apngasm-dynamic
+ ${Boost_LIBRARIES}
+ )
+
--- a/lib/CMakeLists.txt
+++ b/lib/CMakeLists.txt
@@ -55,18 +55,6 @@ set_target_properties(${APNGASM_DYNAMIC_LIB_TARGET}