summaryrefslogtreecommitdiff
path: root/media-gfx/apngasm/files/apngasm-3.1.10-static.patch
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/apngasm/files/apngasm-3.1.10-static.patch')
-rw-r--r--media-gfx/apngasm/files/apngasm-3.1.10-static.patch11
1 files changed, 11 insertions, 0 deletions
diff --git a/media-gfx/apngasm/files/apngasm-3.1.10-static.patch b/media-gfx/apngasm/files/apngasm-3.1.10-static.patch
index a624d03278f3..fdc4f5ea41e8 100644
--- a/media-gfx/apngasm/files/apngasm-3.1.10-static.patch
+++ b/media-gfx/apngasm/files/apngasm-3.1.10-static.patch
@@ -1,3 +1,14 @@
+--- a/cli/CMakeLists.txt
++++ b/cli/CMakeLists.txt
+@@ -51,7 +51,7 @@ set_target_properties(apngasm-cli
+
+ # Link to built apngasm library
+ target_link_libraries(apngasm-cli
+- apngasm
++ apngasm-dynamic
+ ${Boost_LIBRARIES}
+ )
+
--- a/lib/CMakeLists.txt
+++ b/lib/CMakeLists.txt
@@ -55,18 +55,6 @@ set_target_properties(${APNGASM_DYNAMIC_LIB_TARGET}