summaryrefslogtreecommitdiff
path: root/mail-filter/bogofilter
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-21 19:05:26 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-21 19:05:26 +0100
commit511de054920d6e2f43eb973d13aee9b4e3e9a926 (patch)
tree5b2f65aa4c29c8b8a42d466145083e299acb498e /mail-filter/bogofilter
parent8cdbce52e2f89fecc3d9bac3ff73ebee1c8f8c75 (diff)
gentoo resync : 21.07.2018
Diffstat (limited to 'mail-filter/bogofilter')
-rw-r--r--mail-filter/bogofilter/Manifest1
-rw-r--r--mail-filter/bogofilter/bogofilter-1.2.4-r2.ebuild131
2 files changed, 132 insertions, 0 deletions
diff --git a/mail-filter/bogofilter/Manifest b/mail-filter/bogofilter/Manifest
index c5401a4b8d9e..eb1a0c41e8fe 100644
--- a/mail-filter/bogofilter/Manifest
+++ b/mail-filter/bogofilter/Manifest
@@ -2,4 +2,5 @@ AUX bogofilter-1.2.2-gcc34.patch 1393 BLAKE2B e5f1c3fca416ab76114aeaa2da700b4c8c
AUX bogofilter-1.2.4-test-env.patch 392 BLAKE2B a72f6e0c08ca9f100188fff9da98ca41b45c87b42abbc6f68432eef597eb691609130d57f8723a800da6eaabbf87b87e4eed79539a5cf6f88539803d8f9bc4fb SHA512 c9f08a1af44d3281aff119a821423adbb9533cd49d87986a13d817db8d9446bc48a195b964527940aa0e41f5106bd4d7b2a9684c6c725bafed95adb8d3e87e96
DIST bogofilter-1.2.4.tar.bz2 887848 BLAKE2B 4ed5c15a44f5a166e3858581ccc59b36ebde2fe1eb402cc0471378600b555b2452f4eae04d7d37dcb7638568db0c196da2d2504a3a569d7571c4aacd7e0ceea7 SHA512 e8c0b6bcc14f12fbbb2752e697a6d9065e17abfca3f70045ce9fe668d01c1cfad4adaa35c81546ecdd3639b0c28f3f4776bb5ed4699f21e9e2a5b19ca33479db
EBUILD bogofilter-1.2.4-r1.ebuild 3739 BLAKE2B 8bdc42c8080fad6a9043a078d418c732f4a2029613ee2dc3ed75e3ac60da9ea1141352022c9d2852bc6b2473b8a1419c85600e001c7e9b7c571ce634a7fff68b SHA512 f82ea953c36071d6b5f25ce645d585712906f7bfe688400ce0e45cb561cdb7cb774243216bd9af090308744c9d6cd8c4f70fd00b69fe85a28c3331a0cc580021
+EBUILD bogofilter-1.2.4-r2.ebuild 3784 BLAKE2B 3523d28e8d929393a27bbbffeb8062e674538af3e13f3796b99b1b566ba41e14d5742a5f69d324fe2ed959ede637dab278af9c0fcbcdb7447ed2670a3317f4fb SHA512 dbc7dc698e83762e5beeb70a3b00a327ea6f898630b5f4c3e454e7a5dfcdcf524edc33102ac4335fb63f8039d6d32864e0071fc03fd73072875dcc7d531479da
MISC metadata.xml 681 BLAKE2B 847326098ccdb227a492c2c03c6173e8260db73a91df37ed739511402fc2466476cc7ffb5c356b203b46945524224237bcec8058e2ef19d0436c25a2611003cf SHA512 cce40d35e042c532ccac225225ca6a137a041f9da6f8f0696cfd4b12fa6876662379bf2cc01e36bb91bf32479561be0ca44b20a86a7788448207a35983042277
diff --git a/mail-filter/bogofilter/bogofilter-1.2.4-r2.ebuild b/mail-filter/bogofilter/bogofilter-1.2.4-r2.ebuild
new file mode 100644
index 000000000000..0be07cf8a7bf
--- /dev/null
+++ b/mail-filter/bogofilter/bogofilter-1.2.4-r2.ebuild
@@ -0,0 +1,131 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools db-use flag-o-matic toolchain-funcs
+
+DESCRIPTION="Bayesian spam filter designed with fast algorithms, and tuned for speed"
+HOMEPAGE="http://bogofilter.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="berkdb sqlite tokyocabinet"
+
+# pax needed for bf_tar
+DEPEND="
+ app-arch/pax
+ sci-libs/gsl:=
+ virtual/libiconv
+ berkdb? ( >=sys-libs/db-3.2:* )
+ !berkdb? (
+ sqlite? ( >=dev-db/sqlite-3.6.22 )
+ !sqlite? (
+ tokyocabinet? ( dev-db/tokyocabinet )
+ !tokyocabinet? ( >=sys-libs/db-3.2:* )
+ )
+ )
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${P}-test-env.patch" )
+
+pkg_setup() {
+ has_version mail-filter/bogofilter || return 0
+ if ( use berkdb && ! has_version 'mail-filter/bogofilter[berkdb]' ) || \
+ ( ! use berkdb && has_version 'mail-filter/bogofilter[berkdb]' ) || \
+ ( use sqlite && ! has_version 'mail-filter/bogofilter[sqlite]' ) || \
+ ( ! use sqlite && has_version 'mail-filter/bogofilter[sqlite]' ) || \
+ ( has_version '>=mail-filter/bogofilter-1.2.1-r1' && \
+ ( use tokyocabinet && ! has_version 'mail-filter/bogofilter[tokyocabinet]' ) || \
+ ( ! use tokyocabinet && has_version 'mail-filter/bogofilter[tokyocabinet]' )
+ ) ; then
+ ewarn
+ ewarn "If you want to switch the database backend, you must dump the wordlist"
+ ewarn "with the current version (old use flags) and load it with the new version!"
+ ewarn
+ fi
+}
+
+src_prepare() {
+ default
+
+ # bug 445918
+ sed -i -e 's/ -ggdb//' configure.ac || die
+
+ # bug 421747
+ chmod +x src/tests/t.{ctype,leakfind,lexer.qpcr,lexer.eoh,message_id,queue_id}
+
+ # bug 654990
+ sed -i -e 's/t.bulkmode//' \
+ -e 's/t.dump.load//' \
+ -e 's/t.nonascii.replace//' \
+ src/tests/Makefile.am || die
+
+ eautoreconf
+}
+
+src_configure() {
+ local myconf="" berkdb=true
+ myconf="--without-included-gsl"
+
+ # determine backend: berkdb *is* default
+ if use berkdb && use sqlite ; then
+ elog "Both useflags berkdb and sqlite are in USE:"
+ elog "Using berkdb as database backend."
+ elif use berkdb && use tokyocabinet ; then
+ elog "Both useflags berkdb and tokyocabinet are in USE:"
+ elog "Using berkdb as database backend."
+ elif use sqlite && use tokyocabinet ; then
+ elog "Both useflags sqlite and tokyocabinet are in USE:"
+ elog "Using sqlite as database backend."
+ myconf="${myconf} --with-database=sqlite"
+ berkdb=false
+ elif use sqlite ; then
+ myconf="${myconf} --with-database=sqlite"
+ berkdb=false
+ elif use tokyocabinet ; then
+ myconf="${myconf} --with-database=tokyocabinet"
+ berkdb=false
+ elif ! use berkdb ; then
+ elog "Neither berkdb nor sqlite nor tokyocabinet are in USE:"
+ elog "Using berkdb as database backend."
+ fi
+
+ # Include the right berkdb headers for FreeBSD
+ if ${berkdb} ; then
+ append-cppflags "-I$(db_includedir)"
+ fi
+
+ econf ${myconf}
+}
+
+src_test() {
+ emake -C src/ check
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ exeinto /usr/share/${PN}/contrib
+ doexe contrib/{bogofilter-qfe,parmtest,randomtrain}.sh \
+ contrib/{bfproxy,bogominitrain,mime.get.rfc822,printmaildir}.pl \
+ contrib/{spamitarium,stripsearch}.pl
+
+ insinto /usr/share/${PN}/contrib
+ doins contrib/{README.*,dot-qmail-bogofilter-default} \
+ contrib/{bogogrep.c,bogo.R,bogofilter-milter.pl,*.example} \
+ contrib/vm-bogofilter.el \
+ contrib/{trainbogo,scramble}.sh
+
+ dodoc AUTHORS NEWS README RELEASE.NOTES* TODO GETTING.STARTED \
+ doc/integrating-with-* doc/README.{db,sqlite}
+
+ dodoc -r doc/*.html
+
+ dodir /usr/share/doc/${PF}/samples
+ mv "${D}"/etc/bogofilter.cf.example "${D}"/usr/share/doc/${PF}/samples/ || die
+ rmdir "${D}"/etc || die
+}