summaryrefslogtreecommitdiff
path: root/mail-filter
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-21 19:05:26 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-21 19:05:26 +0100
commit511de054920d6e2f43eb973d13aee9b4e3e9a926 (patch)
tree5b2f65aa4c29c8b8a42d466145083e299acb498e /mail-filter
parent8cdbce52e2f89fecc3d9bac3ff73ebee1c8f8c75 (diff)
gentoo resync : 21.07.2018
Diffstat (limited to 'mail-filter')
-rw-r--r--mail-filter/Manifest.gzbin11013 -> 11011 bytes
-rw-r--r--mail-filter/bogofilter/Manifest1
-rw-r--r--mail-filter/bogofilter/bogofilter-1.2.4-r2.ebuild131
-rw-r--r--mail-filter/scmail/Manifest7
-rw-r--r--mail-filter/scmail/files/scmail-doc-encoding.patch (renamed from mail-filter/scmail/files/scmail-doc-encoding.diff)4
-rw-r--r--mail-filter/scmail/files/scmail-gauche-0.9.patch (renamed from mail-filter/scmail/files/scmail-gauche-0.9.diff)4
-rw-r--r--mail-filter/scmail/files/scmail-undefined-reference.patch51
-rw-r--r--mail-filter/scmail/scmail-1.3.ebuild22
8 files changed, 206 insertions, 14 deletions
diff --git a/mail-filter/Manifest.gz b/mail-filter/Manifest.gz
index 04fccf8c5c2a..a4208ad59974 100644
--- a/mail-filter/Manifest.gz
+++ b/mail-filter/Manifest.gz
Binary files differ
diff --git a/mail-filter/bogofilter/Manifest b/mail-filter/bogofilter/Manifest
index c5401a4b8d9e..eb1a0c41e8fe 100644
--- a/mail-filter/bogofilter/Manifest
+++ b/mail-filter/bogofilter/Manifest
@@ -2,4 +2,5 @@ AUX bogofilter-1.2.2-gcc34.patch 1393 BLAKE2B e5f1c3fca416ab76114aeaa2da700b4c8c
AUX bogofilter-1.2.4-test-env.patch 392 BLAKE2B a72f6e0c08ca9f100188fff9da98ca41b45c87b42abbc6f68432eef597eb691609130d57f8723a800da6eaabbf87b87e4eed79539a5cf6f88539803d8f9bc4fb SHA512 c9f08a1af44d3281aff119a821423adbb9533cd49d87986a13d817db8d9446bc48a195b964527940aa0e41f5106bd4d7b2a9684c6c725bafed95adb8d3e87e96
DIST bogofilter-1.2.4.tar.bz2 887848 BLAKE2B 4ed5c15a44f5a166e3858581ccc59b36ebde2fe1eb402cc0471378600b555b2452f4eae04d7d37dcb7638568db0c196da2d2504a3a569d7571c4aacd7e0ceea7 SHA512 e8c0b6bcc14f12fbbb2752e697a6d9065e17abfca3f70045ce9fe668d01c1cfad4adaa35c81546ecdd3639b0c28f3f4776bb5ed4699f21e9e2a5b19ca33479db
EBUILD bogofilter-1.2.4-r1.ebuild 3739 BLAKE2B 8bdc42c8080fad6a9043a078d418c732f4a2029613ee2dc3ed75e3ac60da9ea1141352022c9d2852bc6b2473b8a1419c85600e001c7e9b7c571ce634a7fff68b SHA512 f82ea953c36071d6b5f25ce645d585712906f7bfe688400ce0e45cb561cdb7cb774243216bd9af090308744c9d6cd8c4f70fd00b69fe85a28c3331a0cc580021
+EBUILD bogofilter-1.2.4-r2.ebuild 3784 BLAKE2B 3523d28e8d929393a27bbbffeb8062e674538af3e13f3796b99b1b566ba41e14d5742a5f69d324fe2ed959ede637dab278af9c0fcbcdb7447ed2670a3317f4fb SHA512 dbc7dc698e83762e5beeb70a3b00a327ea6f898630b5f4c3e454e7a5dfcdcf524edc33102ac4335fb63f8039d6d32864e0071fc03fd73072875dcc7d531479da
MISC metadata.xml 681 BLAKE2B 847326098ccdb227a492c2c03c6173e8260db73a91df37ed739511402fc2466476cc7ffb5c356b203b46945524224237bcec8058e2ef19d0436c25a2611003cf SHA512 cce40d35e042c532ccac225225ca6a137a041f9da6f8f0696cfd4b12fa6876662379bf2cc01e36bb91bf32479561be0ca44b20a86a7788448207a35983042277
diff --git a/mail-filter/bogofilter/bogofilter-1.2.4-r2.ebuild b/mail-filter/bogofilter/bogofilter-1.2.4-r2.ebuild
new file mode 100644
index 000000000000..0be07cf8a7bf
--- /dev/null
+++ b/mail-filter/bogofilter/bogofilter-1.2.4-r2.ebuild
@@ -0,0 +1,131 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools db-use flag-o-matic toolchain-funcs
+
+DESCRIPTION="Bayesian spam filter designed with fast algorithms, and tuned for speed"
+HOMEPAGE="http://bogofilter.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="berkdb sqlite tokyocabinet"
+
+# pax needed for bf_tar
+DEPEND="
+ app-arch/pax
+ sci-libs/gsl:=
+ virtual/libiconv
+ berkdb? ( >=sys-libs/db-3.2:* )
+ !berkdb? (
+ sqlite? ( >=dev-db/sqlite-3.6.22 )
+ !sqlite? (
+ tokyocabinet? ( dev-db/tokyocabinet )
+ !tokyocabinet? ( >=sys-libs/db-3.2:* )
+ )
+ )
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${P}-test-env.patch" )
+
+pkg_setup() {
+ has_version mail-filter/bogofilter || return 0
+ if ( use berkdb && ! has_version 'mail-filter/bogofilter[berkdb]' ) || \
+ ( ! use berkdb && has_version 'mail-filter/bogofilter[berkdb]' ) || \
+ ( use sqlite && ! has_version 'mail-filter/bogofilter[sqlite]' ) || \
+ ( ! use sqlite && has_version 'mail-filter/bogofilter[sqlite]' ) || \
+ ( has_version '>=mail-filter/bogofilter-1.2.1-r1' && \
+ ( use tokyocabinet && ! has_version 'mail-filter/bogofilter[tokyocabinet]' ) || \
+ ( ! use tokyocabinet && has_version 'mail-filter/bogofilter[tokyocabinet]' )
+ ) ; then
+ ewarn
+ ewarn "If you want to switch the database backend, you must dump the wordlist"
+ ewarn "with the current version (old use flags) and load it with the new version!"
+ ewarn
+ fi
+}
+
+src_prepare() {
+ default
+
+ # bug 445918
+ sed -i -e 's/ -ggdb//' configure.ac || die
+
+ # bug 421747
+ chmod +x src/tests/t.{ctype,leakfind,lexer.qpcr,lexer.eoh,message_id,queue_id}
+
+ # bug 654990
+ sed -i -e 's/t.bulkmode//' \
+ -e 's/t.dump.load//' \
+ -e 's/t.nonascii.replace//' \
+ src/tests/Makefile.am || die
+
+ eautoreconf
+}
+
+src_configure() {
+ local myconf="" berkdb=true
+ myconf="--without-included-gsl"
+
+ # determine backend: berkdb *is* default
+ if use berkdb && use sqlite ; then
+ elog "Both useflags berkdb and sqlite are in USE:"
+ elog "Using berkdb as database backend."
+ elif use berkdb && use tokyocabinet ; then
+ elog "Both useflags berkdb and tokyocabinet are in USE:"
+ elog "Using berkdb as database backend."
+ elif use sqlite && use tokyocabinet ; then
+ elog "Both useflags sqlite and tokyocabinet are in USE:"
+ elog "Using sqlite as database backend."
+ myconf="${myconf} --with-database=sqlite"
+ berkdb=false
+ elif use sqlite ; then
+ myconf="${myconf} --with-database=sqlite"
+ berkdb=false
+ elif use tokyocabinet ; then
+ myconf="${myconf} --with-database=tokyocabinet"
+ berkdb=false
+ elif ! use berkdb ; then
+ elog "Neither berkdb nor sqlite nor tokyocabinet are in USE:"
+ elog "Using berkdb as database backend."
+ fi
+
+ # Include the right berkdb headers for FreeBSD
+ if ${berkdb} ; then
+ append-cppflags "-I$(db_includedir)"
+ fi
+
+ econf ${myconf}
+}
+
+src_test() {
+ emake -C src/ check
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ exeinto /usr/share/${PN}/contrib
+ doexe contrib/{bogofilter-qfe,parmtest,randomtrain}.sh \
+ contrib/{bfproxy,bogominitrain,mime.get.rfc822,printmaildir}.pl \
+ contrib/{spamitarium,stripsearch}.pl
+
+ insinto /usr/share/${PN}/contrib
+ doins contrib/{README.*,dot-qmail-bogofilter-default} \
+ contrib/{bogogrep.c,bogo.R,bogofilter-milter.pl,*.example} \
+ contrib/vm-bogofilter.el \
+ contrib/{trainbogo,scramble}.sh
+
+ dodoc AUTHORS NEWS README RELEASE.NOTES* TODO GETTING.STARTED \
+ doc/integrating-with-* doc/README.{db,sqlite}
+
+ dodoc -r doc/*.html
+
+ dodir /usr/share/doc/${PF}/samples
+ mv "${D}"/etc/bogofilter.cf.example "${D}"/usr/share/doc/${PF}/samples/ || die
+ rmdir "${D}"/etc || die
+}
diff --git a/mail-filter/scmail/Manifest b/mail-filter/scmail/Manifest
index 9d56ddcd25f6..506c0465f8ad 100644
--- a/mail-filter/scmail/Manifest
+++ b/mail-filter/scmail/Manifest
@@ -1,5 +1,6 @@
-AUX scmail-doc-encoding.diff 1294 BLAKE2B 12513733645550843ca1161cb201506a0fcb22eb1730ebe13cc5550c68822d20b97dc9c8f320d9d84c18313baa7d577ac91495ae7be9ce51b802886e17969cbc SHA512 22bd822c7d153380776c845c31efa0d16a93f4fe809c40a2d75107a60ffa4aa484e9f36ef13194855516059534b944646ed5e6db6992d66c6e146c5dc4cdd01a
-AUX scmail-gauche-0.9.diff 1318 BLAKE2B 9ad569c02208ff4e2415a3ff757828b75b9cd037f21c37740e2316a820397c5df5fb1fdc9cffb6754ec510f32eaee433f2a25cab494e8a33b46da16cfc331bcc SHA512 137c1dfbcd548a28e315bc0df6aac01e2ee89aaf74433297b0173c91da9216e464f9044e8584a3fd543f3cbcf28d47d6bcd539b8bd0830cf1cdd768c055792b6
+AUX scmail-doc-encoding.patch 1271 BLAKE2B c554ebfed8350a10939364b9d4b50d446d839ad2ea171ec88a0929f25c8f76bd0a213c7bfc82ab0863320c921fb43d52706145012b47745e0f2e4505802d974a SHA512 fb38ddca2bb938d7397d6edcfb49ff0fd971a0079f2b1571db9efa1ac8fed49ed27cb4d6a32b911d7135b6e58c5c61b12db64c47ad5422a86cb4701b79c40cf5
+AUX scmail-gauche-0.9.patch 1295 BLAKE2B 2bf2ee2aa2c99ef72d6fbd25c65448a99d1c3a16be20373db867c3ec07604b94ea2fb7a6fac76f1bca4aa8be378140dc6eb6718ead1f61844cba9127a0bd2ea8 SHA512 4aee907271c20254a41035160418429fcd7e35890a0d7a6251d4adefcaafe8581dc5e3df4bc70b27b541eb6a888acc7811231a183d62f2c267b1d2ccf652dc69
+AUX scmail-undefined-reference.patch 1351 BLAKE2B b0758cf2a1de5be0bd32d16bbc44d28d7e3b4e3a65f9a9151e76245c4f5473e8c82a682324544018e7aecf53f2534cc5e2fa2d27451947ff285684221b091e55 SHA512 2b8acf57f55a3367157bf20da796f2529258e48877b049f2928ff06c3365c24c41c6a8824f32b0fbf14fb193f94a2f147afa97c9c03a13227b62b13bd0b550d0
DIST scmail-1.3.tar.gz 52744 BLAKE2B 2e2848472bb6f9ce913fea381c905ec28a1cac5201fe3a8c89e25c96a0fd646e7f96ddcf6cdfd1e0d88f34b5d51ea754faa5c3574635715ed1dc92cfd9d2980c SHA512 ae94de7f34f9279e892533137d76f07642ade63f9d179bbc96202003f49cf8ae6dd6cc5b9d53fa1d2f8be2bebcbe071635910d48593c9e57fb6609cc7ec6e95d
-EBUILD scmail-1.3.ebuild 715 BLAKE2B 587d9bf9559e5e5cda85673d385aa1b0a791ece7d70384c861661b4f61bf4e142e6988bea0d5bc316a98f77208b8f2a161f177493cfaee1b919ca0aeea0344f2 SHA512 22102918a9ac9d5d99a465dfbae42d1bce6db9c94687ce214e26a66d9304bd789c9c7edff67a4de06ee0c3ce5b1246e959801b11aae4a3eb66a5cc3911749d64
+EBUILD scmail-1.3.ebuild 865 BLAKE2B 00cc7be560ab91dcb7ef79c667cf87b3eeb1b06c9bc052bab1620106ff2580e8b8b7873672b0bc861d43c877f605f50ac8821de9a3fb08b0adf96877bacd89f1 SHA512 3c489c5e8c86c032925f313086e1ec876738ac312f053c8cb1d92dae9bbdf4e1d6e9fdc4ddfcd27031a01068591c42d7fb78234848910dcd27af0277003e38bf
MISC metadata.xml 221 BLAKE2B 6fb71e3c82061054a0c2d88c1ce8e591d5742628fe53032c9efd2c371ce1e8b0135b00ac91fa1905df39a507d5faa5871fb3a30d167dd46cec581682ba17c8ff SHA512 a11e9bbbabc9ac96985c5dc247e601b065fa762f12bce74224896c27aee34eb908187622bfc849c39c6c722a8ef8ee72b248afc84da1b0eb72f1ff5eeb13bbf0
diff --git a/mail-filter/scmail/files/scmail-doc-encoding.diff b/mail-filter/scmail/files/scmail-doc-encoding.patch
index 5ed00a62d02d..8740774379f9 100644
--- a/mail-filter/scmail/files/scmail-doc-encoding.diff
+++ b/mail-filter/scmail/files/scmail-doc-encoding.patch
@@ -1,5 +1,5 @@
---- scmail-1.3.orig/doc/embed.scm
-+++ scmail-1.3/doc/embed.scm
+--- a/doc/embed.scm
++++ b/doc/embed.scm
@@ -1,3 +1,4 @@
+(use gauche.charconv)
(use gauche.regexp)
diff --git a/mail-filter/scmail/files/scmail-gauche-0.9.diff b/mail-filter/scmail/files/scmail-gauche-0.9.patch
index 36fc3b3daa77..9062df4eb71d 100644
--- a/mail-filter/scmail/files/scmail-gauche-0.9.diff
+++ b/mail-filter/scmail/files/scmail-gauche-0.9.patch
@@ -1,5 +1,5 @@
---- scmail-1.3.orig/scbayes.in
-+++ scmail-1.3/scbayes.in
+--- a/scbayes.in
++++ b/scbayes.in
@@ -16,6 +16,7 @@
(use gauche.parseopt)
diff --git a/mail-filter/scmail/files/scmail-undefined-reference.patch b/mail-filter/scmail/files/scmail-undefined-reference.patch
new file mode 100644
index 000000000000..5059ef4b1fd2
--- /dev/null
+++ b/mail-filter/scmail/files/scmail-undefined-reference.patch
@@ -0,0 +1,51 @@
+--- a/scmail/config.scm
++++ b/scmail/config.scm
+@@ -30,6 +30,8 @@
+ ))
+ (select-module scmail.config)
+
++(autoload scmail.util scmail-eformat)
++
+ (define scmail-config-directory (make-parameter (expand-path "~/.scmail")))
+
+ (define (scmail-config-set-directory! directory)
+--- a/scmail/mailbox.scm
++++ b/scmail/mailbox.scm
+@@ -19,6 +19,7 @@
+ (use srfi-1)
+ (use file.util)
+ (use gauche.parameter)
++ (use scmail.util)
+ (export <mailbox>
+ make-scmail-mailbox
+ scmail-mailbox-mail-list
+--- a/scmail/util.scm
++++ b/scmail/util.scm
+@@ -19,7 +19,6 @@
+ (use file.util)
+ (use srfi-13)
+ (use gauche.parameter)
+- (use scmail.config)
+ (use scmail.progress)
+ (use gauche.version)
+ (export filter safe-rxmatch
+@@ -31,6 +30,8 @@
+
+ (select-module scmail.util)
+
++(autoload scmail.config scmail-config-verbose-mode?)
++
+ ;;
+ ;; FIXME: Reinvent it because filter in srfi-1 module is too
+ ;; slow in old Gauche implementations.
+--- a/scmail.scm
++++ b/scmail.scm
+@@ -264,7 +264,7 @@
+ (unless (eq? status :last)
+ (scmail-filter-iter mail (cdr filter-rules))))))
+ (unless (is-a? mail <mail>)
+- (scmail-eprintf "<mail> required but got ~a" (class-of mail)))
++ (scmail-eformat "<mail> required but got ~a" (class-of mail)))
+ (scmail-filter-iter mail (filter-rules)))
+
+
diff --git a/mail-filter/scmail/scmail-1.3.ebuild b/mail-filter/scmail/scmail-1.3.ebuild
index 2b3e44ca9c5b..de13bf90310e 100644
--- a/mail-filter/scmail/scmail-1.3.ebuild
+++ b/mail-filter/scmail/scmail-1.3.ebuild
@@ -1,24 +1,32 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="4"
+EAPI="6"
-inherit eutils fixheadtails
+inherit fixheadtails
DESCRIPTION="a mail filter written in Scheme"
HOMEPAGE="http://0xcc.net/scmail/"
-SRC_URI="http://0xcc.net/scmail/${P}.tar.gz"
+SRC_URI="http://0xcc.net/${PN}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~amd64 ~ppc x86"
+KEYWORDS="amd64 ~ia64 ~ppc x86"
IUSE=""
RDEPEND="dev-scheme/gauche"
DEPEND="${RDEPEND}"
+PATCHES=(
+ "${FILESDIR}"/${PN}-doc-encoding.patch
+ "${FILESDIR}"/${PN}-gauche-0.9.patch
+ "${FILESDIR}"/${PN}-undefined-reference.patch
+)
+HTML_DOCS=( doc/{${PN},scbayes}{,-ja}.html )
+
src_prepare() {
- epatch "${FILESDIR}"/${PN}-*.diff
+ default
+
ht_fix_file tests/scmail-commands
# replace make -> $(MAKE)
sed -i "s/make\( \|$\)/\$(MAKE)\1/g" Makefile
@@ -30,5 +38,5 @@ src_install() {
SITELIBDIR="${ED}$(gauche-config --sitelibdir)" \
DATADIR="${ED}/usr/share/doc/${P}" \
install
- dohtml doc/*.html
+ einstalldocs
}