summaryrefslogtreecommitdiff
path: root/mail-client/cone/cone-0.96.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-09-14 18:52:15 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-09-14 18:52:15 +0100
commitd00821e77f72d4af4ea30158c1c6e18ffff0875b (patch)
treeb28b6cb077ae6b2457e30d49028fc978d8e2b59b /mail-client/cone/cone-0.96.ebuild
parent36ac65103bf5503e5bad1ecc7e8cb9e7643f6840 (diff)
parent6a339b4f9ec107438bb71a6f9ca72fd42fbfd436 (diff)
Merge branch 'next'
Diffstat (limited to 'mail-client/cone/cone-0.96.ebuild')
-rw-r--r--mail-client/cone/cone-0.96.ebuild54
1 files changed, 0 insertions, 54 deletions
diff --git a/mail-client/cone/cone-0.96.ebuild b/mail-client/cone/cone-0.96.ebuild
deleted file mode 100644
index 8f7516ca655d..000000000000
--- a/mail-client/cone/cone-0.96.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit eutils autotools
-
-DESCRIPTION="CONE: COnsole News reader and Emailer"
-HOMEPAGE="https://www.courier-mta.org/cone/"
-SRC_URI="mirror://sourceforge/courier/${P}.tar.bz2"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~sparc ~x86"
-IUSE="crypt fam gnutls idn ipv6 ldap"
-
-RDEPEND=">=dev-libs/openssl-0.9.6:0=
- dev-libs/libxml2
- sys-libs/ncurses:=
- >=net-libs/courier-unicode-2
- app-text/aspell
- crypt? ( >=app-crypt/gnupg-1.0.4 )
- fam? ( virtual/fam )
- gnutls? ( net-libs/gnutls )
- idn? ( net-dns/libidn )
- ipv6? ( net-dns/libidn )
- ldap? ( net-nds/openldap )"
-DEPEND="${RDEPEND}
- dev-lang/perl"
-
-src_prepare() {
- default
-
- # move local macro to m4 and run eautoreconf
- mkdir "${S}/m4"
- sed -n -e '/# AC_PROG_SYSCONFTOOL/,+33 p' "${S}"/aclocal.m4 > \
- m4/sysconftool.m4 || die
- sed -i -e '/^SUBDIRS/i ACLOCAL_AMFLAGS = -I m4' "${S}"/Makefile.am || die
-
- eautoreconf
-}
-
-src_configure() {
- econf \
- --with-spellcheck=aspell \
- $(use_with ldap ldapaddressbook) \
- $(use_with gnutls) \
- $(use_with idn libidn) \
- $(use_with ipv6)
-}
-
-src_install() {
- default
- emake DESTDIR="${D}" install-configure
-}