summaryrefslogtreecommitdiff
path: root/mail-client/cone/cone-0.96.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-09-13 17:49:31 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-09-13 17:49:31 +0100
commit36ac65103bf5503e5bad1ecc7e8cb9e7643f6840 (patch)
treed9d1fbc20509d4c90f57fb2d9e1459bc8034c831 /mail-client/cone/cone-0.96.ebuild
parenta1392efe64137262023d92492396ca9156d22396 (diff)
Revert "gentoo resync : 13.09.2019"
This reverts commit a1392efe64137262023d92492396ca9156d22396.
Diffstat (limited to 'mail-client/cone/cone-0.96.ebuild')
-rw-r--r--mail-client/cone/cone-0.96.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/mail-client/cone/cone-0.96.ebuild b/mail-client/cone/cone-0.96.ebuild
new file mode 100644
index 000000000000..8f7516ca655d
--- /dev/null
+++ b/mail-client/cone/cone-0.96.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils autotools
+
+DESCRIPTION="CONE: COnsole News reader and Emailer"
+HOMEPAGE="https://www.courier-mta.org/cone/"
+SRC_URI="mirror://sourceforge/courier/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="crypt fam gnutls idn ipv6 ldap"
+
+RDEPEND=">=dev-libs/openssl-0.9.6:0=
+ dev-libs/libxml2
+ sys-libs/ncurses:=
+ >=net-libs/courier-unicode-2
+ app-text/aspell
+ crypt? ( >=app-crypt/gnupg-1.0.4 )
+ fam? ( virtual/fam )
+ gnutls? ( net-libs/gnutls )
+ idn? ( net-dns/libidn )
+ ipv6? ( net-dns/libidn )
+ ldap? ( net-nds/openldap )"
+DEPEND="${RDEPEND}
+ dev-lang/perl"
+
+src_prepare() {
+ default
+
+ # move local macro to m4 and run eautoreconf
+ mkdir "${S}/m4"
+ sed -n -e '/# AC_PROG_SYSCONFTOOL/,+33 p' "${S}"/aclocal.m4 > \
+ m4/sysconftool.m4 || die
+ sed -i -e '/^SUBDIRS/i ACLOCAL_AMFLAGS = -I m4' "${S}"/Makefile.am || die
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --with-spellcheck=aspell \
+ $(use_with ldap ldapaddressbook) \
+ $(use_with gnutls) \
+ $(use_with idn libidn) \
+ $(use_with ipv6)
+}
+
+src_install() {
+ default
+ emake DESTDIR="${D}" install-configure
+}