summaryrefslogtreecommitdiff
path: root/kde-misc/kio-stash/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /kde-misc/kio-stash/files
reinit the tree, so we can have metadata
Diffstat (limited to 'kde-misc/kio-stash/files')
-rw-r--r--kde-misc/kio-stash/files/kio-stash-1.0-no-kf5config.patch43
1 files changed, 43 insertions, 0 deletions
diff --git a/kde-misc/kio-stash/files/kio-stash-1.0-no-kf5config.patch b/kde-misc/kio-stash/files/kio-stash-1.0-no-kf5config.patch
new file mode 100644
index 000000000000..1e434bb625ea
--- /dev/null
+++ b/kde-misc/kio-stash/files/kio-stash-1.0-no-kf5config.patch
@@ -0,0 +1,43 @@
+commit 624a1f38b9604def78c34e26ac31e1fd21c6673b
+Author: Andreas Sturmlechner <andreas.sturmlechner@gmail.com>
+Date: Mon Jul 3 20:36:41 2017 +0200
+
+ Drop unused KF5Config dependency
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 0cbd710..1552df6 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -27,7 +27,6 @@ find_package(Qt5 ${QT5_MIN_VERSION} REQUIRED COMPONENTS
+ )
+
+ find_package(KF5 ${KF5_MIN_VERSION} REQUIRED COMPONENTS
+- Config
+ KIO
+ DBusAddons
+ I18n
+diff --git a/src/ioslave/CMakeLists.txt b/src/ioslave/CMakeLists.txt
+index 462fef9..23922f8 100644
+--- a/src/ioslave/CMakeLists.txt
++++ b/src/ioslave/CMakeLists.txt
+@@ -6,8 +6,6 @@ target_link_libraries (kio_filestash
+ Qt5::DBus
+ KF5::KIOCore
+ KF5::I18n
+- KF5::ConfigCore
+- KF5::ConfigGui
+ )
+
+ set_target_properties(kio_filestash PROPERTIES OUTPUT_NAME "filestash")
+diff --git a/src/ioslave/ioslave.cpp b/src/ioslave/ioslave.cpp
+index b280f11..8928efb 100644
+--- a/src/ioslave/ioslave.cpp
++++ b/src/ioslave/ioslave.cpp
+@@ -34,7 +34,6 @@
+
+ #include <KProtocolManager>
+ #include <KLocalizedString>
+-#include <KConfigGroup>
+ #include <KFileItem>
+ #include <KIO/Job>
+