summaryrefslogtreecommitdiff
path: root/kde-misc/kio-stash
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /kde-misc/kio-stash
reinit the tree, so we can have metadata
Diffstat (limited to 'kde-misc/kio-stash')
-rw-r--r--kde-misc/kio-stash/Manifest4
-rw-r--r--kde-misc/kio-stash/files/kio-stash-1.0-no-kf5config.patch43
-rw-r--r--kde-misc/kio-stash/kio-stash-1.0.ebuild29
-rw-r--r--kde-misc/kio-stash/metadata.xml8
4 files changed, 84 insertions, 0 deletions
diff --git a/kde-misc/kio-stash/Manifest b/kde-misc/kio-stash/Manifest
new file mode 100644
index 000000000000..d28bea313a4b
--- /dev/null
+++ b/kde-misc/kio-stash/Manifest
@@ -0,0 +1,4 @@
+AUX kio-stash-1.0-no-kf5config.patch 1172 SHA256 8e3399cfedf5808f6f1e0d45d3bf9feba978d1f4741a8eec5f978a88f6abbb64 SHA512 f50ca12e08a04fff8c4066875007237a97189a83de97d62b3f133b3ab79bb90cdc9c7bbc4160281800df16cb7fdce35083b5559f18698238c0b719894e0b13d9 WHIRLPOOL 6ff1871b4eb7c67197e9b18ccc6b6332a53d169894757b78ded7d736db41c31c0aed68fbb92f9d0e070a16f3413e4e5258fc6a462d8781b4a088aabcc670e829
+DIST kio-stash-1.0.tar.xz 25308 SHA256 d8ef422924e24317122524fb1d1e439d45ff9281a502a6258a782cfe0d8c8eaa SHA512 ca345a2cd2d8df72ad1f8de366ba290a21f0f3a98ac098d0393d66ec43334258e1e7222a19f89de9a53f152fe4c63aab1221dc045efee94385299fc63e65a931 WHIRLPOOL 418c43f8447abe1740f25129637e3571a66a7fb371db53a86b7a6fe70c56b44f047310c76bd9858f41dd8bee5d39169832a87517fe2535a12bff19cc83d73e43
+EBUILD kio-stash-1.0.ebuild 685 SHA256 f30c1657676a6e7fb742a76eba6f8b1fcb9bf4601ffd4d20d20ffa458bf201eb SHA512 08b00e94fa69a5f3cbfc6bc2525246d0ea72f7e91d164923dee28ea818dd1e19b9eafef14ee452a627d75fb7f53e8f78353bfd839e26ca02ef5bf6bbf1ed2c1f WHIRLPOOL acd19ac3e207533a585c623454e61595f67bc8ce4ec3e5c2895605f1700971e205142214485b1e4d6e9a3a253dd464a75b64d5e70767296c17226f8a52f22fc2
+MISC metadata.xml 249 SHA256 584f1dcf51866dc24a9abf7a89bfba0fad11dde81ae1c1b715da41770d233c99 SHA512 76a5a340b13f0053ca3c5e94ed24380ea8d29b45ac8655419e22eaadb1e4a827c04d2e7e36b65145c4964e6526f656618fc6ac144e277ef53cb7373e6239e3c3 WHIRLPOOL 200c07a8bf7c55b11b7936d5cd30e991a511684913334e72f59def66c0ced5fed0b4a8754e2d98bffbab631cb90d4e17fcccc59d5dcc5a8e988f69e47c85518c
diff --git a/kde-misc/kio-stash/files/kio-stash-1.0-no-kf5config.patch b/kde-misc/kio-stash/files/kio-stash-1.0-no-kf5config.patch
new file mode 100644
index 000000000000..1e434bb625ea
--- /dev/null
+++ b/kde-misc/kio-stash/files/kio-stash-1.0-no-kf5config.patch
@@ -0,0 +1,43 @@
+commit 624a1f38b9604def78c34e26ac31e1fd21c6673b
+Author: Andreas Sturmlechner <andreas.sturmlechner@gmail.com>
+Date: Mon Jul 3 20:36:41 2017 +0200
+
+ Drop unused KF5Config dependency
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 0cbd710..1552df6 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -27,7 +27,6 @@ find_package(Qt5 ${QT5_MIN_VERSION} REQUIRED COMPONENTS
+ )
+
+ find_package(KF5 ${KF5_MIN_VERSION} REQUIRED COMPONENTS
+- Config
+ KIO
+ DBusAddons
+ I18n
+diff --git a/src/ioslave/CMakeLists.txt b/src/ioslave/CMakeLists.txt
+index 462fef9..23922f8 100644
+--- a/src/ioslave/CMakeLists.txt
++++ b/src/ioslave/CMakeLists.txt
+@@ -6,8 +6,6 @@ target_link_libraries (kio_filestash
+ Qt5::DBus
+ KF5::KIOCore
+ KF5::I18n
+- KF5::ConfigCore
+- KF5::ConfigGui
+ )
+
+ set_target_properties(kio_filestash PROPERTIES OUTPUT_NAME "filestash")
+diff --git a/src/ioslave/ioslave.cpp b/src/ioslave/ioslave.cpp
+index b280f11..8928efb 100644
+--- a/src/ioslave/ioslave.cpp
++++ b/src/ioslave/ioslave.cpp
+@@ -34,7 +34,6 @@
+
+ #include <KProtocolManager>
+ #include <KLocalizedString>
+-#include <KConfigGroup>
+ #include <KFileItem>
+ #include <KIO/Job>
+
diff --git a/kde-misc/kio-stash/kio-stash-1.0.ebuild b/kde-misc/kio-stash/kio-stash-1.0.ebuild
new file mode 100644
index 000000000000..a0b34b7c1542
--- /dev/null
+++ b/kde-misc/kio-stash/kio-stash-1.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_TEST="forceoptional"
+inherit kde5
+
+DESCRIPTION="KIO Slave and daemon to stash discontinuous file selections"
+HOMEPAGE="http://arnavdhamija.com/blog/kio-stash-release.html https://quickgit.kde.org/?p=kio-stash.git"
+SRC_URI="mirror://kde/stable/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RESTRICT+=" test"
+
+DEPEND="
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kio)
+ $(add_qt_dep qtdbus)
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${P}-no-kf5config.patch" )
diff --git a/kde-misc/kio-stash/metadata.xml b/kde-misc/kio-stash/metadata.xml
new file mode 100644
index 000000000000..2fdbf33d963d
--- /dev/null
+++ b/kde-misc/kio-stash/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>kde@gentoo.org</email>
+ <name>Gentoo KDE Project</name>
+ </maintainer>
+</pkgmetadata>