summaryrefslogtreecommitdiff
path: root/gui-apps/waybar
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-08-18 18:16:17 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-08-18 18:16:17 +0100
commitfc637fb28da700da71ec2064d65ca5a7a31b9c6c (patch)
tree326613a08f25851c388715e205576a2e7d25dc4f /gui-apps/waybar
parentb24bd25253fe093f722ab576d29fdc41d04cb1ee (diff)
gentoo resync : 18.08.2019
Diffstat (limited to 'gui-apps/waybar')
-rw-r--r--gui-apps/waybar/Manifest4
-rw-r--r--gui-apps/waybar/metadata.xml26
-rw-r--r--gui-apps/waybar/waybar-0.7.2.ebuild58
-rw-r--r--gui-apps/waybar/waybar-9999.ebuild58
4 files changed, 146 insertions, 0 deletions
diff --git a/gui-apps/waybar/Manifest b/gui-apps/waybar/Manifest
new file mode 100644
index 000000000000..0091a7abf7cc
--- /dev/null
+++ b/gui-apps/waybar/Manifest
@@ -0,0 +1,4 @@
+DIST waybar-0.7.2.tar.gz 101206 BLAKE2B d44b46c840094340e1e5f70d4ef3d01faf483a8c744ce6b549c1fa8767bf455c4c0ef67b564c61795e44c652d37c09848cce6f50ee3664de73477da6b4bce84e SHA512 d83f92d0111cdd01b276907fad18344dbf35be1e0bbbce2208f928e0d5e0fcccfa65ff2279de5a7e4dad5f04a6c99521670d75d65e32a0382bec2bf32eea00e2
+EBUILD waybar-0.7.2.ebuild 1306 BLAKE2B 2b228ed2e336e1a189c9133e52a8fa1b787655948e53282e77bd03f3c278306c9296bb2cb3ae822d925f8f4d1d122cd9445e7a84de83e20e8b3dd06f4d8b2179 SHA512 62faf6e28f4f5ee0aa25557bffc898357a169f30b87f59baa598403c92e58f8e7574b2c3a58aa48eb353ebac9d44ce1db746ab715ec75f45b3de0ad4526681a4
+EBUILD waybar-9999.ebuild 1306 BLAKE2B 2b228ed2e336e1a189c9133e52a8fa1b787655948e53282e77bd03f3c278306c9296bb2cb3ae822d925f8f4d1d122cd9445e7a84de83e20e8b3dd06f4d8b2179 SHA512 62faf6e28f4f5ee0aa25557bffc898357a169f30b87f59baa598403c92e58f8e7574b2c3a58aa48eb353ebac9d44ce1db746ab715ec75f45b3de0ad4526681a4
+MISC metadata.xml 1090 BLAKE2B 5715f34c1493cb3c3b32697c30abe64c40dd28eec3cac3db8bd9c12b288c11d32ed21b8e11f744b8d9401965e29807a2126885f441f038e923b6c2357b8adea7 SHA512 b8dd49c8c049fcc4bf914e1aaa3ec178f59a3cb1094bb0130b2127016033fd2fb1e684e263412d1527159569c899dbe1720ccb5886dc31cb7a54da4f72ccabea
diff --git a/gui-apps/waybar/metadata.xml b/gui-apps/waybar/metadata.xml
new file mode 100644
index 000000000000..3ff34b03135a
--- /dev/null
+++ b/gui-apps/waybar/metadata.xml
@@ -0,0 +1,26 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>bernardo@standard.ai</email>
+ <name>Bernardo Meurer</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>bman@gentoo.org</email>
+ <name>Aaron Bauman</name>
+ </maintainer>
+ <longdescription lang="en">
+ Highly customizable Wayland bar for Sway and Wlroots based compositors.
+ </longdescription>
+ <use>
+ <flag name="libcxx">Build with Clang's libc++ instead of libstdc++ on Linux.</flag>
+ <flag name="mpd">Enable support for the Music Player Daemon</flag>
+ <flag name="network">Enable libnl support for network related features</flag>
+ <flag name="tray">Enable support for tray</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">Alexays/Waybar</remote-id>
+ <bugs-to>https://github.com/Alexays/Waybar/issues</bugs-to>
+ <changelog>https://github.com/Alexays/Waybar/releases</changelog>
+ </upstream>
+</pkgmetadata>
diff --git a/gui-apps/waybar/waybar-0.7.2.ebuild b/gui-apps/waybar/waybar-0.7.2.ebuild
new file mode 100644
index 000000000000..fc844ec121d2
--- /dev/null
+++ b/gui-apps/waybar/waybar-0.7.2.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="Highly customizable Wayland bar for Sway and Wlroots based compositors."
+HOMEPAGE="https://github.com/Alexays/Waybar"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Alexays/${PN^}.git"
+else
+ SRC_URI="https://github.com/Alexays/${PN^}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="libcxx mpd network pulseaudio tray +udev"
+
+DEPEND="
+ dev-cpp/gtkmm:3.0
+ dev-libs/jsoncpp:=
+ dev-libs/libinput:=
+ dev-libs/libsigc++:2
+ >=dev-libs/libfmt-5.3.0:=
+ >=dev-libs/spdlog-1.3.1:=
+ dev-libs/wayland
+ dev-libs/wayland-protocols
+ gui-libs/wlroots
+ libcxx? ( sys-libs/libcxx )
+ mpd? ( media-libs/libmpdclient )
+ network? ( dev-libs/libnl:3 )
+ pulseaudio? ( media-sound/pulseaudio )
+ tray? ( dev-libs/libdbusmenu[gtk3] )
+ udev? ( virtual/libudev:= )"
+
+RDEPEND="${DEPEND}"
+
+BDEPEND="virtual/pkgconfig"
+
+if [[ ${PV} != 9999 ]]; then
+ S="${WORKDIR}/${PN^}-${PV}"
+fi
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use libcxx)
+ $(meson_feature mpd)
+ $(meson_feature network libnl)
+ $(meson_feature pulseaudio)
+ $(meson_feature tray dbusmenu-gtk)
+ $(meson_feature udev libudev)
+ )
+ meson_src_configure
+}
diff --git a/gui-apps/waybar/waybar-9999.ebuild b/gui-apps/waybar/waybar-9999.ebuild
new file mode 100644
index 000000000000..fc844ec121d2
--- /dev/null
+++ b/gui-apps/waybar/waybar-9999.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="Highly customizable Wayland bar for Sway and Wlroots based compositors."
+HOMEPAGE="https://github.com/Alexays/Waybar"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Alexays/${PN^}.git"
+else
+ SRC_URI="https://github.com/Alexays/${PN^}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="libcxx mpd network pulseaudio tray +udev"
+
+DEPEND="
+ dev-cpp/gtkmm:3.0
+ dev-libs/jsoncpp:=
+ dev-libs/libinput:=
+ dev-libs/libsigc++:2
+ >=dev-libs/libfmt-5.3.0:=
+ >=dev-libs/spdlog-1.3.1:=
+ dev-libs/wayland
+ dev-libs/wayland-protocols
+ gui-libs/wlroots
+ libcxx? ( sys-libs/libcxx )
+ mpd? ( media-libs/libmpdclient )
+ network? ( dev-libs/libnl:3 )
+ pulseaudio? ( media-sound/pulseaudio )
+ tray? ( dev-libs/libdbusmenu[gtk3] )
+ udev? ( virtual/libudev:= )"
+
+RDEPEND="${DEPEND}"
+
+BDEPEND="virtual/pkgconfig"
+
+if [[ ${PV} != 9999 ]]; then
+ S="${WORKDIR}/${PN^}-${PV}"
+fi
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use libcxx)
+ $(meson_feature mpd)
+ $(meson_feature network libnl)
+ $(meson_feature pulseaudio)
+ $(meson_feature tray dbusmenu-gtk)
+ $(meson_feature udev libudev)
+ )
+ meson_src_configure
+}