summaryrefslogtreecommitdiff
path: root/gui-apps
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-08-18 18:16:17 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-08-18 18:16:17 +0100
commitfc637fb28da700da71ec2064d65ca5a7a31b9c6c (patch)
tree326613a08f25851c388715e205576a2e7d25dc4f /gui-apps
parentb24bd25253fe093f722ab576d29fdc41d04cb1ee (diff)
gentoo resync : 18.08.2019
Diffstat (limited to 'gui-apps')
-rw-r--r--gui-apps/Manifest.gzbin1051 -> 1543 bytes
-rw-r--r--gui-apps/grim/Manifest4
-rw-r--r--gui-apps/grim/grim-1.2.0.ebuild44
-rw-r--r--gui-apps/grim/grim-9999.ebuild44
-rw-r--r--gui-apps/grim/metadata.xml24
-rw-r--r--gui-apps/slurp/Manifest4
-rw-r--r--gui-apps/slurp/metadata.xml23
-rw-r--r--gui-apps/slurp/slurp-1.2.0.ebuild42
-rw-r--r--gui-apps/slurp/slurp-9999.ebuild38
-rw-r--r--gui-apps/swayidle/Manifest2
-rw-r--r--gui-apps/swayidle/swayidle-1.5.ebuild4
-rw-r--r--gui-apps/waybar/Manifest4
-rw-r--r--gui-apps/waybar/metadata.xml26
-rw-r--r--gui-apps/waybar/waybar-0.7.2.ebuild58
-rw-r--r--gui-apps/waybar/waybar-9999.ebuild58
15 files changed, 372 insertions, 3 deletions
diff --git a/gui-apps/Manifest.gz b/gui-apps/Manifest.gz
index 44b38e4a8246..fbbae298e37b 100644
--- a/gui-apps/Manifest.gz
+++ b/gui-apps/Manifest.gz
Binary files differ
diff --git a/gui-apps/grim/Manifest b/gui-apps/grim/Manifest
new file mode 100644
index 000000000000..5ee9c1e1b248
--- /dev/null
+++ b/gui-apps/grim/Manifest
@@ -0,0 +1,4 @@
+DIST grim-1.2.0.tar.gz 14445 BLAKE2B e833afe5e57768e269ece0d7f99653810424449840867a37f02db4645a0dedd7829241d24a39ca00e844505ab5d2408891aac325e7f6ddd2011884fee240b44b SHA512 d58e392f00b93e031fd46a9e0175aaa5c3ce4fafb2afa3cc97ff28a9f77fc5583774f6ddf86295262749c00dd7c4e98c6041588bfa6fd70319ddfce6b903414e
+EBUILD grim-1.2.0.ebuild 865 BLAKE2B 1c444c860c77a34c402170ae6e11d3842892771acb8edef033ffb555174a3d23e6d52eebc4213fbed2180d69ef44ca4f2dc1e22b5327bb745be27c179c764f5d SHA512 a4edacbae42d0193a0b33f469ef905d078b2aa60ae1b267ac4614965bae7d6c91d0af174e8e5678b7debc6026fa42a301ff10127a5843f232f86a789804b400b
+EBUILD grim-9999.ebuild 865 BLAKE2B 1c444c860c77a34c402170ae6e11d3842892771acb8edef033ffb555174a3d23e6d52eebc4213fbed2180d69ef44ca4f2dc1e22b5327bb745be27c179c764f5d SHA512 a4edacbae42d0193a0b33f469ef905d078b2aa60ae1b267ac4614965bae7d6c91d0af174e8e5678b7debc6026fa42a301ff10127a5843f232f86a789804b400b
+MISC metadata.xml 862 BLAKE2B 7ef2bd9fbcffafbaa9405c2a708617a9eaf08dc28f694f288a875c5ebd2bf4cd3cecbe1e17387ba1a4181b34f31cf54881573b11f58e3d66ddad14c0c9356f56 SHA512 ce02ac38b4e866bec0d612659e6d65edf5e692a118e8f89145679c803e59af9610236fd0e581c3a9468f3278436f2f1f41ef8dab2092f7bc3d2e09a43bfb1406
diff --git a/gui-apps/grim/grim-1.2.0.ebuild b/gui-apps/grim/grim-1.2.0.ebuild
new file mode 100644
index 000000000000..818ccfb4b9e2
--- /dev/null
+++ b/gui-apps/grim/grim-1.2.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="Grab images from a Wayland compositor."
+HOMEPAGE="https://github.com/emersion/grim"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/emersion/${PN}.git"
+else
+ SRC_URI="https://github.com/emersion/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="+man jpeg"
+
+DEPEND="
+ >=dev-libs/wayland-protocols-1.14
+ dev-libs/wayland
+ jpeg? ( virtual/jpeg )
+ x11-libs/cairo"
+
+RDEPEND="${DEPEND}"
+
+if [[ ${PV} == 9999 ]]; then
+ BDEPEND+="man? ( ~app-text/scdoc-9999 )"
+else
+ BDEPEND+="man? ( app-text/scdoc )"
+fi
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature jpeg)
+ $(meson_feature man man-pages)
+ "-Dwerror=false"
+ )
+ meson_src_configure
+}
diff --git a/gui-apps/grim/grim-9999.ebuild b/gui-apps/grim/grim-9999.ebuild
new file mode 100644
index 000000000000..818ccfb4b9e2
--- /dev/null
+++ b/gui-apps/grim/grim-9999.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="Grab images from a Wayland compositor."
+HOMEPAGE="https://github.com/emersion/grim"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/emersion/${PN}.git"
+else
+ SRC_URI="https://github.com/emersion/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="+man jpeg"
+
+DEPEND="
+ >=dev-libs/wayland-protocols-1.14
+ dev-libs/wayland
+ jpeg? ( virtual/jpeg )
+ x11-libs/cairo"
+
+RDEPEND="${DEPEND}"
+
+if [[ ${PV} == 9999 ]]; then
+ BDEPEND+="man? ( ~app-text/scdoc-9999 )"
+else
+ BDEPEND+="man? ( app-text/scdoc )"
+fi
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature jpeg)
+ $(meson_feature man man-pages)
+ "-Dwerror=false"
+ )
+ meson_src_configure
+}
diff --git a/gui-apps/grim/metadata.xml b/gui-apps/grim/metadata.xml
new file mode 100644
index 000000000000..24e0317c3dfa
--- /dev/null
+++ b/gui-apps/grim/metadata.xml
@@ -0,0 +1,24 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>bernardo@standard.ai</email>
+ <name>Bernardo Meurer</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>bman@gentoo.org</email>
+ <name>Aaron Bauman</name>
+ </maintainer>
+ <longdescription lang="en">
+ Grab images from a Wayland compositor.
+ </longdescription>
+ <use>
+ <flag name="jpeg">Enable JPEG support.</flag>
+ <flag name="man">Generate and install man pages.</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">emersion/grim</remote-id>
+ <bugs-to>https://github.com/emersion/grim/issues</bugs-to>
+ <changelog>https://github.com/emersion/grim/releases</changelog>
+ </upstream>
+</pkgmetadata>
diff --git a/gui-apps/slurp/Manifest b/gui-apps/slurp/Manifest
new file mode 100644
index 000000000000..f1c26d7a805a
--- /dev/null
+++ b/gui-apps/slurp/Manifest
@@ -0,0 +1,4 @@
+DIST slurp-1.2.0.tar.gz 15317 BLAKE2B 92de74abb54b2d53334e0f0c5d08b0b50e9c4583eb192226e38fcefa07cce2265f808ce81c04170e65d3c1209fa263352e3d70cc0a7cf745ed5e18d57c4d3af6 SHA512 443cd497049a5128e80a48c7b2afcc555a8d58a5eacc2dc6207058a9a399bc9e9804c7bca8b010af63f8be99000c05245720bd3e8cca248a74d5aa63a7faf4f9
+EBUILD slurp-1.2.0.ebuild 851 BLAKE2B a800a162e24f187d6034e55c84be3819edfc53d810282c59d864324c7912fc3b68ce05b3a2d25e62cb73ff13b8e2974079fa452b66d8227d6569f2aa0f776781 SHA512 643157353085abab70748739e4fa9f7f1d6abde60fa504fc405904170559d453fc829700fb45be423c3a9a7807feaa3a1ba531439763e8ad2d16817e02f64631
+EBUILD slurp-9999.ebuild 776 BLAKE2B 21ef37528c843b14519c19914f61da5e98e7e9428a5e1db06b0fec8696327cdc46b787bf9f968802ca13e96050d44cbff541eb2ad3a2f62010bd267a7a8c7523 SHA512 04ae9dff0514afb268ff4576f847b345917787a374b2624bb74525ab414c83db8543e9c87189026bb8d53f866f1672ef0c2bb950d6101cf4a0eda6c05fda5800
+MISC metadata.xml 849 BLAKE2B 1a92c4a9ea3e213f14e676e0f1ea494d6d97c9af099b28bf5281529c82513aada20f9d922565b41ff88589bb08e6634a774d30af92b530b722142994a06a3a35 SHA512 86c46c6c16e1c8f42a0eaddfd8887daab14ae05bff00383164b90f04c94fbb76fd653cdcce5462cd86f7bc339047c5d65f532301081f089e8b6a902d7a8a74ee
diff --git a/gui-apps/slurp/metadata.xml b/gui-apps/slurp/metadata.xml
new file mode 100644
index 000000000000..8308bbd5341c
--- /dev/null
+++ b/gui-apps/slurp/metadata.xml
@@ -0,0 +1,23 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>bernardo@standard.ai</email>
+ <name>Bernardo Meurer</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>bman@gentoo.org</email>
+ <name>Aaron Bauman</name>
+ </maintainer>
+ <longdescription lang="en">
+ Select a region in a Wayland compositor and print it to the standard output.
+ </longdescription>
+ <use>
+ <flag name="man">Generate and install man pages.</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">emersion/slurp</remote-id>
+ <bugs-to>https://github.com/emersion/slurp/issues</bugs-to>
+ <changelog>https://github.com/emersion/slurp/releases</changelog>
+ </upstream>
+</pkgmetadata>
diff --git a/gui-apps/slurp/slurp-1.2.0.ebuild b/gui-apps/slurp/slurp-1.2.0.ebuild
new file mode 100644
index 000000000000..c66a344b8153
--- /dev/null
+++ b/gui-apps/slurp/slurp-1.2.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="Select a region in a Wayland compositor and print it to the standard output."
+HOMEPAGE="https://github.com/emersion/slurp"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/emersion/${PN}.git"
+else
+ SRC_URI="https://github.com/emersion/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="+man"
+
+DEPEND="
+ >=dev-libs/wayland-protocols-1.14
+ dev-libs/wayland
+ x11-libs/cairo"
+
+RDEPEND="${DEPEND}"
+
+if [[ ${PV} == 9999 ]]; then
+ BDEPEND+="man? ( ~app-text/scdoc-9999 )"
+else
+ BDEPEND+="man? ( app-text/scdoc )"
+fi
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature man man-pages)
+ "-Dwerror=false"
+ )
+ meson_src_configure
+}
diff --git a/gui-apps/slurp/slurp-9999.ebuild b/gui-apps/slurp/slurp-9999.ebuild
new file mode 100644
index 000000000000..5c6fe52e5b6b
--- /dev/null
+++ b/gui-apps/slurp/slurp-9999.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="Select a region in a Wayland compositor and print it to the standard output."
+HOMEPAGE="https://github.com/emersion/slurp"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/emersion/${PN}.git"
+else
+ SRC_URI="https://github.com/emersion/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="+man"
+
+DEPEND="
+ >=dev-libs/wayland-protocols-1.14
+ dev-libs/wayland
+ x11-libs/cairo"
+
+RDEPEND="${DEPEND}"
+
+BDEPEND="man? ( ~app-text/scdoc-9999 )"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature man man-pages)
+ "-Dwerror=false"
+ )
+ meson_src_configure
+}
diff --git a/gui-apps/swayidle/Manifest b/gui-apps/swayidle/Manifest
index c5129fe36fc5..465c2ba65640 100644
--- a/gui-apps/swayidle/Manifest
+++ b/gui-apps/swayidle/Manifest
@@ -3,6 +3,6 @@ DIST swayidle-1.3.tar.gz 9714 BLAKE2B 2f57576be0fc9343c2dcacb0acbb06f105143e98e2
DIST swayidle-1.5.tar.gz 9715 BLAKE2B 85f4b2c4e813b8b17975e4c3f984e1eec1cdd64c2a81a4f0f829a5c788f26128c558f2028597ba180573b62d269501dd12bbf3009ee11be724bd5017fadc7855 SHA512 33bf73a3e8297770b301fb3a860a52d9ddc332eed0b84dbd78cfd94855e638bb116e365b825e3bec869b1f5e516f9c0c2b442ddb052dc937e9b31748b74a978e
EBUILD swayidle-1.2.ebuild 1327 BLAKE2B 8d8d05bed875eae6b86984e92051a8da8e52b0fef07e42d0459baaef18d5efd0fd043b7251fe717c1514b25e249d65f10c7b1ee7da756c07d63592722dd81d0c SHA512 c8d544b8f4549770a58f6663207a0af73eea7186c18234e78744b60b598ee998ddc1ab90ad416b8a5775ab99fdda4ed8d35e3df2aa68ee2e479462b5151e779c
EBUILD swayidle-1.3.ebuild 1327 BLAKE2B 8d8d05bed875eae6b86984e92051a8da8e52b0fef07e42d0459baaef18d5efd0fd043b7251fe717c1514b25e249d65f10c7b1ee7da756c07d63592722dd81d0c SHA512 c8d544b8f4549770a58f6663207a0af73eea7186c18234e78744b60b598ee998ddc1ab90ad416b8a5775ab99fdda4ed8d35e3df2aa68ee2e479462b5151e779c
-EBUILD swayidle-1.5.ebuild 1383 BLAKE2B ce14d6f7ab11ede2352b5d6c1594ed3e3a0c61880077b56db4953be93202e40d294aea01126e0200f3d4b68595fd824f16e7cc0c17f3af1cc2f2afb5de35c593 SHA512 a4dd99e88849ad756ba68b2290cea3e4723cd130c66231fb4aa062e720cf2adddd299b54915f7b56f7104dd4f31a9b95482f279aecb3c7bc666b069ce77ac6b7
+EBUILD swayidle-1.5.ebuild 1327 BLAKE2B 8d8d05bed875eae6b86984e92051a8da8e52b0fef07e42d0459baaef18d5efd0fd043b7251fe717c1514b25e249d65f10c7b1ee7da756c07d63592722dd81d0c SHA512 c8d544b8f4549770a58f6663207a0af73eea7186c18234e78744b60b598ee998ddc1ab90ad416b8a5775ab99fdda4ed8d35e3df2aa68ee2e479462b5151e779c
EBUILD swayidle-9999.ebuild 1330 BLAKE2B 79fceac111b432e684b932303e55e92cbeb06f8a4f2210911e2c43f347b88e3d5924b8d17fdac06e081c86aa004d5124c63d1a16c40d7e5954ed353911734588 SHA512 3208a10066102103291b349c6251cfb4a3c7b8680f0315b7f57226d16131d0300c60acaef296e56a83aa586af768efb5d55b8dacd952c48faee16a773fed8cde
MISC metadata.xml 1067 BLAKE2B 059ead0c34aebcaa6f8ebd10db8b9b0aaf2df66f84a6ae10d16f3a32d680426aa4733c0788dfe61532bb90d3b92f4bb451e7fd1be822c6866205575fd3c4861a SHA512 99a60f4bcfb76aa7d2a6d4d2a7a6879d9f0ac17f0be3e37d59bef4a4b158b9e685dd5932a02e650b96756dc7f6cba2aac9b1eee95c6d56f4429c23e32a101ad4
diff --git a/gui-apps/swayidle/swayidle-1.5.ebuild b/gui-apps/swayidle/swayidle-1.5.ebuild
index ac8f006b415e..b4a51c1048ea 100644
--- a/gui-apps/swayidle/swayidle-1.5.ebuild
+++ b/gui-apps/swayidle/swayidle-1.5.ebuild
@@ -1,4 +1,4 @@
-#wayidle-1.3.ebuild 2019-07-09 14:35:07.685881181 -0500Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -13,7 +13,7 @@ if [[ ${PV} == 9999 ]]; then
EGIT_REPO_URI="https://github.com/swaywm/${PN}.git"
else
SRC_URI="https://github.com/swaywm/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~arm64 ~x86"
+ KEYWORDS="amd64 arm64 x86"
fi
LICENSE="MIT"
diff --git a/gui-apps/waybar/Manifest b/gui-apps/waybar/Manifest
new file mode 100644
index 000000000000..0091a7abf7cc
--- /dev/null
+++ b/gui-apps/waybar/Manifest
@@ -0,0 +1,4 @@
+DIST waybar-0.7.2.tar.gz 101206 BLAKE2B d44b46c840094340e1e5f70d4ef3d01faf483a8c744ce6b549c1fa8767bf455c4c0ef67b564c61795e44c652d37c09848cce6f50ee3664de73477da6b4bce84e SHA512 d83f92d0111cdd01b276907fad18344dbf35be1e0bbbce2208f928e0d5e0fcccfa65ff2279de5a7e4dad5f04a6c99521670d75d65e32a0382bec2bf32eea00e2
+EBUILD waybar-0.7.2.ebuild 1306 BLAKE2B 2b228ed2e336e1a189c9133e52a8fa1b787655948e53282e77bd03f3c278306c9296bb2cb3ae822d925f8f4d1d122cd9445e7a84de83e20e8b3dd06f4d8b2179 SHA512 62faf6e28f4f5ee0aa25557bffc898357a169f30b87f59baa598403c92e58f8e7574b2c3a58aa48eb353ebac9d44ce1db746ab715ec75f45b3de0ad4526681a4
+EBUILD waybar-9999.ebuild 1306 BLAKE2B 2b228ed2e336e1a189c9133e52a8fa1b787655948e53282e77bd03f3c278306c9296bb2cb3ae822d925f8f4d1d122cd9445e7a84de83e20e8b3dd06f4d8b2179 SHA512 62faf6e28f4f5ee0aa25557bffc898357a169f30b87f59baa598403c92e58f8e7574b2c3a58aa48eb353ebac9d44ce1db746ab715ec75f45b3de0ad4526681a4
+MISC metadata.xml 1090 BLAKE2B 5715f34c1493cb3c3b32697c30abe64c40dd28eec3cac3db8bd9c12b288c11d32ed21b8e11f744b8d9401965e29807a2126885f441f038e923b6c2357b8adea7 SHA512 b8dd49c8c049fcc4bf914e1aaa3ec178f59a3cb1094bb0130b2127016033fd2fb1e684e263412d1527159569c899dbe1720ccb5886dc31cb7a54da4f72ccabea
diff --git a/gui-apps/waybar/metadata.xml b/gui-apps/waybar/metadata.xml
new file mode 100644
index 000000000000..3ff34b03135a
--- /dev/null
+++ b/gui-apps/waybar/metadata.xml
@@ -0,0 +1,26 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>bernardo@standard.ai</email>
+ <name>Bernardo Meurer</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>bman@gentoo.org</email>
+ <name>Aaron Bauman</name>
+ </maintainer>
+ <longdescription lang="en">
+ Highly customizable Wayland bar for Sway and Wlroots based compositors.
+ </longdescription>
+ <use>
+ <flag name="libcxx">Build with Clang's libc++ instead of libstdc++ on Linux.</flag>
+ <flag name="mpd">Enable support for the Music Player Daemon</flag>
+ <flag name="network">Enable libnl support for network related features</flag>
+ <flag name="tray">Enable support for tray</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">Alexays/Waybar</remote-id>
+ <bugs-to>https://github.com/Alexays/Waybar/issues</bugs-to>
+ <changelog>https://github.com/Alexays/Waybar/releases</changelog>
+ </upstream>
+</pkgmetadata>
diff --git a/gui-apps/waybar/waybar-0.7.2.ebuild b/gui-apps/waybar/waybar-0.7.2.ebuild
new file mode 100644
index 000000000000..fc844ec121d2
--- /dev/null
+++ b/gui-apps/waybar/waybar-0.7.2.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="Highly customizable Wayland bar for Sway and Wlroots based compositors."
+HOMEPAGE="https://github.com/Alexays/Waybar"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Alexays/${PN^}.git"
+else
+ SRC_URI="https://github.com/Alexays/${PN^}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="libcxx mpd network pulseaudio tray +udev"
+
+DEPEND="
+ dev-cpp/gtkmm:3.0
+ dev-libs/jsoncpp:=
+ dev-libs/libinput:=
+ dev-libs/libsigc++:2
+ >=dev-libs/libfmt-5.3.0:=
+ >=dev-libs/spdlog-1.3.1:=
+ dev-libs/wayland
+ dev-libs/wayland-protocols
+ gui-libs/wlroots
+ libcxx? ( sys-libs/libcxx )
+ mpd? ( media-libs/libmpdclient )
+ network? ( dev-libs/libnl:3 )
+ pulseaudio? ( media-sound/pulseaudio )
+ tray? ( dev-libs/libdbusmenu[gtk3] )
+ udev? ( virtual/libudev:= )"
+
+RDEPEND="${DEPEND}"
+
+BDEPEND="virtual/pkgconfig"
+
+if [[ ${PV} != 9999 ]]; then
+ S="${WORKDIR}/${PN^}-${PV}"
+fi
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use libcxx)
+ $(meson_feature mpd)
+ $(meson_feature network libnl)
+ $(meson_feature pulseaudio)
+ $(meson_feature tray dbusmenu-gtk)
+ $(meson_feature udev libudev)
+ )
+ meson_src_configure
+}
diff --git a/gui-apps/waybar/waybar-9999.ebuild b/gui-apps/waybar/waybar-9999.ebuild
new file mode 100644
index 000000000000..fc844ec121d2
--- /dev/null
+++ b/gui-apps/waybar/waybar-9999.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="Highly customizable Wayland bar for Sway and Wlroots based compositors."
+HOMEPAGE="https://github.com/Alexays/Waybar"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Alexays/${PN^}.git"
+else
+ SRC_URI="https://github.com/Alexays/${PN^}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="libcxx mpd network pulseaudio tray +udev"
+
+DEPEND="
+ dev-cpp/gtkmm:3.0
+ dev-libs/jsoncpp:=
+ dev-libs/libinput:=
+ dev-libs/libsigc++:2
+ >=dev-libs/libfmt-5.3.0:=
+ >=dev-libs/spdlog-1.3.1:=
+ dev-libs/wayland
+ dev-libs/wayland-protocols
+ gui-libs/wlroots
+ libcxx? ( sys-libs/libcxx )
+ mpd? ( media-libs/libmpdclient )
+ network? ( dev-libs/libnl:3 )
+ pulseaudio? ( media-sound/pulseaudio )
+ tray? ( dev-libs/libdbusmenu[gtk3] )
+ udev? ( virtual/libudev:= )"
+
+RDEPEND="${DEPEND}"
+
+BDEPEND="virtual/pkgconfig"
+
+if [[ ${PV} != 9999 ]]; then
+ S="${WORKDIR}/${PN^}-${PV}"
+fi
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use libcxx)
+ $(meson_feature mpd)
+ $(meson_feature network libnl)
+ $(meson_feature pulseaudio)
+ $(meson_feature tray dbusmenu-gtk)
+ $(meson_feature udev libudev)
+ )
+ meson_src_configure
+}