summaryrefslogtreecommitdiff
path: root/gui-apps/swaybg/swaybg-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-05-04 12:02:00 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-05-04 12:02:00 +0100
commiteab5731cdf11d4ae8cdf111461d46fd96c5bdd37 (patch)
treece35c6d01b5ff5de95c3a20fef853b9a6518ad2e /gui-apps/swaybg/swaybg-9999.ebuild
parentb7ebc951da8800f711142f69d9d958bde67a112d (diff)
gentoo resync : 04.05.2019
Diffstat (limited to 'gui-apps/swaybg/swaybg-9999.ebuild')
-rw-r--r--gui-apps/swaybg/swaybg-9999.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/gui-apps/swaybg/swaybg-9999.ebuild b/gui-apps/swaybg/swaybg-9999.ebuild
new file mode 100644
index 000000000000..af2fdfa04742
--- /dev/null
+++ b/gui-apps/swaybg/swaybg-9999.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="A wallpaper utility for Wayland"
+HOMEPAGE="https://github.com/swaywm/swaybg"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/swaywm/${PN}.git"
+else
+ SRC_URI="https://github.com/swaywm/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="+man"
+
+DEPEND="
+ dev-libs/wayland
+"
+RDEPEND="
+ ${DEPEND}
+ !<gui-wm/sway-1.1_alpha1
+"
+BDEPEND="
+ >=dev-libs/wayland-protocols-1.14
+ x11-libs/gdk-pixbuf
+ x11-libs/cairo
+ virtual/pkgconfig
+ man? ( app-text/scdoc )
+"
+
+src_configure() {
+ local emesonargs=(
+ -Dman-pages=$(usex man enabled disabled)
+ "-Dwerror=false"
+ )
+
+ meson_src_configure
+}