summaryrefslogtreecommitdiff
path: root/gui-apps/swaybg
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-05-04 12:02:00 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-05-04 12:02:00 +0100
commiteab5731cdf11d4ae8cdf111461d46fd96c5bdd37 (patch)
treece35c6d01b5ff5de95c3a20fef853b9a6518ad2e /gui-apps/swaybg
parentb7ebc951da8800f711142f69d9d958bde67a112d (diff)
gentoo resync : 04.05.2019
Diffstat (limited to 'gui-apps/swaybg')
-rw-r--r--gui-apps/swaybg/Manifest4
-rw-r--r--gui-apps/swaybg/metadata.xml28
-rw-r--r--gui-apps/swaybg/swaybg-1.0.ebuild45
-rw-r--r--gui-apps/swaybg/swaybg-9999.ebuild45
4 files changed, 122 insertions, 0 deletions
diff --git a/gui-apps/swaybg/Manifest b/gui-apps/swaybg/Manifest
new file mode 100644
index 000000000000..54d888231f30
--- /dev/null
+++ b/gui-apps/swaybg/Manifest
@@ -0,0 +1,4 @@
+DIST swaybg-1.0.tar.gz 15851 BLAKE2B 820edbce4161f2d109bc8e842fb2bef101a5793d1da90f4258e5771fe85ab089e184c063a0a7073adbe218c59307946f86bd02c4d62b0585aeb3f9cd5c7963f8 SHA512 67d0e0109b906ece51800729182940374cc59fa07d0866b57cf876d12191fe12e796b84350a849dc85183fa58a3b2d196191e48dcc03dcc3708a980ed4a8cff0
+EBUILD swaybg-1.0.ebuild 806 BLAKE2B 12b1dca5a0e6ac37c752ff068f785f490fd467c698b052656a1ed80f4e5d22c14b97f264b07b2016e7e12a12d8595dad1fddf2c3d72c8571827116ee0fd56354 SHA512 a1dfe9bbb8bb4051c56ef2f3b6d3a0b5dd70ff73ff4ec7e90dae7f8d8640d47d03d5021874469bc585c1058acef783a27ee743c4b26cec57352cf291c86d3400
+EBUILD swaybg-9999.ebuild 806 BLAKE2B 12b1dca5a0e6ac37c752ff068f785f490fd467c698b052656a1ed80f4e5d22c14b97f264b07b2016e7e12a12d8595dad1fddf2c3d72c8571827116ee0fd56354 SHA512 a1dfe9bbb8bb4051c56ef2f3b6d3a0b5dd70ff73ff4ec7e90dae7f8d8640d47d03d5021874469bc585c1058acef783a27ee743c4b26cec57352cf291c86d3400
+MISC metadata.xml 943 BLAKE2B bee5990db9047cfa3f362a6d576f6d932e247e0235a04b83f427b5c9048e822a193585719e1d65747cc8f97d6b1f44f2435b9e956412b8fe707401fa492215bb SHA512 7d4b7910ef0d43041f899b608f351ef834870f8a7f1b9081c08e6ac197f65b9c7dc53e6785b7b9250ec7c3ee2200ee69b711a24c672c8bd3ceee381d5568756a
diff --git a/gui-apps/swaybg/metadata.xml b/gui-apps/swaybg/metadata.xml
new file mode 100644
index 000000000000..4708ce6a7966
--- /dev/null
+++ b/gui-apps/swaybg/metadata.xml
@@ -0,0 +1,28 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>prometheanfire@gentoo.org</email>
+ <name>Matthew Thode</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>speedjack95@gmail.com</email>
+ <name>Niccolò Scatena</name>
+ </maintainer>
+ <longdescription lang="en">
+ Sway's wallpaper utility, compatible with any Wayland compositor
+ which implements the wlr-layer-shell, xdg-output and xdg-shell protocols.
+ </longdescription>
+ <use>
+ <flag name="man">Build and install man pages</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">swaywm/swaybg</remote-id>
+ <maintainer status="active">
+ <email>sir@cmpwn.com</email>
+ <name>Drew DeVault</name>
+ </maintainer>
+ <bugs-to>https://github.com/swaywm/swaybg/issues</bugs-to>
+ <changelog>https://github.com/swaywm/swaybg/releases</changelog>
+ </upstream>
+</pkgmetadata>
diff --git a/gui-apps/swaybg/swaybg-1.0.ebuild b/gui-apps/swaybg/swaybg-1.0.ebuild
new file mode 100644
index 000000000000..af2fdfa04742
--- /dev/null
+++ b/gui-apps/swaybg/swaybg-1.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="A wallpaper utility for Wayland"
+HOMEPAGE="https://github.com/swaywm/swaybg"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/swaywm/${PN}.git"
+else
+ SRC_URI="https://github.com/swaywm/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="+man"
+
+DEPEND="
+ dev-libs/wayland
+"
+RDEPEND="
+ ${DEPEND}
+ !<gui-wm/sway-1.1_alpha1
+"
+BDEPEND="
+ >=dev-libs/wayland-protocols-1.14
+ x11-libs/gdk-pixbuf
+ x11-libs/cairo
+ virtual/pkgconfig
+ man? ( app-text/scdoc )
+"
+
+src_configure() {
+ local emesonargs=(
+ -Dman-pages=$(usex man enabled disabled)
+ "-Dwerror=false"
+ )
+
+ meson_src_configure
+}
diff --git a/gui-apps/swaybg/swaybg-9999.ebuild b/gui-apps/swaybg/swaybg-9999.ebuild
new file mode 100644
index 000000000000..af2fdfa04742
--- /dev/null
+++ b/gui-apps/swaybg/swaybg-9999.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="A wallpaper utility for Wayland"
+HOMEPAGE="https://github.com/swaywm/swaybg"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/swaywm/${PN}.git"
+else
+ SRC_URI="https://github.com/swaywm/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="+man"
+
+DEPEND="
+ dev-libs/wayland
+"
+RDEPEND="
+ ${DEPEND}
+ !<gui-wm/sway-1.1_alpha1
+"
+BDEPEND="
+ >=dev-libs/wayland-protocols-1.14
+ x11-libs/gdk-pixbuf
+ x11-libs/cairo
+ virtual/pkgconfig
+ man? ( app-text/scdoc )
+"
+
+src_configure() {
+ local emesonargs=(
+ -Dman-pages=$(usex man enabled disabled)
+ "-Dwerror=false"
+ )
+
+ meson_src_configure
+}