summaryrefslogtreecommitdiff
path: root/gui-apps/grim
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-08-18 18:16:17 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-08-18 18:16:17 +0100
commitfc637fb28da700da71ec2064d65ca5a7a31b9c6c (patch)
tree326613a08f25851c388715e205576a2e7d25dc4f /gui-apps/grim
parentb24bd25253fe093f722ab576d29fdc41d04cb1ee (diff)
gentoo resync : 18.08.2019
Diffstat (limited to 'gui-apps/grim')
-rw-r--r--gui-apps/grim/Manifest4
-rw-r--r--gui-apps/grim/grim-1.2.0.ebuild44
-rw-r--r--gui-apps/grim/grim-9999.ebuild44
-rw-r--r--gui-apps/grim/metadata.xml24
4 files changed, 116 insertions, 0 deletions
diff --git a/gui-apps/grim/Manifest b/gui-apps/grim/Manifest
new file mode 100644
index 000000000000..5ee9c1e1b248
--- /dev/null
+++ b/gui-apps/grim/Manifest
@@ -0,0 +1,4 @@
+DIST grim-1.2.0.tar.gz 14445 BLAKE2B e833afe5e57768e269ece0d7f99653810424449840867a37f02db4645a0dedd7829241d24a39ca00e844505ab5d2408891aac325e7f6ddd2011884fee240b44b SHA512 d58e392f00b93e031fd46a9e0175aaa5c3ce4fafb2afa3cc97ff28a9f77fc5583774f6ddf86295262749c00dd7c4e98c6041588bfa6fd70319ddfce6b903414e
+EBUILD grim-1.2.0.ebuild 865 BLAKE2B 1c444c860c77a34c402170ae6e11d3842892771acb8edef033ffb555174a3d23e6d52eebc4213fbed2180d69ef44ca4f2dc1e22b5327bb745be27c179c764f5d SHA512 a4edacbae42d0193a0b33f469ef905d078b2aa60ae1b267ac4614965bae7d6c91d0af174e8e5678b7debc6026fa42a301ff10127a5843f232f86a789804b400b
+EBUILD grim-9999.ebuild 865 BLAKE2B 1c444c860c77a34c402170ae6e11d3842892771acb8edef033ffb555174a3d23e6d52eebc4213fbed2180d69ef44ca4f2dc1e22b5327bb745be27c179c764f5d SHA512 a4edacbae42d0193a0b33f469ef905d078b2aa60ae1b267ac4614965bae7d6c91d0af174e8e5678b7debc6026fa42a301ff10127a5843f232f86a789804b400b
+MISC metadata.xml 862 BLAKE2B 7ef2bd9fbcffafbaa9405c2a708617a9eaf08dc28f694f288a875c5ebd2bf4cd3cecbe1e17387ba1a4181b34f31cf54881573b11f58e3d66ddad14c0c9356f56 SHA512 ce02ac38b4e866bec0d612659e6d65edf5e692a118e8f89145679c803e59af9610236fd0e581c3a9468f3278436f2f1f41ef8dab2092f7bc3d2e09a43bfb1406
diff --git a/gui-apps/grim/grim-1.2.0.ebuild b/gui-apps/grim/grim-1.2.0.ebuild
new file mode 100644
index 000000000000..818ccfb4b9e2
--- /dev/null
+++ b/gui-apps/grim/grim-1.2.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="Grab images from a Wayland compositor."
+HOMEPAGE="https://github.com/emersion/grim"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/emersion/${PN}.git"
+else
+ SRC_URI="https://github.com/emersion/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="+man jpeg"
+
+DEPEND="
+ >=dev-libs/wayland-protocols-1.14
+ dev-libs/wayland
+ jpeg? ( virtual/jpeg )
+ x11-libs/cairo"
+
+RDEPEND="${DEPEND}"
+
+if [[ ${PV} == 9999 ]]; then
+ BDEPEND+="man? ( ~app-text/scdoc-9999 )"
+else
+ BDEPEND+="man? ( app-text/scdoc )"
+fi
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature jpeg)
+ $(meson_feature man man-pages)
+ "-Dwerror=false"
+ )
+ meson_src_configure
+}
diff --git a/gui-apps/grim/grim-9999.ebuild b/gui-apps/grim/grim-9999.ebuild
new file mode 100644
index 000000000000..818ccfb4b9e2
--- /dev/null
+++ b/gui-apps/grim/grim-9999.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="Grab images from a Wayland compositor."
+HOMEPAGE="https://github.com/emersion/grim"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/emersion/${PN}.git"
+else
+ SRC_URI="https://github.com/emersion/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="+man jpeg"
+
+DEPEND="
+ >=dev-libs/wayland-protocols-1.14
+ dev-libs/wayland
+ jpeg? ( virtual/jpeg )
+ x11-libs/cairo"
+
+RDEPEND="${DEPEND}"
+
+if [[ ${PV} == 9999 ]]; then
+ BDEPEND+="man? ( ~app-text/scdoc-9999 )"
+else
+ BDEPEND+="man? ( app-text/scdoc )"
+fi
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature jpeg)
+ $(meson_feature man man-pages)
+ "-Dwerror=false"
+ )
+ meson_src_configure
+}
diff --git a/gui-apps/grim/metadata.xml b/gui-apps/grim/metadata.xml
new file mode 100644
index 000000000000..24e0317c3dfa
--- /dev/null
+++ b/gui-apps/grim/metadata.xml
@@ -0,0 +1,24 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>bernardo@standard.ai</email>
+ <name>Bernardo Meurer</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>bman@gentoo.org</email>
+ <name>Aaron Bauman</name>
+ </maintainer>
+ <longdescription lang="en">
+ Grab images from a Wayland compositor.
+ </longdescription>
+ <use>
+ <flag name="jpeg">Enable JPEG support.</flag>
+ <flag name="man">Generate and install man pages.</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">emersion/grim</remote-id>
+ <bugs-to>https://github.com/emersion/grim/issues</bugs-to>
+ <changelog>https://github.com/emersion/grim/releases</changelog>
+ </upstream>
+</pkgmetadata>