summaryrefslogtreecommitdiff
path: root/games-util
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-03-19 11:37:34 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-03-19 11:37:34 +0000
commitb7b97785ebbb2f11d24d14dab8b81ed274f4ce6a (patch)
tree9fd110f9fc996e8a4213eeda994a8c112491b86d /games-util
parent066d27181e9a797ad9f8fc43b49fc9a10ff2f707 (diff)
gentoo resync : 19.03.2019
Diffstat (limited to 'games-util')
-rw-r--r--games-util/Manifest.gzbin7379 -> 7382 bytes
-rw-r--r--games-util/lutris/Manifest4
-rw-r--r--games-util/lutris/lutris-0.5.0.1-r1.ebuild75
-rw-r--r--games-util/lutris/lutris-9999.ebuild70
4 files changed, 116 insertions, 33 deletions
diff --git a/games-util/Manifest.gz b/games-util/Manifest.gz
index 1c3a9a9a853a..f6887f61ef84 100644
--- a/games-util/Manifest.gz
+++ b/games-util/Manifest.gz
Binary files differ
diff --git a/games-util/lutris/Manifest b/games-util/lutris/Manifest
index 2d4a381def4e..4f48ab6844ed 100644
--- a/games-util/lutris/Manifest
+++ b/games-util/lutris/Manifest
@@ -1,4 +1,6 @@
DIST lutris-0.4.23.tar.gz 1831736 BLAKE2B 9da20d5545e9d2474bed436443fed325beb3ed2e3e945cb27e25fbce88ac7aeb9547a0a1bcd74349e5c7bda0dd6be50949b5abaa1fc091a21217b330c6fe655f SHA512 a0860920e01568888db5ac9a52c0d33a5108af33906ea411d4621dec4b059c399b17ca35c245bf9bfb506c6b242d32d917d3ade6898f619e00f9361117632fb3
+DIST lutris_0.5.0.1.tar.xz 1687904 BLAKE2B 646182416201dd4e2fc025b600e569d87821ff98f2fc37ca6029479b7b097466e47135694303f8fc242c4d2632d0b4ecf471919181cd45b095bbff6ba8d973d4 SHA512 a9bf51f388859873de0af43b800692327b098c83966b9e32bbca3ccc0397e1ce5018e751b8f9fef5e83d9de4d1b014e330ffe7d8ab253af7dd2379151297f1bb
EBUILD lutris-0.4.23.ebuild 1381 BLAKE2B 4a4ed8bc414feda741c037df4c77c6b36ec27ab4d7b0dfe23e25125bb67c3487bf12139a7b4a8203b8c1fd6dda590806ec7724b49c750a3758b9a05120a9cb06 SHA512 8a1ff1fc83fd75aa42d1f424a8940373c6e982c66fb8360112358f96c49dd0e1b3b09ca31e0650ba1cee1c1aab98505705722e38bce52a23a8e6ae935b969bd4
-EBUILD lutris-9999.ebuild 1377 BLAKE2B 6228490d33bc2e502ed40995bf281813e5367300b7d189f68b287908bc4905001a4e6fb650f2d3c44aa763b1e4e28ba803d466ec8f344c62c8295133105812a7 SHA512 9894d39b9504ee331f7b171509b6cb7bafcec16e10613fe0742da169d82d3290df912bf8eecfa67cb24991d13a39f138f3dcdd59aa93123c6ed8cdf839b1be62
+EBUILD lutris-0.5.0.1-r1.ebuild 1651 BLAKE2B 128c3f5a8bd869998e44963dbf3e5e58f65c470e191c49642a37d884219b557895d92f6e0af03848cd68a1687b6430f862adb81db0774f925ac8497a83a989b2 SHA512 4f6c2bbd8aed5fd86983f901210545816fe2b6628e434a117636348aec23dfd5e140672a2eb5df69b274f1738ede41c3275a62dae8d05892969892949e069202
+EBUILD lutris-9999.ebuild 1612 BLAKE2B aa0a6d946e70f7675e25321deefa2807b0724748877f39fc9959bbb43f08bac0698200d5a4a78e18ae36248c89b9ff6a1a8ab797d0b9c06e68f5797ae8daf045 SHA512 e3e5e361d7997cd25d6341098f80384fb4a6cca49b2dac11ef2b107896aa7994689e30c6420ce822f4664825df0995845488dee4879c4a02422960ac22cfaecb
MISC metadata.xml 661 BLAKE2B 8b05694fe3755a3b2b1546c1392bccb408d99f430c361e6058702107d665b13e0d36834d37c2a31ab7065290363e6af7712fcf4b36542222b59e47b508b7d1ef SHA512 e5d7a7023e9aa025d8d526457ba61ec9d9ceadf472d3f04f6b799cb3c130543e4300a56ce1830c163650f0554e2a87d705152b3771bb4f7fd9edeba3db16b9a7
diff --git a/games-util/lutris/lutris-0.5.0.1-r1.ebuild b/games-util/lutris/lutris-0.5.0.1-r1.ebuild
new file mode 100644
index 000000000000..d6cbb9e6644a
--- /dev/null
+++ b/games-util/lutris/lutris-0.5.0.1-r1.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{4,5,6,7} )
+PYTHON_REQ_USE="sqlite,threads(+)"
+
+inherit distutils-r1 virtualx xdg
+
+DESCRIPTION="An open source gaming platform for GNU/Linux"
+HOMEPAGE="https://lutris.net/"
+
+if [[ ${PV} == *9999* ]] ; then
+ EGIT_REPO_URI="https://github.com/lutris/lutris.git"
+ inherit git-r3
+else
+ SRC_URI="https://lutris.net/releases/${P/-/_}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+
+BDEPEND="
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+"
+RDEPEND="
+ app-arch/cabextract
+ app-arch/p7zip
+ app-arch/unrar
+ app-arch/unzip
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/python-evdev[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ gnome-base/gnome-desktop[introspection]
+ media-sound/fluid-soundfont
+ net-libs/libsoup
+ net-libs/webkit-gtk:4[introspection]
+ x11-apps/xgamma
+ x11-apps/xrandr
+ x11-libs/gtk+:3[introspection]
+ x11-libs/libnotify
+"
+
+S="${WORKDIR}/${PN}"
+
+python_install_all() {
+ local DOCS=( AUTHORS README.rst docs/installers.rst )
+ distutils-r1_python_install_all
+}
+
+python_test() {
+ virtx nosetests -v || die
+}
+
+pkg_preinst() {
+ xdg_pkg_preinst
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ # Quote README.rst
+ elog "Lutris installations are fully automated through scripts, which can"
+ elog "be written in either JSON or YAML. The scripting syntax is described"
+ elog "in ${EROOT}/usr/share/doc/${PF}/installers.rst.bz2, and is also"
+ elog "available online at lutris.net."
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+}
diff --git a/games-util/lutris/lutris-9999.ebuild b/games-util/lutris/lutris-9999.ebuild
index 960cafec846a..fca79a193ebf 100644
--- a/games-util/lutris/lutris-9999.ebuild
+++ b/games-util/lutris/lutris-9999.ebuild
@@ -1,68 +1,74 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-PYTHON_COMPAT=( python3_{4,5,6} )
-PYTHON_REQ_USE="sqlite,threads"
+PYTHON_COMPAT=( python3_{4,5,6,7} )
+PYTHON_REQ_USE="sqlite,threads(+)"
-inherit distutils-r1 gnome2-utils python-r1
+inherit distutils-r1 virtualx xdg
-DESCRIPTION="Lutris is an open source gaming platform for GNU/Linux."
+DESCRIPTION="An open source gaming platform for GNU/Linux"
HOMEPAGE="https://lutris.net/"
-if [[ "${PV}" == "9999" ]] ; then
- EGIT_REPO_URI="https://github.com/lutris/${PN}.git"
+if [[ ${PV} == *9999* ]] ; then
+ EGIT_REPO_URI="https://github.com/lutris/lutris.git"
inherit git-r3
else
- SRC_URI="https://github.com/lutris/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ SRC_URI="https://lutris.net/releases/${P/-/_}.tar.xz"
KEYWORDS="~amd64 ~x86"
fi
LICENSE="GPL-3"
SLOT="0"
+BDEPEND="
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+"
RDEPEND="
- dev-python/dbus-python[${PYTHON_USEDEP}]
+ app-arch/cabextract
+ app-arch/p7zip
+ app-arch/unrar
+ app-arch/unzip
+ dev-python/pillow[${PYTHON_USEDEP}]
dev-python/pygobject:3[${PYTHON_USEDEP}]
dev-python/python-evdev[${PYTHON_USEDEP}]
dev-python/pyyaml[${PYTHON_USEDEP}]
+ gnome-base/gnome-desktop[introspection]
+ media-sound/fluid-soundfont
net-libs/libsoup
+ net-libs/webkit-gtk:4[introspection]
+ x11-apps/xgamma
x11-apps/xrandr
- x11-apps/xgamma"
+ x11-libs/gtk+:3[introspection]
+ x11-libs/libnotify
+"
-python_install() {
- distutils-r1_python_install
-}
-
-src_prepare() {
- distutils-r1_src_prepare
-}
+S="${WORKDIR}/${PN}"
-src_compile() {
- distutils-r1_src_compile
+python_install_all() {
+ local DOCS=( AUTHORS README.rst docs/installers.rst )
+ distutils-r1_python_install_all
}
-src_install() {
- # README.rst contains list of optional deps
- DOCS=( AUTHORS README.rst INSTALL.rst )
- distutils-r1_src_install
+python_test() {
+ virtx nosetests -v || die
}
pkg_preinst() {
- gnome2_icon_savelist
- gnome2_schemas_savelist
+ xdg_pkg_preinst
}
pkg_postinst() {
- gnome2_icon_cache_update
- gnome2_schemas_update
+ xdg_pkg_postinst
- elog "For a list of optional dependencies (runners) see:"
- elog "/usr/share/doc/${PF}/README.rst.bz2"
+ # Quote README.rst
+ elog "Lutris installations are fully automated through scripts, which can"
+ elog "be written in either JSON or YAML. The scripting syntax is described"
+ elog "in ${EROOT}/usr/share/doc/${PF}/installers.rst.bz2, and is also"
+ elog "available online at lutris.net."
}
pkg_postrm() {
- gnome2_icon_cache_update
- gnome2_schemas_update
+ xdg_pkg_postrm
}