summaryrefslogtreecommitdiff
path: root/games-util
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-03-03 13:42:34 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-03-03 13:42:34 +0000
commit066d27181e9a797ad9f8fc43b49fc9a10ff2f707 (patch)
tree3cb05783d73b2c33589ba305144a31c718e123cd /games-util
parent16449a80e28af2209916cc66d19c9a44ca2b90d9 (diff)
gentoo resync : 03.03.2019
Diffstat (limited to 'games-util')
-rw-r--r--games-util/Manifest.gzbin7379 -> 7379 bytes
-rw-r--r--games-util/joystick/Manifest2
-rw-r--r--games-util/joystick/joystick-1.6.1.ebuild41
-rw-r--r--games-util/lutris/Manifest4
-rw-r--r--games-util/lutris/lutris-0.4.14.ebuild68
-rw-r--r--games-util/lutris/lutris-0.4.23.ebuild59
6 files changed, 104 insertions, 70 deletions
diff --git a/games-util/Manifest.gz b/games-util/Manifest.gz
index 1424120f9ac3..1c3a9a9a853a 100644
--- a/games-util/Manifest.gz
+++ b/games-util/Manifest.gz
Binary files differ
diff --git a/games-util/joystick/Manifest b/games-util/joystick/Manifest
index 438275836543..7824607915cd 100644
--- a/games-util/joystick/Manifest
+++ b/games-util/joystick/Manifest
@@ -1,5 +1,7 @@
AUX joystick-1.4.8-udev.patch 1724 BLAKE2B 63fd913ee85bbcdb00ccf8150dcccca4f2f6c36ef274b04dffd78aaaf9906048368495855edaa8809f371b7f63320ad89b3c40f94242b8d1f4316ab04a4eece6 SHA512 8a00825c9fb293e174eace79b1ce08af9eb2c6e18450daa62ae67b7c6a49ebe6b2490de4ccc7c1177edb300ed361a0920773b14d90c1aae4a34062ca16ad76de
AUX joystick-1.6.0-build.patch 831 BLAKE2B 942038f6997caa84cdbc8c05a6353dd448c1b70f9229f38084e2b8c80df2f8d3df3eb8a0da754a7ba56863aaed58375eec22267f08d304bd550d2237054f6e16 SHA512 071b15e16a1688e2d743dbf0bc44c784184ee93698b660394c83bed719d579952c9d73680e3e24754a41d5de69a65559b61255b0366c3437a193fc526c3d6064
DIST linuxconsoletools-1.6.0.tar.bz2 50563 BLAKE2B 26f68f4a9a4af5b875bc7efcc70edd80978a560f62c415b4957ee851260a2f6e6227c5a3001fb009777eac7e19d0449a8335486290ae0aaa9467ad8e1e9a89fb SHA512 35ca923cceca729bcbab95dff18682abd0d87a297e70aa8707fbabccde018fef0775a99195af4bf9111ba33210a14c10d1a766f83112cd535930a1ae430c7c75
+DIST linuxconsoletools-1.6.1.tar.bz2 50854 BLAKE2B 0614e72226c575499ae5976011a0fca146a1981e2d355f7554f105b184bdd4f1090bf5374377e89f3881c5476e3c3a362b70f86cfd83440264066ea50a8c6a4b SHA512 b520c0a2d55986204619e3a5a00fb8b1e26453ac6df4f51c8c87495661a68bb6fe5a1947a3e079a53a537bf06d23c73c404a4d7e4d4dd18c0f7f69c1985a77be
EBUILD joystick-1.6.0.ebuild 887 BLAKE2B 4884fd349de63ed785b16f5f094463619560a4bfeb59ad5b9b9a4b24fd3d47eb00dd285ec2b4957e544828e846a953b5c5b77a8dad1a65564ad38a84a10e0982 SHA512 53c67ffa860135221e573741ca2352fefed4b8284022b906383bf63775ea62b751792218c3f9dd36448c20346683d6ee657d9a91dc7f748506c2827b2db0c3f5
+EBUILD joystick-1.6.1.ebuild 841 BLAKE2B 88add5fc4038140e9af4fcceeac0efd19119285d467bc335dc89ed24e35a57c0b87f1af14989a8dd297654971b639a0ca076096c32ba4d137b22a1b9504d577b SHA512 a0ac620ef668b62951e2c317c59c615f5234b727ecf3fbffa3c47c02055f6d185b37649bdd8a2c992cf8abfc8f5cea72194cf9ad2211b4f12586234283ddc627
MISC metadata.xml 335 BLAKE2B e83ffecd1afda0861555f62d9bad50f99c8e1bebb296f303bbdb8624ea283eb04d30d76a74d9970f519e303e851991ae33b232f74c9d2fdacce16b59fccdf9f5 SHA512 6440a6652a98c7439b22df51f22089ddd867be3e07e6c04001aa15b1fc01fd84dc8d3244f106abe4ae89caf7561aa45fe2526f2f9e8e8844a5e44f9f8a51df41
diff --git a/games-util/joystick/joystick-1.6.1.ebuild b/games-util/joystick/joystick-1.6.1.ebuild
new file mode 100644
index 000000000000..389255caf332
--- /dev/null
+++ b/games-util/joystick/joystick-1.6.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit toolchain-funcs
+
+MY_P="linuxconsoletools-${PV}"
+DESCRIPTION="joystick testing utilities"
+HOMEPAGE="https://sourceforge.net/projects/linuxconsole/ http://atrey.karlin.mff.cuni.cz/~vojtech/input/"
+SRC_URI="mirror://sourceforge/linuxconsole/files/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="sdl udev"
+
+DEPEND="sdl? ( media-libs/libsdl:0[video] )
+ !<x11-libs/tslib-1.0-r2"
+RDEPEND="${DEPEND}
+ udev? ( virtual/udev )"
+
+S=${WORKDIR}/${MY_P}
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.6.0-build.patch
+)
+
+src_prepare() {
+ default
+
+ export PREFIX=/usr
+ tc-export CC PKG_CONFIG
+ export USE_SDL=$(usex sdl)
+}
+
+src_install() {
+ default
+ if ! use udev ; then
+ rm "${ED}"/usr/bin/jscal-{re,}store || die
+ fi
+}
diff --git a/games-util/lutris/Manifest b/games-util/lutris/Manifest
index 23946bb4a4c0..2d4a381def4e 100644
--- a/games-util/lutris/Manifest
+++ b/games-util/lutris/Manifest
@@ -1,4 +1,4 @@
-DIST lutris-0.4.14.tar.gz 1617493 BLAKE2B c97d0e31657252c4ae5c6718151f028d273831cdb9f21b748ada651686cf3aa51a618a007db87528d84f21dca292509399f9bb1f0c0444c57e369b13b9ae79a0 SHA512 d229d7f79b3395db22ad49abc02ca5e08db9465258be33fcefe743c0a099e1ca507b6b9c28f03d2a6857489f7f2e19fca38803f6876df88a96b060ed5f7f94bc
-EBUILD lutris-0.4.14.ebuild 1377 BLAKE2B 6228490d33bc2e502ed40995bf281813e5367300b7d189f68b287908bc4905001a4e6fb650f2d3c44aa763b1e4e28ba803d466ec8f344c62c8295133105812a7 SHA512 9894d39b9504ee331f7b171509b6cb7bafcec16e10613fe0742da169d82d3290df912bf8eecfa67cb24991d13a39f138f3dcdd59aa93123c6ed8cdf839b1be62
+DIST lutris-0.4.23.tar.gz 1831736 BLAKE2B 9da20d5545e9d2474bed436443fed325beb3ed2e3e945cb27e25fbce88ac7aeb9547a0a1bcd74349e5c7bda0dd6be50949b5abaa1fc091a21217b330c6fe655f SHA512 a0860920e01568888db5ac9a52c0d33a5108af33906ea411d4621dec4b059c399b17ca35c245bf9bfb506c6b242d32d917d3ade6898f619e00f9361117632fb3
+EBUILD lutris-0.4.23.ebuild 1381 BLAKE2B 4a4ed8bc414feda741c037df4c77c6b36ec27ab4d7b0dfe23e25125bb67c3487bf12139a7b4a8203b8c1fd6dda590806ec7724b49c750a3758b9a05120a9cb06 SHA512 8a1ff1fc83fd75aa42d1f424a8940373c6e982c66fb8360112358f96c49dd0e1b3b09ca31e0650ba1cee1c1aab98505705722e38bce52a23a8e6ae935b969bd4
EBUILD lutris-9999.ebuild 1377 BLAKE2B 6228490d33bc2e502ed40995bf281813e5367300b7d189f68b287908bc4905001a4e6fb650f2d3c44aa763b1e4e28ba803d466ec8f344c62c8295133105812a7 SHA512 9894d39b9504ee331f7b171509b6cb7bafcec16e10613fe0742da169d82d3290df912bf8eecfa67cb24991d13a39f138f3dcdd59aa93123c6ed8cdf839b1be62
MISC metadata.xml 661 BLAKE2B 8b05694fe3755a3b2b1546c1392bccb408d99f430c361e6058702107d665b13e0d36834d37c2a31ab7065290363e6af7712fcf4b36542222b59e47b508b7d1ef SHA512 e5d7a7023e9aa025d8d526457ba61ec9d9ceadf472d3f04f6b799cb3c130543e4300a56ce1830c163650f0554e2a87d705152b3771bb4f7fd9edeba3db16b9a7
diff --git a/games-util/lutris/lutris-0.4.14.ebuild b/games-util/lutris/lutris-0.4.14.ebuild
deleted file mode 100644
index 960cafec846a..000000000000
--- a/games-util/lutris/lutris-0.4.14.ebuild
+++ /dev/null
@@ -1,68 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_{4,5,6} )
-PYTHON_REQ_USE="sqlite,threads"
-
-inherit distutils-r1 gnome2-utils python-r1
-
-DESCRIPTION="Lutris is an open source gaming platform for GNU/Linux."
-HOMEPAGE="https://lutris.net/"
-
-if [[ "${PV}" == "9999" ]] ; then
- EGIT_REPO_URI="https://github.com/lutris/${PN}.git"
- inherit git-r3
-else
- SRC_URI="https://github.com/lutris/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
-fi
-
-LICENSE="GPL-3"
-SLOT="0"
-
-RDEPEND="
- dev-python/dbus-python[${PYTHON_USEDEP}]
- dev-python/pygobject:3[${PYTHON_USEDEP}]
- dev-python/python-evdev[${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP}]
- net-libs/libsoup
- x11-apps/xrandr
- x11-apps/xgamma"
-
-python_install() {
- distutils-r1_python_install
-}
-
-src_prepare() {
- distutils-r1_src_prepare
-}
-
-src_compile() {
- distutils-r1_src_compile
-}
-
-src_install() {
- # README.rst contains list of optional deps
- DOCS=( AUTHORS README.rst INSTALL.rst )
- distutils-r1_src_install
-}
-
-pkg_preinst() {
- gnome2_icon_savelist
- gnome2_schemas_savelist
-}
-
-pkg_postinst() {
- gnome2_icon_cache_update
- gnome2_schemas_update
-
- elog "For a list of optional dependencies (runners) see:"
- elog "/usr/share/doc/${PF}/README.rst.bz2"
-}
-
-pkg_postrm() {
- gnome2_icon_cache_update
- gnome2_schemas_update
-}
diff --git a/games-util/lutris/lutris-0.4.23.ebuild b/games-util/lutris/lutris-0.4.23.ebuild
new file mode 100644
index 000000000000..5f92d60797f1
--- /dev/null
+++ b/games-util/lutris/lutris-0.4.23.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{4,5,6,7} )
+PYTHON_REQ_USE="sqlite,threads(+)"
+
+inherit distutils-r1 virtualx xdg
+
+DESCRIPTION="An open source gaming platform for GNU/Linux"
+HOMEPAGE="https://lutris.net/"
+
+if [[ ${PV} == *9999* ]] ; then
+ EGIT_REPO_URI="https://github.com/lutris/${PN}.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/lutris/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+
+BDEPEND="
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+"
+RDEPEND="
+ app-arch/cabextract
+ app-arch/p7zip
+ app-arch/unrar
+ app-arch/unzip
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/python-evdev[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ net-libs/libsoup
+ x11-apps/xgamma
+ x11-apps/xrandr
+ x11-libs/gtk+:3[introspection]
+"
+
+python_install_all() {
+ local DOCS=( AUTHORS README.rst docs/installers.rst )
+ distutils-r1_python_install_all
+}
+
+python_test() {
+ virtx nosetests -v || die
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ # Quote README.rst
+ elog "Lutris installations are fully automated through scripts, which can"
+ elog "be written in either JSON or YAML. The scripting syntax is described"
+ elog "in ${EROOT%/}/usr/share/doc/${PF}/installers.rst.bz2, and is also"
+ elog "available online at lutris.net."
+}