summaryrefslogtreecommitdiff
path: root/games-util/linux-wbfs-manager
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-08-07 00:16:33 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-08-07 00:16:33 +0100
commitd162ba1860a88062f4cd61f8b52fc303ba0b2991 (patch)
tree24cd2cf57f3932a24b96e4a0f6666489447e43ba /games-util/linux-wbfs-manager
parent590b9b7b03bf4651e099949e318755af7cfa81b8 (diff)
gentoo resync : 07.08.2021
Diffstat (limited to 'games-util/linux-wbfs-manager')
-rw-r--r--games-util/linux-wbfs-manager/Manifest3
-rw-r--r--games-util/linux-wbfs-manager/linux-wbfs-manager-0.1.12.ebuild43
-rw-r--r--games-util/linux-wbfs-manager/linux-wbfs-manager-9999.ebuild51
3 files changed, 13 insertions, 84 deletions
diff --git a/games-util/linux-wbfs-manager/Manifest b/games-util/linux-wbfs-manager/Manifest
index 814f8627fb46..35745b3767b4 100644
--- a/games-util/linux-wbfs-manager/Manifest
+++ b/games-util/linux-wbfs-manager/Manifest
@@ -1,4 +1,3 @@
DIST linux-wbfs-manager-0.1.12.tar.gz 34251 BLAKE2B 57a3e5c405318ab128455455e6e45fb58b397c6b3135d97b54642569b26fd9f388d65250723818795fc310704afb59db7a682dbcaaea9c26e113bf0a28998e5d SHA512 58ac4d110e27123d04261d618df8734a0471bcad63171025aa4766a73bcc4a9240fceec59b1ba91fff71230e98f57b5fdd12390d380dc0c41d08740b7076bf6f
-EBUILD linux-wbfs-manager-0.1.12.ebuild 885 BLAKE2B c532d4dab9a898b3201b232e8db19e388bfa2674a224325332bfbc21e50bef187dc11b5ef8aec8ffcebe388211dcd8c38a6f178f6ef9183cb2edbfacb9d773ce SHA512 6b89eaf4fa7d97b52368ca0f5fd6cef7c925137f1262b3bd20060487fac4715db85efaf3e327c41a444e2e1907bfb5fc242c1f88333de421f8f2333ee13adce2
-EBUILD linux-wbfs-manager-9999.ebuild 885 BLAKE2B c532d4dab9a898b3201b232e8db19e388bfa2674a224325332bfbc21e50bef187dc11b5ef8aec8ffcebe388211dcd8c38a6f178f6ef9183cb2edbfacb9d773ce SHA512 6b89eaf4fa7d97b52368ca0f5fd6cef7c925137f1262b3bd20060487fac4715db85efaf3e327c41a444e2e1907bfb5fc242c1f88333de421f8f2333ee13adce2
+EBUILD linux-wbfs-manager-0.1.12.ebuild 704 BLAKE2B cecc2a1fa975aab6b1d1bc52583d3bde944fdbce47e6485c0980947c6fcd4cbec2d8178c48a4bae215093060904a1e361367b483eb11a27f342b230ada6c12be SHA512 e14351d2197187057456cd8290e503adedcaf7f91395df5d59a9b063abee6d2ae7b6eaa2d4b3c1bedeed640e061837a9fc1618ae261e41def9dc429f07a3de05
MISC metadata.xml 341 BLAKE2B 6dfa68b48d7d834af0a719e930d49fca895d7f929780e087882b9e5889ab492f02ad3f3ebaa990e4c995b80ef43e714fce299ff16181426138dcbe5fe1a6c211 SHA512 46913ec989d81928c2faf97ef1a4e57e19f412189b9acf6de875fea5a9615e808dde58ad29df401fa8d125dd1be232f76800dd2497c60a160db752a13f2ff8cd
diff --git a/games-util/linux-wbfs-manager/linux-wbfs-manager-0.1.12.ebuild b/games-util/linux-wbfs-manager/linux-wbfs-manager-0.1.12.ebuild
index c94ba9084a1f..aba85f691454 100644
--- a/games-util/linux-wbfs-manager/linux-wbfs-manager-0.1.12.ebuild
+++ b/games-util/linux-wbfs-manager/linux-wbfs-manager-0.1.12.ebuild
@@ -1,45 +1,24 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=8
-inherit toolchain-funcs
-
-if [[ "${PV}" == "9999" ]]; then
- ESVN_REPO_URI="https://linux-wbfs-manager.googlecode.com/svn/trunk/"
- inherit subversion
- SRC_URI=""
-else
- SRC_URI="https://linux-wbfs-manager.googlecode.com/files/${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
-fi;
+inherit desktop toolchain-funcs
DESCRIPTION="WBFS manager for Linux using GTK+"
HOMEPAGE="https://code.google.com/p/linux-wbfs-manager/"
+SRC_URI="https://storage.googleapis.com/google-code-archive-downloads/v2/code.google.com/linux-wbfs-manager/${P}.tar.gz"
+S="${WORKDIR}/${PN}"
LICENSE="GPL-2"
SLOT="0"
-IUSE=""
+KEYWORDS="~amd64 ~x86"
-RDEPEND="dev-libs/glib:2
+RDEPEND="
+ dev-libs/glib:2
gnome-base/libglade:2.0"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
-"
-
-if [[ ${PV} == "9999" ]] ; then
- S=${WORKDIR}/${ECVS_MODULE}
-else
- S=${WORKDIR}/${PN}
-fi
-
-src_unpack() {
- if [[ ${PV} == "9999" ]]; then
- subversion_src_unpack
- else
- default
- fi
-}
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
src_compile() {
emake CC="$(tc-getCC)"
@@ -47,5 +26,7 @@ src_compile() {
src_install() {
dobin wbfs_gtk
- dodoc README
+ einstalldocs
+
+ make_desktop_entry wbfs_gtk "WBFS manager" applications-utilities
}
diff --git a/games-util/linux-wbfs-manager/linux-wbfs-manager-9999.ebuild b/games-util/linux-wbfs-manager/linux-wbfs-manager-9999.ebuild
deleted file mode 100644
index c94ba9084a1f..000000000000
--- a/games-util/linux-wbfs-manager/linux-wbfs-manager-9999.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit toolchain-funcs
-
-if [[ "${PV}" == "9999" ]]; then
- ESVN_REPO_URI="https://linux-wbfs-manager.googlecode.com/svn/trunk/"
- inherit subversion
- SRC_URI=""
-else
- SRC_URI="https://linux-wbfs-manager.googlecode.com/files/${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
-fi;
-
-DESCRIPTION="WBFS manager for Linux using GTK+"
-HOMEPAGE="https://code.google.com/p/linux-wbfs-manager/"
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE=""
-
-RDEPEND="dev-libs/glib:2
- gnome-base/libglade:2.0"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
-"
-
-if [[ ${PV} == "9999" ]] ; then
- S=${WORKDIR}/${ECVS_MODULE}
-else
- S=${WORKDIR}/${PN}
-fi
-
-src_unpack() {
- if [[ ${PV} == "9999" ]]; then
- subversion_src_unpack
- else
- default
- fi
-}
-
-src_compile() {
- emake CC="$(tc-getCC)"
-}
-
-src_install() {
- dobin wbfs_gtk
- dodoc README
-}