summaryrefslogtreecommitdiff
path: root/games-util/linux-wbfs-manager/linux-wbfs-manager-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-util/linux-wbfs-manager/linux-wbfs-manager-9999.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-util/linux-wbfs-manager/linux-wbfs-manager-9999.ebuild')
-rw-r--r--games-util/linux-wbfs-manager/linux-wbfs-manager-9999.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/games-util/linux-wbfs-manager/linux-wbfs-manager-9999.ebuild b/games-util/linux-wbfs-manager/linux-wbfs-manager-9999.ebuild
new file mode 100644
index 000000000000..59c3678a99f2
--- /dev/null
+++ b/games-util/linux-wbfs-manager/linux-wbfs-manager-9999.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+if [[ "${PV}" == "9999" ]]; then
+ ESVN_REPO_URI="https://linux-wbfs-manager.googlecode.com/svn/trunk/"
+ inherit toolchain-funcs subversion
+ SRC_URI=""
+ #KEYWORDS=""
+else
+ inherit toolchain-funcs
+ SRC_URI="https://linux-wbfs-manager.googlecode.com/files/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi;
+
+DESCRIPTION="WBFS manager for Linux using GTK+"
+HOMEPAGE="https://code.google.com/p/linux-wbfs-manager/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-libs/glib:2
+ gnome-base/libglade:2.0"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+if [[ ${PV} == "9999" ]] ; then
+ S=${WORKDIR}/${ECVS_MODULE}
+else
+ S=${WORKDIR}/${PN}
+fi
+
+src_unpack() {
+ if [[ ${PV} == "9999" ]]; then
+ subversion_src_unpack
+ else
+ default
+ fi
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ dobin wbfs_gtk
+ dodoc README
+}