summaryrefslogtreecommitdiff
path: root/games-util/linux-wbfs-manager
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-util/linux-wbfs-manager
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-util/linux-wbfs-manager')
-rw-r--r--games-util/linux-wbfs-manager/Manifest4
-rw-r--r--games-util/linux-wbfs-manager/linux-wbfs-manager-0.1.12.ebuild49
-rw-r--r--games-util/linux-wbfs-manager/linux-wbfs-manager-9999.ebuild49
-rw-r--r--games-util/linux-wbfs-manager/metadata.xml11
4 files changed, 113 insertions, 0 deletions
diff --git a/games-util/linux-wbfs-manager/Manifest b/games-util/linux-wbfs-manager/Manifest
new file mode 100644
index 000000000000..5fc94351162e
--- /dev/null
+++ b/games-util/linux-wbfs-manager/Manifest
@@ -0,0 +1,4 @@
+DIST linux-wbfs-manager-0.1.12.tar.gz 34251 BLAKE2B 57a3e5c405318ab128455455e6e45fb58b397c6b3135d97b54642569b26fd9f388d65250723818795fc310704afb59db7a682dbcaaea9c26e113bf0a28998e5d SHA512 58ac4d110e27123d04261d618df8734a0471bcad63171025aa4766a73bcc4a9240fceec59b1ba91fff71230e98f57b5fdd12390d380dc0c41d08740b7076bf6f
+EBUILD linux-wbfs-manager-0.1.12.ebuild 916 BLAKE2B dd786f471afb037d1d4a5f50c311e30322995ad114d7b0c8b5cf16dfbbef1af9f7ad6b8e3434d53824f9f0a557e0af7597400631a8a6d46a0413ce8a0837faa2 SHA512 09e8aab18b18c8b8eb001c844ae589e44ee04c04a668b158dbd6da07891812170f4d4a8d3f945876bce3a9ad6e39859c324ef8a43f2068a5208a6d697036293f
+EBUILD linux-wbfs-manager-9999.ebuild 916 BLAKE2B 060cad1ce2e2e3b1982df08efdefe1d5fbff75b03ce4cb6d14d26040b1737d721f738fa3e1c019c7067e1dd3678ea07e9e88270578b236ac45f0ca57f18fc830 SHA512 a56bb18d7466c517aea67a668bc30b91b8d59773127699963ee5aefc24b706a74751ecfa75fb94b33787ba8979d04bab8980cb7d76c85a2b0652ed065a0b8496
+MISC metadata.xml 341 BLAKE2B 6dfa68b48d7d834af0a719e930d49fca895d7f929780e087882b9e5889ab492f02ad3f3ebaa990e4c995b80ef43e714fce299ff16181426138dcbe5fe1a6c211 SHA512 46913ec989d81928c2faf97ef1a4e57e19f412189b9acf6de875fea5a9615e808dde58ad29df401fa8d125dd1be232f76800dd2497c60a160db752a13f2ff8cd
diff --git a/games-util/linux-wbfs-manager/linux-wbfs-manager-0.1.12.ebuild b/games-util/linux-wbfs-manager/linux-wbfs-manager-0.1.12.ebuild
new file mode 100644
index 000000000000..ac70b1fc110d
--- /dev/null
+++ b/games-util/linux-wbfs-manager/linux-wbfs-manager-0.1.12.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+if [[ "${PV}" == "9999" ]]; then
+ ESVN_REPO_URI="https://linux-wbfs-manager.googlecode.com/svn/trunk/"
+ inherit toolchain-funcs subversion
+ SRC_URI=""
+ #KEYWORDS=""
+else
+ inherit toolchain-funcs
+ SRC_URI="https://linux-wbfs-manager.googlecode.com/files/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi;
+
+DESCRIPTION="WBFS manager for Linux using GTK+"
+HOMEPAGE="https://code.google.com/p/linux-wbfs-manager/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-libs/glib:2
+ gnome-base/libglade:2.0"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+if [[ ${PV} == "9999" ]] ; then
+ S=${WORKDIR}/${ECVS_MODULE}
+else
+ S=${WORKDIR}/${PN}
+fi
+
+src_unpack() {
+ if [[ ${PV} == "9999" ]]; then
+ subversion_src_unpack
+ else
+ default
+ fi
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ dobin wbfs_gtk
+ dodoc README
+}
diff --git a/games-util/linux-wbfs-manager/linux-wbfs-manager-9999.ebuild b/games-util/linux-wbfs-manager/linux-wbfs-manager-9999.ebuild
new file mode 100644
index 000000000000..59c3678a99f2
--- /dev/null
+++ b/games-util/linux-wbfs-manager/linux-wbfs-manager-9999.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+if [[ "${PV}" == "9999" ]]; then
+ ESVN_REPO_URI="https://linux-wbfs-manager.googlecode.com/svn/trunk/"
+ inherit toolchain-funcs subversion
+ SRC_URI=""
+ #KEYWORDS=""
+else
+ inherit toolchain-funcs
+ SRC_URI="https://linux-wbfs-manager.googlecode.com/files/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi;
+
+DESCRIPTION="WBFS manager for Linux using GTK+"
+HOMEPAGE="https://code.google.com/p/linux-wbfs-manager/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-libs/glib:2
+ gnome-base/libglade:2.0"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+if [[ ${PV} == "9999" ]] ; then
+ S=${WORKDIR}/${ECVS_MODULE}
+else
+ S=${WORKDIR}/${PN}
+fi
+
+src_unpack() {
+ if [[ ${PV} == "9999" ]]; then
+ subversion_src_unpack
+ else
+ default
+ fi
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ dobin wbfs_gtk
+ dodoc README
+}
diff --git a/games-util/linux-wbfs-manager/metadata.xml b/games-util/linux-wbfs-manager/metadata.xml
new file mode 100644
index 000000000000..42bfc468b26b
--- /dev/null
+++ b/games-util/linux-wbfs-manager/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="google-code">linux-wbfs-manager</remote-id>
+ </upstream>
+</pkgmetadata>