summaryrefslogtreecommitdiff
path: root/games-util/joycond
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /games-util/joycond
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'games-util/joycond')
-rw-r--r--games-util/joycond/Manifest4
-rw-r--r--games-util/joycond/files/joycond.initd7
-rw-r--r--games-util/joycond/joycond-0.1.0_p20210730.ebuild39
-rw-r--r--games-util/joycond/metadata.xml11
4 files changed, 61 insertions, 0 deletions
diff --git a/games-util/joycond/Manifest b/games-util/joycond/Manifest
new file mode 100644
index 000000000000..81e9e2bcca5c
--- /dev/null
+++ b/games-util/joycond/Manifest
@@ -0,0 +1,4 @@
+AUX joycond.initd 205 BLAKE2B e5da9bf96d39796897bd0f819c874c40285a85578c61c12c38c702e1719c238e8ad6e106d282846f8576a38ddd3c1960efdaeed2ab9e186b25e86cc40b0035e0 SHA512 2d96fe9af653f88adc8918733f729e9bf5e7c43ed5a6ae5f24f8ad73d45d05f59b142634377de74a3fccda6704233a862bb4a066068b1aabc428d6d54cd4cb0d
+DIST joycond-0.1.0_p20210730.tar.gz 29947 BLAKE2B d151e9a798a358e142c44722ce5d9892bc63a7c2992aa6b962a02ab971a8aec9bd343bd56cc26ae36e63d5977d1d0a99c52c35aeb779d352f1bbe2d15010e43c SHA512 1d0a82bd9e2aeecef3215232ffb6acb77008845fe0e8094e81d2b81627cca1e5d581986fad6631c5efd2b29514370fbac8a65d9996df762543d050628327a564
+EBUILD joycond-0.1.0_p20210730.ebuild 756 BLAKE2B 0cd4d88b137eb29d43c94c2748727fdace281c57b5d70f074c4059205d86c923d10d0ca1e54a1977b3b88ca07791cd06ca828f2b3b4bfce7b80ccd84a4820b0f SHA512 12c55cacef7844a7f7d061bff509e48045425e144f9ed457cdbe049e5638d087014b931f2289ffcddf23b8ac790df3c9874381471b9f9fd92ad95b35a331eee4
+MISC metadata.xml 342 BLAKE2B f256215b8ff7fe2d8b1d360f3a3da2a530a5c7b8137a2f38d21a51e303ead2fc3b28c20a9199bd7885a940908cd2b084ce58db14cb9578b3d63c5e86be5f45e8 SHA512 a68b62631acf469245b1c78ad35487390937f5a555251cc0ae75d7756677d760d2c730f891854e16e06cbf0382a649992006a1c7f13b843c03551aa1754f106c
diff --git a/games-util/joycond/files/joycond.initd b/games-util/joycond/files/joycond.initd
new file mode 100644
index 000000000000..f23e1131e753
--- /dev/null
+++ b/games-util/joycond/files/joycond.initd
@@ -0,0 +1,7 @@
+#!/sbin/openrc-run
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+pidfile="/var/run/${RC_SVCNAME}.pid"
+command_background="true"
+command="joycond"
diff --git a/games-util/joycond/joycond-0.1.0_p20210730.ebuild b/games-util/joycond/joycond-0.1.0_p20210730.ebuild
new file mode 100644
index 000000000000..e06a319c6811
--- /dev/null
+++ b/games-util/joycond/joycond-0.1.0_p20210730.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake linux-info
+
+COMMIT="f9a66914622514c13997c2bf7ec20fa98e9dfc1d"
+DESCRIPTION="Daemon that uses hid-nintendo evdev devices to implement joycon pairing"
+HOMEPAGE="https://github.com/DanielOgorchock/joycond"
+SRC_URI="https://github.com/DanielOgorchock/joycond/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="
+ dev-libs/libevdev
+ virtual/udev
+"
+
+RDEPEND="
+ ${DEPEND}
+"
+
+CONFIG_CHECK="
+ ~HID
+ ~HID_NINTENDO
+ ~HIDRAW
+"
+
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+src_install() {
+ cmake_src_install
+ rm -r "${ED}"/etc/modules-load.d/ || die
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ doman doc/${PN}.1
+}
diff --git a/games-util/joycond/metadata.xml b/games-util/joycond/metadata.xml
new file mode 100644
index 000000000000..c529738df197
--- /dev/null
+++ b/games-util/joycond/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">DanielOgorchock/joycond</remote-id>
+ </upstream>
+</pkgmetadata>