summaryrefslogtreecommitdiff
path: root/games-util/joycond/joycond-0.1.0_p20210730.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-util/joycond/joycond-0.1.0_p20210730.ebuild')
-rw-r--r--games-util/joycond/joycond-0.1.0_p20210730.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/games-util/joycond/joycond-0.1.0_p20210730.ebuild b/games-util/joycond/joycond-0.1.0_p20210730.ebuild
new file mode 100644
index 000000000000..e06a319c6811
--- /dev/null
+++ b/games-util/joycond/joycond-0.1.0_p20210730.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake linux-info
+
+COMMIT="f9a66914622514c13997c2bf7ec20fa98e9dfc1d"
+DESCRIPTION="Daemon that uses hid-nintendo evdev devices to implement joycon pairing"
+HOMEPAGE="https://github.com/DanielOgorchock/joycond"
+SRC_URI="https://github.com/DanielOgorchock/joycond/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="
+ dev-libs/libevdev
+ virtual/udev
+"
+
+RDEPEND="
+ ${DEPEND}
+"
+
+CONFIG_CHECK="
+ ~HID
+ ~HID_NINTENDO
+ ~HIDRAW
+"
+
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+src_install() {
+ cmake_src_install
+ rm -r "${ED}"/etc/modules-load.d/ || die
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ doman doc/${PN}.1
+}