summaryrefslogtreecommitdiff
path: root/games-util/acc
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-29 11:38:31 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-29 11:38:31 +0100
commit90c88731bd036e5698b281fbc0a5f3aa4c9983ac (patch)
tree83fc5facb6b12be510a37bc3d241cc63e965b13a /games-util/acc
parentfeb0daf81d888e9160f9f94502de09b66f2a63fd (diff)
gentoo resync : 29.06.2020
Diffstat (limited to 'games-util/acc')
-rw-r--r--games-util/acc/Manifest3
-rw-r--r--games-util/acc/acc-1.57.ebuild30
-rw-r--r--games-util/acc/metadata.xml11
3 files changed, 44 insertions, 0 deletions
diff --git a/games-util/acc/Manifest b/games-util/acc/Manifest
new file mode 100644
index 000000000000..23c2b9e19acd
--- /dev/null
+++ b/games-util/acc/Manifest
@@ -0,0 +1,3 @@
+DIST acc-1.57.tar.gz 70969 BLAKE2B 0c5d9f6778505881d9fa698da0958aea410a8d42f4b81c24277f59d0e9a601d44213e9399f0e693a210d0b935e57df4b6878fe1575005e5d573e19993404f570 SHA512 997bb6bb262743cacbf0606e7f6dcd00132a1f54eb24eddad92948c31ed552b3b678e72932150856fee57df2ab01fd25c29408f6c46a804614b883cf07532f3a
+EBUILD acc-1.57.ebuild 684 BLAKE2B 8866afd11b232d9d02ee8e5e564c6aedd0cd74ba25e0a7b53f4c21a2456d15e424ae528b77c58e8ebb57d54257384e0fa285f470b4cbd2fb2cfc851c5a846f25 SHA512 840682b7043e73eaa446d78b85cd7d057ba637f239344f1ada9a01103a7ab446f1b91fceadd170d329ec00c9266afa16b4fe83a89ffdac8a5d87d21fe59bcb78
+MISC metadata.xml 327 BLAKE2B 56e2211185f35bb2cee5dc0ea79748bd2edbf488b79da4204b03eb9015a9ac3bfa3c8dedea6b647b2ab228e1bc41bc461eebdc38f3b62b388529f330771707ef SHA512 b9bc86d737231f3c729665fd1238b36cc0da253747c94ec8b994381a75fef37a8a2dfe43384dca189518786e4c5dd2750fb192c4d7c264569cc94f2b1e8ffef1
diff --git a/games-util/acc/acc-1.57.ebuild b/games-util/acc/acc-1.57.ebuild
new file mode 100644
index 000000000000..ca25dbd7690e
--- /dev/null
+++ b/games-util/acc/acc-1.57.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="ACS script compiler for use with ZDoom and Hexen"
+HOMEPAGE="https://zdoom.org/wiki/ACC"
+SRC_URI="https://github.com/rheit/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="Activision"
+SLOT="0"
+KEYWORDS="~amd64"
+
+# The Activision EULA is inappropriate but this was never resolved. :(
+# https://doomwiki.org/wiki/Raven_source_code_licensing
+RESTRICT="bindist mirror"
+
+src_configure() {
+ tc-export CC
+ append-cflags -Wall -Wextra
+}
+
+src_install() {
+ dobin ${PN}
+ dodoc readme.md
+
+ insinto /usr/share/${PN}
+ doins *.acs
+}
diff --git a/games-util/acc/metadata.xml b/games-util/acc/metadata.xml
new file mode 100644
index 000000000000..95907e587a83
--- /dev/null
+++ b/games-util/acc/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">rheit/acc</remote-id>
+ </upstream>
+</pkgmetadata>