summaryrefslogtreecommitdiff
path: root/games-util
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-29 11:38:31 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-29 11:38:31 +0100
commit90c88731bd036e5698b281fbc0a5f3aa4c9983ac (patch)
tree83fc5facb6b12be510a37bc3d241cc63e965b13a /games-util
parentfeb0daf81d888e9160f9f94502de09b66f2a63fd (diff)
gentoo resync : 29.06.2020
Diffstat (limited to 'games-util')
-rw-r--r--games-util/Manifest.gzbin7396 -> 7557 bytes
-rw-r--r--games-util/acc/Manifest3
-rw-r--r--games-util/acc/acc-1.57.ebuild30
-rw-r--r--games-util/acc/metadata.xml11
-rw-r--r--games-util/loki_patch/Manifest6
-rw-r--r--games-util/loki_patch/files/loki_patch-20091105-build.patch23
-rw-r--r--games-util/loki_patch/files/loki_patch-20091105-patchdata.patch4
-rw-r--r--games-util/loki_patch/loki_patch-20091105.ebuild42
8 files changed, 86 insertions, 33 deletions
diff --git a/games-util/Manifest.gz b/games-util/Manifest.gz
index fdd2f6ae4f04..8d7a5e278da2 100644
--- a/games-util/Manifest.gz
+++ b/games-util/Manifest.gz
Binary files differ
diff --git a/games-util/acc/Manifest b/games-util/acc/Manifest
new file mode 100644
index 000000000000..23c2b9e19acd
--- /dev/null
+++ b/games-util/acc/Manifest
@@ -0,0 +1,3 @@
+DIST acc-1.57.tar.gz 70969 BLAKE2B 0c5d9f6778505881d9fa698da0958aea410a8d42f4b81c24277f59d0e9a601d44213e9399f0e693a210d0b935e57df4b6878fe1575005e5d573e19993404f570 SHA512 997bb6bb262743cacbf0606e7f6dcd00132a1f54eb24eddad92948c31ed552b3b678e72932150856fee57df2ab01fd25c29408f6c46a804614b883cf07532f3a
+EBUILD acc-1.57.ebuild 684 BLAKE2B 8866afd11b232d9d02ee8e5e564c6aedd0cd74ba25e0a7b53f4c21a2456d15e424ae528b77c58e8ebb57d54257384e0fa285f470b4cbd2fb2cfc851c5a846f25 SHA512 840682b7043e73eaa446d78b85cd7d057ba637f239344f1ada9a01103a7ab446f1b91fceadd170d329ec00c9266afa16b4fe83a89ffdac8a5d87d21fe59bcb78
+MISC metadata.xml 327 BLAKE2B 56e2211185f35bb2cee5dc0ea79748bd2edbf488b79da4204b03eb9015a9ac3bfa3c8dedea6b647b2ab228e1bc41bc461eebdc38f3b62b388529f330771707ef SHA512 b9bc86d737231f3c729665fd1238b36cc0da253747c94ec8b994381a75fef37a8a2dfe43384dca189518786e4c5dd2750fb192c4d7c264569cc94f2b1e8ffef1
diff --git a/games-util/acc/acc-1.57.ebuild b/games-util/acc/acc-1.57.ebuild
new file mode 100644
index 000000000000..ca25dbd7690e
--- /dev/null
+++ b/games-util/acc/acc-1.57.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="ACS script compiler for use with ZDoom and Hexen"
+HOMEPAGE="https://zdoom.org/wiki/ACC"
+SRC_URI="https://github.com/rheit/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="Activision"
+SLOT="0"
+KEYWORDS="~amd64"
+
+# The Activision EULA is inappropriate but this was never resolved. :(
+# https://doomwiki.org/wiki/Raven_source_code_licensing
+RESTRICT="bindist mirror"
+
+src_configure() {
+ tc-export CC
+ append-cflags -Wall -Wextra
+}
+
+src_install() {
+ dobin ${PN}
+ dodoc readme.md
+
+ insinto /usr/share/${PN}
+ doins *.acs
+}
diff --git a/games-util/acc/metadata.xml b/games-util/acc/metadata.xml
new file mode 100644
index 000000000000..95907e587a83
--- /dev/null
+++ b/games-util/acc/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">rheit/acc</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/games-util/loki_patch/Manifest b/games-util/loki_patch/Manifest
index 9e09480a90f5..3d0edb4c021d 100644
--- a/games-util/loki_patch/Manifest
+++ b/games-util/loki_patch/Manifest
@@ -1,6 +1,6 @@
-AUX loki_patch-20091105-build.patch 4617 BLAKE2B 2dd2804ee90c88e8cc055a26dcf75ade6fc96d7e194a25909b97df745b74d8a67e80190b60af824538e82458e67648f7fa9390456000d31cc071001481bde5e0 SHA512 eabc0db3f6594b99ef76d57e1fdd738c96e4ef45c0bb67127907fa6a19d19002e2a97acc2735e7353915047ecf626bacd6bcdc7bf42446cd42c6b10f79dc6ca7
-AUX loki_patch-20091105-patchdata.patch 257 BLAKE2B 0bab64cabdfc931e06f61b140a5a079267028c7e975a742344cb593b5144776152f2b88c12877de26fef23e1b8efe8db5448b123d889c19eaf61ccc229e640ab SHA512 e21da8ce772f38c1bc2acb52bedeb96042e5bb2168c76ec3efde995bfd4b113000a20b4c6efba92fc79f7ebc16486cc7871d628bf71494bf4bb8ce7dfd7dfed4
+AUX loki_patch-20091105-build.patch 4619 BLAKE2B df4baad3059b3f147570f9af23664ebbd6f9e156c3cd248c1b6775b2fad9db058144a178f265ec6e62e95ddc731ce8c7bb10a8ca20199ae1ddd1970c863d3993 SHA512 477dea6fe3c66416205ff583f2c220e3cd7b25bb97dffc21b8420ce08ffe02e0c6705c51942298cfb867e7a04bc30ce80859f905e7dbfb0121f5b62e47501d85
+AUX loki_patch-20091105-patchdata.patch 261 BLAKE2B b55e36397b3ebf9fc1255b32a60a2fb527c89003d353c4fb9a118b9b150d314f397cfe53f52214abb3c3b2c9d4bdfe50e818b17ed745a4eac24c9f43346dc514 SHA512 858d1a792743ab9295ec2d3d23b9c4334425f6e8b1c79bdf960fb3e93d5c4066678aa764e84362034a44404dbc5e48a283acec504ae02fa694195909fce15e3f
DIST loki_patch-20091105.tar.bz2 331725 BLAKE2B a3fa2e1c594d3484830527276ebd24f6e1c56f924b815fd3e2a12f802bccfd556017084a094508c531badd568158eb68fa3d608c30a55110de24410088fc5275 SHA512 9db40b1746ecf5603c09be3ddf01bf92cfc6b3d1c35ac7153751e1871840175c538af98c22f458658bcbebac65ccddccc1aee92a88300a243b8e68bda13ca323
DIST loki_setupdb-20091105.tar.bz2 60725 BLAKE2B d3bed3d6b9123093b307f9c735f14c630f8ebfd2b228d6268cf97e8016ec83fa18b3b390e84facd42afe5d3f707bfb63a48e21a6b002a7d0583fdbde907567dc SHA512 ba55b24a6e2b2b6268dec9df8ec0581d852461b5c07ca97a24ebee3e55fe5764dffbbcfdb6b18a80677f2fae1e7701df4fbca0f6af8ef8050c662f5a39daf25d
-EBUILD loki_patch-20091105.ebuild 874 BLAKE2B c67c080b6639c66bf20d26522b13bfdabfd169ac6696092e03a9aa44d222428b7aaf2cb94aa29835b4ee6e43b15ef53d40f128fbdd0cdd6eac215286528f4638 SHA512 4e6e08b74cb19c7dd3e20a5b7a35bae1d25140ed1e41af95af2d106534aef94a5b2a37cce2f3085ac3c23b0548cc216fdcc6fec6438604d27332c6ae41003543
+EBUILD loki_patch-20091105.ebuild 974 BLAKE2B c4c45c9997dded498912f271d457bb2542d1457fc87957ed4b640a7ff089510511ba6470d9c3357b68c918f009d80fae7bfab5873c9c2dc5e8fe3497aeae75e3 SHA512 eeda30dcff747f41dcb322d65f0d7c8bbaae25ecd2f1e08e36ee73d3ab9d66685d109795fbab78eb21c19fe215e7bca22a956a5a7311e512d89500ee182cf330
MISC metadata.xml 249 BLAKE2B 7113a758d7abc93accec998a8843d8ef51ca8b72d72e659e224d5cec2a1a6a63e6c0605958091532ac6e51fa0d501ca4fd9f3f4a9e55baeb31519a02971b465f SHA512 895577c3a805c40581da03057b94e3f28f05f23012bf350c1e3575847d1a0fe40bb044a46f909012a200d991a400f6389358a60e9c2b5bef0da01fb26f846118
diff --git a/games-util/loki_patch/files/loki_patch-20091105-build.patch b/games-util/loki_patch/files/loki_patch-20091105-build.patch
index 8e2b5bbf1557..e17007e57a75 100644
--- a/games-util/loki_patch/files/loki_patch-20091105-build.patch
+++ b/games-util/loki_patch/files/loki_patch-20091105-build.patch
@@ -1,5 +1,5 @@
---- loki_patch/configure.in
-+++ loki_patch/configure.in
+--- a/loki_patch/configure.in
++++ b/loki_patch/configure.in
@@ -1,4 +1,4 @@
-AC_INIT(README)
+AC_INIT(loki_patch, 1.0.2)
@@ -60,8 +60,8 @@
CFLAGS="$CFLAGS -I$SETUPDB"
AC_SUBST(SETUPDB)
---- loki_patch/loki_xdelta.c
-+++ loki_patch/loki_xdelta.c
+--- a/loki_patch/loki_xdelta.c
++++ b/loki_patch/loki_xdelta.c
@@ -49,7 +49,7 @@
#define LOKI_PATCH
@@ -71,8 +71,8 @@
static HandleFuncTable xd_handle_table;
---- loki_patch/Makefile.am
-+++ loki_patch/Makefile.am
+--- a/dev/null
++++ b/loki_patch/Makefile.am
@@ -0,0 +1,12 @@
+COMMONSRC = load_patch.c size_patch.c print_patch.c \
+ loki_xdelta.c mkdirhier.c log_output.c
@@ -86,8 +86,8 @@
+AM_CPPFLAGS = $(XDELTA_CFLAGS)
+
+LDADD = $(top_builddir)/../loki_setupdb/libsetupdb.a $(XDELTA_LIBS) $(XML_LIBS) -lz
---- loki_setupdb/configure.in
-+++ loki_setupdb/configure.in
+--- a/loki_setupdb/configure.in
++++ b/loki_setupdb/configure.in
@@ -1,4 +1,4 @@
-AC_INIT
+AC_INIT(setupdb, 1.6.5)
@@ -111,7 +111,8 @@
+AM_INIT_AUTOMAKE(foreign no-dependencies)
AC_PROG_CC
AC_PROG_MAKE_SET
- AC_PATH_PROGS(AR, [ar gar])
+-AC_PATH_PROGS(AR, [ar gar])
++AM_PROG_AR
+AC_PROG_RANLIB
AC_CHECK_HEADERS(unistd.h)
@@ -165,8 +166,8 @@
AC_ARG_WITH(vendor,
[ --with-vendor with specified vendor prefix [default=loki]],
---- loki_setupdb/Makefile.am
-+++ loki_setupdb/Makefile.am
+--- a/dev/null
++++ b/loki_setupdb/Makefile.am
@@ -0,0 +1,9 @@
+noinst_LIBRARIES = libsetupdb.a
+
diff --git a/games-util/loki_patch/files/loki_patch-20091105-patchdata.patch b/games-util/loki_patch/files/loki_patch-20091105-patchdata.patch
index 74ec3dae7568..403c24ed79f9 100644
--- a/games-util/loki_patch/files/loki_patch-20091105-patchdata.patch
+++ b/games-util/loki_patch/files/loki_patch-20091105-patchdata.patch
@@ -1,5 +1,5 @@
---- loki_patch/load_patch.c
-+++ loki_patch/load_patch.c
+--- a/loki_patch/load_patch.c
++++ b/loki_patch/load_patch.c
@@ -8,7 +8,7 @@
#include "load_patch.h"
#include "log_output.h"
diff --git a/games-util/loki_patch/loki_patch-20091105.ebuild b/games-util/loki_patch/loki_patch-20091105.ebuild
index b3084027a98d..1fc2b57f633a 100644
--- a/games-util/loki_patch/loki_patch-20091105.ebuild
+++ b/games-util/loki_patch/loki_patch-20091105.ebuild
@@ -1,41 +1,49 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-inherit autotools eutils
+EAPI=7
+
+inherit autotools
DESCRIPTION="Loki Software binary patch tool"
HOMEPAGE="http://www.icculus.org/loki_setup/"
-SRC_URI="mirror://gentoo/${P}.tar.bz2
+SRC_URI="
+ mirror://gentoo/${P}.tar.bz2
mirror://gentoo/loki_setupdb-${PV}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
-RDEPEND="dev-util/xdelta:0
+RDEPEND="
+ dev-util/xdelta:0
dev-libs/libxml2
dev-libs/glib:2"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
-S=${WORKDIR}
+S="${WORKDIR}"
+PATCHES=(
+ "${FILESDIR}"/${P}-build.patch
+ "${FILESDIR}"/${P}-patchdata.patch
+)
src_prepare() {
- epatch \
- "${FILESDIR}"/${P}-build.patch \
- "${FILESDIR}"/${P}-patchdata.patch
- cd loki_setupdb
+ default
+
+ cd loki_setupdb || die
+ mv configure.{in,ac} || die
eautoreconf
- cd "${S}"/${PN}
+
+ cd "${S}"/${PN} || die
+ mv configure.{in,ac} || die
eautoreconf
}
src_configure() {
- cd loki_setupdb
+ cd loki_setupdb || die
econf
- cd "${S}"/${PN}
+ cd "${S}"/${PN} || die
econf
}
@@ -45,7 +53,7 @@ src_compile() {
}
src_install() {
- cd ${PN}
+ cd ${PN} || die
dobin loki_patch make_patch
dodoc CHANGES NOTES README TODO
}