summaryrefslogtreecommitdiff
path: root/games-strategy/widelands/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-19 14:39:08 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-19 14:39:08 +0100
commitfc7e841956ae3cc385629bf33433de23a6d04db6 (patch)
tree48882d11ff725a7df862343487d339fdaae1c604 /games-strategy/widelands/files
parentdbb637a643576bbb9286907cd6c73e3cda3ca1f6 (diff)
gentoo auto-resync : 19:07:2022 - 14:39:08
Diffstat (limited to 'games-strategy/widelands/files')
-rw-r--r--games-strategy/widelands/files/widelands-1.0-gcc12-werror.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/games-strategy/widelands/files/widelands-1.0-gcc12-werror.patch b/games-strategy/widelands/files/widelands-1.0-gcc12-werror.patch
new file mode 100644
index 000000000000..a00603a7969c
--- /dev/null
+++ b/games-strategy/widelands/files/widelands-1.0-gcc12-werror.patch
@@ -0,0 +1,29 @@
+Drop -Werror= (uninitialized cause issues from gcc-12) and also backport
+fix for the offending variable.
+
+Note: upstream changed how -Werror is handled next release, currently pass
+a hard non-specific -Werror and disables it for gcc-12 (review on bump, see
+commit/PR below).
+
+https://bugs.gentoo.org/859277
+https://github.com/widelands/widelands/pull/5415
+https://github.com/widelands/widelands/commit/e4da6d624
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -312,8 +312,2 @@
+ if(NOT MSVC)
+- # Turn some warnings into errors.
+- wl_add_flag(WL_COMPILE_DIAGNOSTICS "-Werror=format-security")
+- wl_add_flag(WL_COMPILE_DIAGNOSTICS "-Werror=return-type")
+- wl_add_flag(WL_COMPILE_DIAGNOSTICS "-Werror=shadow")
+- wl_add_flag(WL_COMPILE_DIAGNOSTICS "-Werror=uninitialized")
+-
+ wl_add_flag(WL_GENERIC_CXX_FLAGS "-std=c++11")
+--- a/src/editor/editorinteractive.h
++++ b/src/editor/editorinteractive.h
+@@ -87,4 +87,4 @@
+ EditorIncreaseResourcesTool increase_resources;
+- EditorSetPortSpaceTool set_port_space;
+ EditorUnsetPortSpaceTool unset_port_space;
++ EditorSetPortSpaceTool set_port_space;
+ EditorSetOriginTool set_origin;