summaryrefslogtreecommitdiff
path: root/games-strategy/widelands
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-19 14:39:08 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-19 14:39:08 +0100
commitfc7e841956ae3cc385629bf33433de23a6d04db6 (patch)
tree48882d11ff725a7df862343487d339fdaae1c604 /games-strategy/widelands
parentdbb637a643576bbb9286907cd6c73e3cda3ca1f6 (diff)
gentoo auto-resync : 19:07:2022 - 14:39:08
Diffstat (limited to 'games-strategy/widelands')
-rw-r--r--games-strategy/widelands/Manifest3
-rw-r--r--games-strategy/widelands/files/widelands-1.0-gcc12-werror.patch29
-rw-r--r--games-strategy/widelands/widelands-1.0.ebuild1
3 files changed, 32 insertions, 1 deletions
diff --git a/games-strategy/widelands/Manifest b/games-strategy/widelands/Manifest
index e97d9295be42..5d723171d6b8 100644
--- a/games-strategy/widelands/Manifest
+++ b/games-strategy/widelands/Manifest
@@ -1,5 +1,6 @@
AUX widelands-1.0-boost-1.77.patch 473 BLAKE2B c874688efafde34c19b9362b4a744c054076bbdb62ad4bddf3f3960774852fac514e768e20d78b1908b2d0274534304f6629ac2bbf87200f4f44f7730cd63981 SHA512 8b1d989c208f917bd26e9ab6000a1367f1dc9f6fa7dcdf681503541b1dd6d1a6433463c4f547ff387aeceb38156e7e8c73790f329746b6b55350f17b96289f9c
+AUX widelands-1.0-gcc12-werror.patch 1130 BLAKE2B 814e0ae5d710cbd0f02df6888deea17c33f934cde25d7e6cf78ad5dde106f4b1534012eaea9996b66ad12ff1ea2578e08802a581db5a9f17438cfe7d9e0fce78 SHA512 a303972d15f2ad2fb895992358759f7a3006c81c875afbbbac4cf4ec76ca93d3ad93754b26eea2315bd9c82f2967912019759117c7004843d659d2d767c2f7ee
DIST widelands-1.0.tar.gz 792124780 BLAKE2B 03f3eeacd8a9a867020be8ed086f139dc7f2fdf30b901edfc1d86bf9c245a71c3c4358d5589f1cd7734b6ac3bf93bab38870544050628f44863decbed86f6d47 SHA512 1092750944a8669682097dfbd2b578cdb8fab377f32cb81ce8d85b9d9b2e8ae8c4c73500c0a89be649b360fd7e086e19595eba37cecb8d64679e46f7da13e46e
-EBUILD widelands-1.0.ebuild 1363 BLAKE2B 8d6b29f34ad7725fc3249e260e63dc36d0e8f345469264b7b256d8340041ad26acbcff75735fda9d216618469aecab46156b6595a0cabb187ecdc9e520c5e436 SHA512 ca05758fc32143bf586b069b8027affddf56efcd442ca97dc2f6b5b2a71d95bb90ee8309811d05b5b669caed632215cb2c1ef357d288a7642314a1d33480f529
+EBUILD widelands-1.0.ebuild 1402 BLAKE2B 4298ca52bfbd4da0305d685aa395d1e439e07d748d64ad7b6c9e87788597a5c9b1e620c4fe403fcbf71678aafcd200682ecd642e070fd08a840d5d2cebb30ffa SHA512 7dce68948ac145f1e68dea3aad856bece3913cb4127d50ef45ee310a95839f3557459e4937047ffccc3009f9851497d9088fc87fc8b8a72a371d81be847b7887
EBUILD widelands-9999.ebuild 1299 BLAKE2B 1e8aabd7763e7956e7fcc6cd6526d698e463c563d18f0ce333b40a1230d05b92eec849837dad41fb303b4711ce1dbe115fe83bdd200578a0b2af10e4d0b7b82a SHA512 6f39ef1467065f4430fd66c3dc7350fe242150e34eec238dd9f19fcc3ab93e5a7a1f7f2d04b15694d0d4603caf503fb29d02c76852fe0b201185f6b5f1b05e3c
MISC metadata.xml 390 BLAKE2B 139ecbaa266c6fe37441b3e0dd05692dc9eff8301339b7ed358ff32e17c6a1a14cd52b2cf22f141381bcf76d5e9dd579575d204e5a3c1c3793b49ced61b090af SHA512 ecaa9b97ffb2302a7f356e53393f185b70b83563052066d4dd70ad7b725a9963c46b582e1a438f36d517cc52e0ff56316ea8be6c92b54fcdda1726776845f46f
diff --git a/games-strategy/widelands/files/widelands-1.0-gcc12-werror.patch b/games-strategy/widelands/files/widelands-1.0-gcc12-werror.patch
new file mode 100644
index 000000000000..a00603a7969c
--- /dev/null
+++ b/games-strategy/widelands/files/widelands-1.0-gcc12-werror.patch
@@ -0,0 +1,29 @@
+Drop -Werror= (uninitialized cause issues from gcc-12) and also backport
+fix for the offending variable.
+
+Note: upstream changed how -Werror is handled next release, currently pass
+a hard non-specific -Werror and disables it for gcc-12 (review on bump, see
+commit/PR below).
+
+https://bugs.gentoo.org/859277
+https://github.com/widelands/widelands/pull/5415
+https://github.com/widelands/widelands/commit/e4da6d624
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -312,8 +312,2 @@
+ if(NOT MSVC)
+- # Turn some warnings into errors.
+- wl_add_flag(WL_COMPILE_DIAGNOSTICS "-Werror=format-security")
+- wl_add_flag(WL_COMPILE_DIAGNOSTICS "-Werror=return-type")
+- wl_add_flag(WL_COMPILE_DIAGNOSTICS "-Werror=shadow")
+- wl_add_flag(WL_COMPILE_DIAGNOSTICS "-Werror=uninitialized")
+-
+ wl_add_flag(WL_GENERIC_CXX_FLAGS "-std=c++11")
+--- a/src/editor/editorinteractive.h
++++ b/src/editor/editorinteractive.h
+@@ -87,4 +87,4 @@
+ EditorIncreaseResourcesTool increase_resources;
+- EditorSetPortSpaceTool set_port_space;
+ EditorUnsetPortSpaceTool unset_port_space;
++ EditorSetPortSpaceTool set_port_space;
+ EditorSetOriginTool set_origin;
diff --git a/games-strategy/widelands/widelands-1.0.ebuild b/games-strategy/widelands/widelands-1.0.ebuild
index 6d14e5f8e931..62799a6e424f 100644
--- a/games-strategy/widelands/widelands-1.0.ebuild
+++ b/games-strategy/widelands/widelands-1.0.ebuild
@@ -44,6 +44,7 @@ BDEPEND="
PATCHES=(
"${FILESDIR}"/${P}-boost-1.77.patch
+ "${FILESDIR}"/${P}-gcc12-werror.patch
)
src_configure() {