summaryrefslogtreecommitdiff
path: root/games-simulation/gl117/gl117-1.3.2-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-simulation/gl117/gl117-1.3.2-r1.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-simulation/gl117/gl117-1.3.2-r1.ebuild')
-rw-r--r--games-simulation/gl117/gl117-1.3.2-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/games-simulation/gl117/gl117-1.3.2-r1.ebuild b/games-simulation/gl117/gl117-1.3.2-r1.ebuild
new file mode 100644
index 000000000000..f5c52f6068ab
--- /dev/null
+++ b/games-simulation/gl117/gl117-1.3.2-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils
+
+MY_P="gl-117-${PV}-src"
+DESCRIPTION="An action flight simulator"
+HOMEPAGE="http://www.heptargon.de/gl-117/gl-117.html"
+SRC_URI="mirror://sourceforge/gl-117/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ media-libs/freeglut
+ media-libs/libsdl[sound,joystick,opengl,video]
+ media-libs/sdl-mixer[mod]
+ virtual/glu
+ virtual/opengl"
+RDEPEND=${DEPEND}
+
+S=${WORKDIR}/${MY_P}
+
+PATCHES=(
+ "${FILESDIR}"/${P}-mode.patch
+)
+
+src_install() {
+ DOCS="doc/gl-117.pdf AUTHORS ChangeLog FAQ NEWS README" \
+ default
+ newicon doc/src/falcon.jpg ${PN}.jpg
+ make_desktop_entry gl-117 GL-117 /usr/share/pixmaps/${PN}.jpg
+ doman doc/gl-117.6
+}