summaryrefslogtreecommitdiff
path: root/games-simulation/gl117
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-simulation/gl117
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-simulation/gl117')
-rw-r--r--games-simulation/gl117/Manifest4
-rw-r--r--games-simulation/gl117/files/gl117-1.3.2-mode.patch12
-rw-r--r--games-simulation/gl117/gl117-1.3.2-r1.ebuild37
-rw-r--r--games-simulation/gl117/metadata.xml11
4 files changed, 64 insertions, 0 deletions
diff --git a/games-simulation/gl117/Manifest b/games-simulation/gl117/Manifest
new file mode 100644
index 000000000000..1a6914d62f08
--- /dev/null
+++ b/games-simulation/gl117/Manifest
@@ -0,0 +1,4 @@
+AUX gl117-1.3.2-mode.patch 394 BLAKE2B ee932b73f82100910bea6466edeb4a8a0d5782ac64baac4b64872cb95b3018391bd66550c5a2ff7575aff7449aa01e856769aabd0e4f9ef51bed71c4de7349e6 SHA512 b6bdfa938f19481dff3f4d275826f1308aea99c1a2fc78df6f2b49096ecabce6c476cbf7de64afd0ac0903ea0ac3b5d84e43a876ae333bd0db20b39a0085ca11
+DIST gl-117-1.3.2-src.tar.bz2 2411075 BLAKE2B efd2c7b9dd3f71bf0b8b1aac79f90dcc6286301997913346f8ee536b3f5981564438e6a805c658678b5ae0402f84da762b60472ddc553cab49f9ffb421d69993 SHA512 1d2382576c6399d8c84d56ddc7eb2b11b9e1e3ffeebcc1bd30e258ef231626d15d1be649f8c791f30e4f2f78aca2b4290c5d08036c5f482eef01eda8f4f48b5f
+EBUILD gl117-1.3.2-r1.ebuild 790 BLAKE2B 9e0539a943ce93f7db7bb0481a6c9baf4cf0642ff3fc13300a60e43825dfad17e3299d9fc8dd5644c35bb2af1c2595efbd19d8cdf5dec56b0637aa22c9fc2a96 SHA512 dfa801635069584401af3e9b7fed23ed79cd54217dfffe1a5f3666704d666a11fd470adfd437fe02d05e46179477981ab3b9128edacbc6663c635b069faa02f8
+MISC metadata.xml 329 BLAKE2B 69ad3f12c9a48f6cbb1094fb1952d75e5e317060ad8534cd95e1e94bf2e3bb824862ad2a050aa81f55970b0cb0d032197ae86b6336beb09835a9f6c56aba0a0f SHA512 a2756adb5a9afa30e93c7f7726706ed9b435f76631d268685f9fea734a4ef6e643a8f8fdae8f59cc979a1bfcb91e2778496828db50458d6adacd789b3b3763f9
diff --git a/games-simulation/gl117/files/gl117-1.3.2-mode.patch b/games-simulation/gl117/files/gl117-1.3.2-mode.patch
new file mode 100644
index 000000000000..d3f13084a96f
--- /dev/null
+++ b/games-simulation/gl117/files/gl117-1.3.2-mode.patch
@@ -0,0 +1,12 @@
+--- a/src/main.cpp 2010-07-13 09:35:18.374122609 +0100
++++ b/src/main.cpp 2010-07-13 09:35:45.334955120 +0100
+@@ -71,8 +71,7 @@ int mode = 0;
+
+ // pre-defined screen resolutions (x, y, bpp, fullscreen)
+ int resolution [4] [4] =
+- { { 1024, 768, 32, 1 },
+- { 800, 600, 32, 1 },
++ { { 800, 600, 32, 1 },
+ { 640, 480, 32, 1 },
+ { 640, 480, 32, 0 } };
+
diff --git a/games-simulation/gl117/gl117-1.3.2-r1.ebuild b/games-simulation/gl117/gl117-1.3.2-r1.ebuild
new file mode 100644
index 000000000000..f5c52f6068ab
--- /dev/null
+++ b/games-simulation/gl117/gl117-1.3.2-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils
+
+MY_P="gl-117-${PV}-src"
+DESCRIPTION="An action flight simulator"
+HOMEPAGE="http://www.heptargon.de/gl-117/gl-117.html"
+SRC_URI="mirror://sourceforge/gl-117/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ media-libs/freeglut
+ media-libs/libsdl[sound,joystick,opengl,video]
+ media-libs/sdl-mixer[mod]
+ virtual/glu
+ virtual/opengl"
+RDEPEND=${DEPEND}
+
+S=${WORKDIR}/${MY_P}
+
+PATCHES=(
+ "${FILESDIR}"/${P}-mode.patch
+)
+
+src_install() {
+ DOCS="doc/gl-117.pdf AUTHORS ChangeLog FAQ NEWS README" \
+ default
+ newicon doc/src/falcon.jpg ${PN}.jpg
+ make_desktop_entry gl-117 GL-117 /usr/share/pixmaps/${PN}.jpg
+ doman doc/gl-117.6
+}
diff --git a/games-simulation/gl117/metadata.xml b/games-simulation/gl117/metadata.xml
new file mode 100644
index 000000000000..e991eac66f1d
--- /dev/null
+++ b/games-simulation/gl117/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">gl-117</remote-id>
+ </upstream>
+</pkgmetadata>