summaryrefslogtreecommitdiff
path: root/games-rpg/sakura-spirit
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-07-10 23:40:16 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-07-10 23:40:16 +0100
commit51af5f0eb4cddbe6aa7953717873691d77aae9ff (patch)
tree1541525274162b033ebbc3ed38abaf335fbbd49a /games-rpg/sakura-spirit
parent7014a5a3ea0feffab9701fdd6b64cc7667a985af (diff)
gentoo resync : 11.07.2019
Diffstat (limited to 'games-rpg/sakura-spirit')
-rw-r--r--games-rpg/sakura-spirit/Manifest3
-rw-r--r--games-rpg/sakura-spirit/metadata.xml8
-rw-r--r--games-rpg/sakura-spirit/sakura-spirit-0.ebuild41
3 files changed, 52 insertions, 0 deletions
diff --git a/games-rpg/sakura-spirit/Manifest b/games-rpg/sakura-spirit/Manifest
new file mode 100644
index 000000000000..92461beb03e1
--- /dev/null
+++ b/games-rpg/sakura-spirit/Manifest
@@ -0,0 +1,3 @@
+DIST Sakura_Spirit-linux.tar 132434253 BLAKE2B a8ea7d111b755cdcf82ca8e4d8cd1c4a41aed661998f77eefd237f748c187e77f43de701f203a97ca24b98665a7a876c458f67646e8f100c014178d8adb58790 SHA512 94c42c7252fd871915ef89535d3d28321496f3e813fd71e9fa6bf3c264421b9c10c445dff1fef64f63d60255e89fb2c1085351c85d5c1279467134e5ef5e7011
+EBUILD sakura-spirit-0.ebuild 1020 BLAKE2B 940025cb640b49c7d02a06bdd3f22bf6048d41180e265e85dfd57f56ab984fc6f50261da0e3c257e03a8353d7946011df16fcdf2c4141353d0d2b0beab0fd0ee SHA512 e165beec63f7b96f7a72bd707ec4c8371ec128d62ef522c0e8f95cd3e74b6b04f38e91789b217a266ad33dedba563fa9b617c1d3081f88507ec69082ef1af975
+MISC metadata.xml 253 BLAKE2B 443ca9c8d4f6801169382e87a0ecd1385c56e65229209e7200f9d313ef380e92ae8d7dc3c38e5989a4166289f22607a20b1e13bb960fff6b3d9f78629d8ab020 SHA512 61c4689cbc649d84a00be211b7b5b98dd03e1d3f813eff370df549f2998cd4343f391c18b57cf20e4a8f4dd2311e3bfa04eb60f356f2bbac78f0b68f5091f254
diff --git a/games-rpg/sakura-spirit/metadata.xml b/games-rpg/sakura-spirit/metadata.xml
new file mode 100644
index 000000000000..26079e608bed
--- /dev/null
+++ b/games-rpg/sakura-spirit/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/games-rpg/sakura-spirit/sakura-spirit-0.ebuild b/games-rpg/sakura-spirit/sakura-spirit-0.ebuild
new file mode 100644
index 000000000000..2cc4e8c84edd
--- /dev/null
+++ b/games-rpg/sakura-spirit/sakura-spirit-0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop eutils xdg-utils
+
+RENPY_SLOT="6.99"
+MY_PN="Sakura Spirit"
+
+DESCRIPTION="Adult-themed visual novel and dating simulator set in Japan"
+HOMEPAGE="http://wingedcloud.com"
+SRC_URI="${MY_PN/ /_}-linux.tar"
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="bindist fetch"
+
+RDEPEND="games-engines/renpy:${RENPY_SLOT}"
+
+S="${WORKDIR}/${MY_PN/ /_}-linux"
+
+pkg_nofetch() {
+ einfo "If you have ${SRC_URI} as distributed by Humble Bundle then move"
+ einfo "it to your distfiles directory. If you have some other version then"
+ einfo "please contact the Gentoo Games team."
+}
+
+src_install() {
+ insinto /usr/share/${PN}
+ doins -r game/*
+
+ make_wrapper ${PN} "renpy-${RENPY_SLOT} '${EPREFIX}/usr/share/${PN}'"
+ make_desktop_entry ${PN} "${MY_PN}" applications-games
+
+ docinto html
+ dodoc README.html
+}
+
+pkg_postinst() { xdg_icon_cache_update; }
+pkg_postrm() { xdg_icon_cache_update; }